Announcement

Collapse
No announcement yet.

Upgraded from .103 to .118 - outputs inverted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by ozinnewy View Post
    I updated yesterday, spent hours changing the values of 1 and 0 to work with the relay boards i have. Today the arduino disconnected, and to my dismay it reset all of the devices. Is there some way I can update without it over writing my changes when the plugin crashes?
    The Device can not change with the board disconnect but the the update will do this as it has to add new devices to the plugin and update the Status Values on the output devices when creating them. I have no way of getting this info from homeseer to keep them inverted when I rebuild the devices so unfortunately this will happen the first time you run the update. After that the plugin looks to see if the new devices and will not change the devices if they exist.

    Greig.
    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


    • #17
      Thanks for the reply, I understand that they will change the first time after the update. However once I have updated the plugin, changed each device and the plugin crashes, when it restarts it changes the devices again. So does this mean I can not upgrade past ver 103?


      Sent from my iPad using Tapatalk

      Comment


      • #18
        Originally posted by ozinnewy View Post
        Thanks for the reply, I understand that they will change the first time after the update. However once I have updated the plugin, changed each device and the plugin crashes, when it restarts it changes the devices again. So does this mean I can not upgrade past ver 103?


        Sent from my iPad using Tapatalk
        No you should update to .127 and then the devices will change once and stay there.
        There was a bug that caused them to reset but this was fixed in .121. It checks that there are more that 3 status values in the device as there was only two in the old device and there are 5 in the new one so if you are removing all the other values it will reset them to. Just change the 1 and 0 values round.

        I have been thinking about how to invert the outputs easily but have not found an easy way yet!

        Greig.
        Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
        X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
        Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
        Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
        Scripts =
        Various

        Comment


        • #19
          Ok in V.128 there is an option to invert the outputs by auto changing the value status pairs. This is located on each output device configuration page under the Ardunio Tab and saves you changing the values manually.
          Attached Files
          Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
          X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
          Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
          Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
          Scripts =
          Various

          Comment


          • #20
            Originally posted by enigmatheatre View Post
            Ok in V.128 there is an option to invert the outputs by auto changing the value status pairs. This is located on each output device configuration page under the Ardunio Tab and saves you changing the values manually.
            This works well.

            Be advised that if you have assigned custom status graphics to output values, you will need to edit those because the values are inverted. If you leave it as standard (default) graphics, you do not need to change anything because those graphics are tied to the status text.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment

            Working...
            X