Announcement

Collapse
No announcement yet.

Stability issues in .18?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bbowser
    replied
    Of course keep me posted.

    Leave a comment:


  • mterry63
    replied
    Yeah, I'm stumped at this point. I've shutdown all the other plugins except this one to see how things go over the next day.

    Leave a comment:


  • bbowser
    replied
    I'm at a loss Martin. I have had it running on 2 machines for days. Not sure how many others are running the plugin but haven't heard anything in that respect. I checked it for memory leaks, all was good there. I'll look everything over again in the morning.
    Last edited by bbowser; March 12, 2016, 08:19 AM.

    Leave a comment:


  • mterry63
    replied
    I'm still having issues with keeping this plugin stable. Maybe the database got corrupt from the previous instability?

    I'm not seeing the errors I had yesterday, but every few hours I still get this error:

    Mar-11 2:04:45 PM Warning I/O interface GTS CPUXA is down, executable is not running, restarting ...

    And my HS3 machine locked up hard twice already in the past 24 hours. The last time the last thing in the log prior to the reboot was this:

    Mar-11 2:33:28 PM GTS CPUXA Error in FindDevice: Object reference not set to an instance of an object.

    Leave a comment:


  • mterry63
    replied
    Originally posted by bbowser View Post
    Martin,
    Thanks... For the update.

    There will be an update on Saturday 3/12/16 around 10:00 am

    The update better handles the Ocelot coughing on startup. Plus the addition of X10 actions and the ability to swap back and forth from Lamp Mod and Lamp Mod Ext without recreating devices.

    I will post a sticky here when I have it in the updater.

    Bruce
    Thanks Bruce, sounds like great updates.

    Leave a comment:


  • bbowser
    replied
    Martin,
    Thanks... For the update.

    There will be an update on Saturday 3/12/16 around 10:00 am

    The update better handles the Ocelot coughing on startup. Plus the addition of X10 actions and the ability to swap back and forth from Lamp Mod and Lamp Mod Ext without recreating devices.

    I will post a sticky here when I have it in the updater.

    Bruce

    Leave a comment:


  • mterry63
    replied
    Bruce,

    Just to give you an update, I've moved the Ocelot and plugin to another serial port and all those errors have disappeared. Seems like I have a hardware issue with the serial port or cable.

    Sorry for any false alarms. Certainly will make my wife happier. I'll let things cook for a day before I take any other action.

    Leave a comment:


  • bbowser
    replied
    Martin,

    The only thing that was changed in the latest version was removing the one custom object I had in the device PED. No other changes were made and I don't think that would cause what you are seeing.

    There is a checkbox for Log Checksum Errors and Serial Timeouts, check that and see if you are getting coms errors.
    Last edited by bbowser; March 11, 2016, 08:56 AM.

    Leave a comment:


  • mterry63
    replied
    I started seeing this issue shortly after installing the new version. I only had a couple of X10 devices on the old version in test. After installing the new version, I moved all my X10 devices to this plugin and deleted the HS3 X10 plugin that I was using. Problems ensued right after. Plugin crashing, and the errors messages show below.

    In the logs below, error messages started 5 minutes after the plugin initialized.

    I'm running maybe 20 events with X10 devices. Mostly turn devices on/off, with maybe 3 events that are X10 triggered.

    I have types of Lamp Module, Lamp Module extended, and Appliance Modules.

    I just moved to a new serial port (USB) and restarted the server and plugin on the new serial port. I clicked the check devices button and got this in the log:

    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:SECU16 Unit_No:1 Point:3 IO_Type:Input Zone:N/A X10 Type:N/A
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:SECU16 Unit_No:1 Point:2 IO_Type:Input Zone:N/A X10 Type:N/A
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:41 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module Ext
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Appliance Module
    Mar-10 1:47:40 PM GTS CPUXA Unit_type:X10 Unit_No:0 Point:0 IO_Type:N/A Zone:N/A X10 Type:Lamp Module
    Mar-10 1:47:40 PM GTS CPUXA Testing Plug-in Extra Data for all devices

    Other plugins:
    BL Backup
    BLRF
    BLRFid
    Harmony Hub
    Napco Gemini
    Omnistat 3
    Random
    Z-Wave

    I'll see how things go with this change.

    Is there a debug mode for the plugin?

    Leave a comment:


  • bbowser
    replied
    Martin,

    Wow... that is very strange. I've had it running for days with no issues.


    What exactly are you doing with the plug-in? Device types? Events?
    What other plug-ins do you have running?

    What version of HS3?

    Let's see if I can reproduce this.

    Leave a comment:


  • mterry63
    started a topic Stability issues in .18?

    Stability issues in .18?

    Bruce,

    I seem to have terrible stability issues with the plugin, perhaps after moving to the newest version? I was only running it for a day or so prior to that version so I can't say for sure.

    Here' are all the messages I've gotten since restarting the plugin after 1:00 am. Is there some kind of debugging I can do?

    One thing I plan to do quickly is move to a new physical serial port to see if I have some hardware issue that might have started coincidentally.



    Mar-10 1:28:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:25:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:21:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:18:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:14:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:11:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:07:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:04:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 1:00:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:57:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:53:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:50:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:46:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:43:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:39:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:36:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:32:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:29:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:25:38 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Mar-10 12:22:08 PM Warning Plugin GTS CPUXA is not responding but it is still running, not restarting yet.
    Last edited by mterry63; March 10, 2016, 05:49 PM.
Working...
X