Announcement

Collapse
No announcement yet.

Help with RPI disconnecting and reconnecting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with RPI disconnecting and reconnecting

    im trying to get my Raspberry Pie 3 to remotely connect to my Windows 7 Hs3 PC.It seem to connect then disconnects straight away.Here is the rpi3 errors. Can anyone help.
    System.NullReferenceException: Object reference not set to an instance of an object
    at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
    at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73a9b908 + 0x0025b> in <filename unknown>:0
    Connection lost, exiting
    Waiting 30 seconds before trying to reconnect
    Connecting to server at 192.168.0.7...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    Jan-22 15:12:24 INFO RaspberryIO version 3.0.0.5
    Jan-22 15:12:29 INFO Raspberry Pi running on Bcm2709 processor
    Jan-22 15:12:29 INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
    Jan-22 15:12:29 INFO Serial number: 00000000cebb8b7e
    Disconnected from server - client
    Jan-22 15:12:29 ERROR CreateHSDevices: Object reference not set to an instance of an object
    System.NullReferenceException: Object reference not set to an instance of an object
    at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
    at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73a9b908 + 0x0025b> in <filename unknown>:0
    Jan-22 15:12:29 ERROR System.NullReferenceException: Object reference not set to an instance of an object
    at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetINISection (string,string)
    at HSPI_RaspberryIO.RaspberryPiApp.ReadPinsConfigFromIni () <0x7341ef98 + 0x00067> in <filename unknown>:0
    System.NullReferenceException: Object reference not set to an instance of an object
    at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
    at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73a9b908 + 0x0025b> in <filename unknown>:0
    Jan-22 15:12:29 INFO Shutting Down plug-in
    System.NullReferenceException: Object reference not set to an instance of an object
    at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
    at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73a9b908 + 0x0025b> in <filename unknown>:0
    Connection lost, exiting
    Waiting 30 seconds before trying to reconnect

    Thanks Nick.

  • #2
    what is the version of mono installed on your RPi?
    what is the version of HS3?
    how do you start the plugin on your RPi?

    to troubleshoot, try to disable any firewall and AV on your HS3 machine.

    Comment


    • #3
      RPI

      Hi Spud,
      Thanks for the quick reply.

      Homeseer is v 3.0.0.27
      Mono is v 4.2.3

      I ran it with: sudo ./run.sh

      An instance of testremote is showing up as a remote plugin, however comes and goes when refreshed.
      Nick

      Comment


      • #4
        Originally posted by nickclift View Post
        Homeseer is v 3.0.0.27
        is it a typo?
        3.0.0.27 is very very old, probably doesn't work well with this plugin...

        Comment


        • #5
          Hi Spud,
          Thanks for the help so far. Just trying to get this working before i purchase. Here is some more info.
          HS3Pro was a newer version:

          System Information
          Current Date/Time: 25/01/2017 5:09:48 PM AUS Eastern Daylight Time
          HomeSeer Version: HS3 Pro Edition 3.0.0.297 (Windows)
          HomeSeer: Is Registered
          Operating System: Microsoft Windows 7 Professional - Work Station
          OS Version: 6.1.7601 Service Pack: 1.0
          System Uptime: 0 Days 0 Hours 39 Minutes 28 Seconds
          User Name and Access Level: default (Admin)
          LAN IP Address: 192.168.0.7 (HOMESEER3)
          Client IP Address: 192.168.0.7 (HOMESEER3.telstra.com.au)
          External IP Address: 120.147.143.20 (CPE-120-147-143-20.gdfw2.lon.bigpond.net.au)
          Network Adapter: Adapter -> Intel(R) 82579LM Gigabit Network Connection IP: 192.168.0.7/24 MAC: E8:39:35:60:1B:E9
          Network Adapter: HomeSeer Adapter -> Loopback Address (localhost) IP: 127.0.0.1
          Web Server Port: 80
          Number of Devices: 59
          Number of Events: 1
          Event Last Ran: Backyard : Pergola Leds Table, Ran at 14/01/2017 8:13:46 PM
          Number of unique event scripts used: 0
          Connected Speaker Clients: HOMESEER3 (127.0.0.1)EFAULT
          Plug-Ins Enabled: HSTouch Server:,Applied Digital Ocelot:,Current Cost:
          Processor Type and Speed: Intel64 Family 6 Model 42 Stepping 7 at 2.89 GHz
          Modules/Threads: 122 Modules, 62 Threads
          Available Threads: 400
          System Processes/Load: 86 Processes, 31% Load
          Free / Total Physical Memory: 1.72 GBytes / 3.96 GBytes (43% free)
          Free / Total Virtual Memory: 5.00 GBytes / 7.92 GBytes (63% free)
          HomeSeer Memory Used: 74 Mbytes
          Plug-In Memory Used: 3 EXE Plug-Ins using 113 Mbytes

          HS3 Log:

          Jan-25 5:17:45 PM Info Plugin RaspberryIO with instance: TestRemote has disconnected
          Jan-25 5:17:45 PM RaspberryIO INFO Serial number: 00000000cebb8b7e
          Jan-25 5:17:45 PM RaspberryIO INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
          Jan-25 5:17:45 PM RaspberryIO INFO Raspberry Pi running on Bcm2709 processor
          Jan-25 5:17:40 PM RaspberryIO INFO RaspberryIO version 3.0.0.5
          Jan-25 5:17:40 PM Info Plugin RaspberryIO with instance TestRemote has connected. IP:192.168.0.24:41978
          Jan-25 5:17:08 PM Info Plugin RaspberryIO with instance: TestRemote has disconnected
          Jan-25 5:17:08 PM RaspberryIO INFO Serial number: 00000000cebb8b7e
          Jan-25 5:17:08 PM RaspberryIO INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
          Jan-25 5:17:08 PM RaspberryIO INFO Raspberry Pi running on Bcm2709 processor
          Jan-25 5:17:03 PM RaspberryIO INFO RaspberryIO version 3.0.0.5
          Jan-25 5:17:03 PM Info Plugin RaspberryIO with instance TestRemote has connected. IP:192.168.0.24:41974
          Jan-25 5:16:31 PM Info Plugin RaspberryIO with instance: TestRemote has disconnected
          Jan-25 5:16:31 PM RaspberryIO INFO Serial number: 00000000cebb8b7e
          Jan-25 5:16:31 PM RaspberryIO INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
          Jan-25 5:16:31 PM RaspberryIO INFO Raspberry Pi running on Bcm2709 processor
          Jan-25 5:16:25 PM RaspberryIO INFO RaspberryIO version 3.0.0.5
          Jan-25 5:16:25 PM Info Plugin RaspberryIO with instance TestRemote has connected. IP:192.168.0.24:41970
          Jan-25 5:15:53 PM Info Plugin RaspberryIO with instance: TestRemote has disconnected
          Jan-25 5:15:53 PM RaspberryIO INFO Serial number: 00000000cebb8b7e
          Jan-25 5:15:53 PM RaspberryIO INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
          Jan-25 5:15:53 PM RaspberryIO INFO Raspberry Pi running on Bcm2709 processor
          Jan-25 5:15:48 PM RaspberryIO INFO RaspberryIO version 3.0.0.5
          Jan-25 5:15:48 PM Info Plugin RaspberryIO with instance TestRemote has connected. IP:192.168.0.24:41964
          Jan-25 5:15:16 PM Info Plugin RaspberryIO with instance: TestRemote has disconnected
          Jan-25 5:15:16 PM RaspberryIO INFO Serial number: 00000000cebb8b7e
          Jan-25 5:15:16 PM RaspberryIO INFO Fir

          Widows Firewall and Antivirus software have been disabled.
          Anymore trouble shooting ideas?
          Thanks Nick.
          Last edited by nickclift; January 25th, 2017, 05:43 PM.

          Comment


          • #6
            have you disabled firewall and antivirus on your HS3 machine and RPi?

            you can try to copy the following dlls from your HS3 machine to your RPi (overwrite the ones you unzziped previously)
            HomeSeerAPI.dll
            HSCF.dll
            Scheduler.dll

            Comment


            • #7
              Still No Luck

              Still trying to get this plugin working. Homeseer can see the pi via the remote plugin.IT says ok and has the correct ip address. The pi is connecting to homeseer however it then disconnects and throws the following error. Firewall and av software is disabled on homeseer.
              Can anyone help??

              Jan-30 06:54:14 INFO Serial number: 00000000cebb8b7e
              Disconnected from server - client
              Jan-30 06:54:14 ERROR CreateHSDevices: Object reference not set to an instance of an object
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:14 DEBUG Stack: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetDeviceEnumerator ()
              at HSPI_RaspberryIO.RaspberryPiApp.CreateHSDevices () <0x724aa9c8 + 0x00043> in <filename unknown>:0
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:14 ERROR System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetINISection (string,string)
              at HSPI_RaspberryIO.RaspberryPiApp.ReadPinsConfigFromIni () <0x724ad388 + 0x00067> in <filename unknown>:0
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:14 INFO Shutting Down plug-in
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Connection lost, exiting
              Waiting 30 seconds before trying to reconnect
              Connecting to server at 192.168.0.7...
              Connection attempt #1
              Connected (HomeSeer API 3). Waiting to be initialized...
              Jan-30 06:54:47 INFO RaspberryIO version 3.0.0.5
              Jan-30 06:54:52 INFO Raspberry Pi running on Bcm2709 processor
              Jan-30 06:54:52 INFO Firmware rev10625154, board model B3 (Raspberry Pi 3 Model B)
              Jan-30 06:54:52 INFO Serial number: 00000000cebb8b7e
              Disconnected from server - client
              Jan-30 06:54:52 ERROR CreateHSDevices: Object reference not set to an instance of an object
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:52 DEBUG Stack: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetDeviceEnumerator ()
              at HSPI_RaspberryIO.RaspberryPiApp.CreateHSDevices () <0x724aa9c8 + 0x00043> in <filename unknown>:0
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:52 ERROR System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:GetINISection (string,string)
              at HSPI_RaspberryIO.RaspberryPiApp.ReadPinsConfigFromIni () <0x724ad388 + 0x00067> in <filename unknown>:0
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Jan-30 06:54:52 INFO Shutting Down plug-in
              System.NullReferenceException: Object reference not set to an instance of an object
              at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
              at (wrapper remoting-invoke) HomeSeerAPI.IHSApplication:WriteLog (string,string)
              at HSPI_RaspberryIO.Logger.Log (System.String line, ELogLevel level) <0x73ae53b0 + 0x0025b> in <filename unknown>:0
              Connection lost, exiting
              Waiting 30 seconds before trying to reconnect


              I know sfa about rasbian/linux so im gathering something is going wrong with the RaspberryIO installation on the pi.

              Comment


              • #8
                Raspberry Pi and HS3 on Windows, help on error message in RPi and disconnection

                Hi,

                I am having trouble getting this plugin to work. This thread seems simular to my problem, and I have tryed everything suggested here.
                Not helping unfortunately.
                I can see that the RPi is connecting to the HS3, but gives an error messages and disconnectes.
                I have done the installation of both Mono and the plugin to the letter of the descriptions in the message board.

                Any suggestiones anyone?

                Homeseer is HS3 Pro Edition 3.0.0.318 (Windows)
                Mono is v 4.2.3
                Started with: sudo ./run.sh

                The logs:

                Homeseer log:

                May-08 11:38:53 Info Plugin RaspberryIO with instance: HomeseerPi01 has disconnected
                May-08 11:38:53 RaspberryIO INFO Serial number: 000000006087bb79
                May-08 11:38:53 RaspberryIO INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                May-08 11:38:53 RaspberryIO INFO Raspberry Pi running on Unknown processor
                May-08 11:38:47 RaspberryIO INFO RaspberryIO version 3.0.0.7
                May-08 11:38:47 Info Plugin RaspberryIO with instance HomeseerPi01 has connected. IP:192.168.0.183:38608
                May-08 11:38:46 RaspberryIO ERROR System is not a Raspberry Pi
                May-08 11:38:42 Plug-In Finished initializing plug-in RaspberryIO
                May-08 11:38:41 RaspberryIO INFO RaspberryIO version 3.0.0.7
                May-08 11:38:41 Info Plugin RaspberryIO has connected. IP:127.0.0.1:52191
                May-08 11:38:35 Info Plugin RaspberryIO with instance: has disconnected
                May-08 11:38:35 RaspberryIO INFO Shutting Down plug-in
                May-08 11:38:35 Plug-In Shutting down Plug-In: RaspberryIO
                May-08 11:37:34 Info Plugin RaspberryIO with instance: HomeseerPi01 has disconnected
                May-08 11:37:34 RaspberryIO INFO Serial number: 000000006087bb79
                May-08 11:37:34 RaspberryIO INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                May-08 11:37:34 RaspberryIO INFO Raspberry Pi running on Unknown processor
                May-08 11:37:29 RaspberryIO INFO RaspberryIO version 3.0.0.7
                May-08 11:37:28 Info Plugin RaspberryIO with instance HomeseerPi01 has connected. IP:192.168.0.183:38602


                Raspberry pi error message:

                pi@homeseerPi01:~/RaspberryIO $ sudo ./run.sh
                Plugin: RaspberryIO Instance: HomeseerPi01 starting...
                Connecting to server at 192.168.0.11...
                Connection attempt #1
                Connected (HomeSeer API 3). Waiting to be initialized...
                May-08 11:38:47 INFO RaspberryIO version 3.0.0.7
                May-08 11:38:52 INFO Raspberry Pi running on Unknown processor
                May-08 11:38:52 INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                May-08 11:38:52 INFO Serial number: 000000006087bb79

                Unhandled Exception:
                System.NullReferenceException: Object reference not set to an instance of an object
                at Raspberry.IO.GeneralPurpose.GpioConnection.CheckInputPins () <0x7342e848 + 0x00054> in <filename unknown>:0
                at Raspberry.Timers.StandardTimer.OnElapsed (System.Object state) <0x7342e388 + 0x000b3> in <filename unknown>:0
                at System.Threading.Timer+Scheduler.TimerCB (System.Object o) <0x74e498c8 + 0x001af> in <filename unknown>:0
                at System.Threading.QueueUserWorkItemCallback.System.Threading. IThreadPoolWorkItem.ExecuteWorkItem () <0x74c75e04 + 0x00037> in <filename unknown>:0
                at System.Threading.ThreadPoolWorkQueue.Dispatch () <0x74c74314 + 0x00223> in <filename unknown>:0
                at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback () <0x74c75c78 + 0x0000b> in <filename unknown>:0
                pi@homeseerPi01:~/RaspberryIO $


                Comment


                • #9
                  Originally posted by TinkerThor View Post
                  Hi,

                  I am having trouble getting this plugin to work. This thread seems simular to my problem, and I have tryed everything suggested here.
                  Not helping unfortunately.
                  I can see that the RPi is connecting to the HS3, but gives an error messages and disconnectes.
                  I have done the installation of both Mono and the plugin to the letter of the descriptions in the message board.

                  Any suggestiones anyone?

                  Homeseer is HS3 Pro Edition 3.0.0.318 (Windows)
                  Mono is v 4.2.3
                  Started with: sudo ./run.sh

                  The logs:

                  Homeseer log:

                  May-08 11:38:53 Info Plugin RaspberryIO with instance: HomeseerPi01 has disconnected
                  May-08 11:38:53 RaspberryIO INFO Serial number: 000000006087bb79
                  May-08 11:38:53 RaspberryIO INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                  May-08 11:38:53 RaspberryIO INFO Raspberry Pi running on Unknown processor
                  May-08 11:38:47 RaspberryIO INFO RaspberryIO version 3.0.0.7
                  May-08 11:38:47 Info Plugin RaspberryIO with instance HomeseerPi01 has connected. IP:192.168.0.183:38608
                  May-08 11:38:46 RaspberryIO ERROR System is not a Raspberry Pi
                  May-08 11:38:42 Plug-In Finished initializing plug-in RaspberryIO
                  May-08 11:38:41 RaspberryIO INFO RaspberryIO version 3.0.0.7
                  May-08 11:38:41 Info Plugin RaspberryIO has connected. IP:127.0.0.1:52191
                  May-08 11:38:35 Info Plugin RaspberryIO with instance: has disconnected
                  May-08 11:38:35 RaspberryIO INFO Shutting Down plug-in
                  May-08 11:38:35 Plug-In Shutting down Plug-In: RaspberryIO
                  May-08 11:37:34 Info Plugin RaspberryIO with instance: HomeseerPi01 has disconnected
                  May-08 11:37:34 RaspberryIO INFO Serial number: 000000006087bb79
                  May-08 11:37:34 RaspberryIO INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                  May-08 11:37:34 RaspberryIO INFO Raspberry Pi running on Unknown processor
                  May-08 11:37:29 RaspberryIO INFO RaspberryIO version 3.0.0.7
                  May-08 11:37:28 Info Plugin RaspberryIO with instance HomeseerPi01 has connected. IP:192.168.0.183:38602


                  Raspberry pi error message:

                  pi@homeseerPi01:~/RaspberryIO $ sudo ./run.sh
                  Plugin: RaspberryIO Instance: HomeseerPi01 starting...
                  Connecting to server at 192.168.0.11...
                  Connection attempt #1
                  Connected (HomeSeer API 3). Waiting to be initialized...
                  May-08 11:38:47 INFO RaspberryIO version 3.0.0.7
                  May-08 11:38:52 INFO Raspberry Pi running on Unknown processor
                  May-08 11:38:52 INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
                  May-08 11:38:52 INFO Serial number: 000000006087bb79

                  Unhandled Exception:
                  System.NullReferenceException: Object reference not set to an instance of an object
                  at Raspberry.IO.GeneralPurpose.GpioConnection.CheckInputPins () <0x7342e848 + 0x00054> in <filename unknown>:0
                  at Raspberry.Timers.StandardTimer.OnElapsed (System.Object state) <0x7342e388 + 0x000b3> in <filename unknown>:0
                  at System.Threading.Timer+Scheduler.TimerCB (System.Object o) <0x74e498c8 + 0x001af> in <filename unknown>:0
                  at System.Threading.QueueUserWorkItemCallback.System.Threading. IThreadPoolWorkItem.ExecuteWorkItem () <0x74c75e04 + 0x00037> in <filename unknown>:0
                  at System.Threading.ThreadPoolWorkQueue.Dispatch () <0x74c74314 + 0x00223> in <filename unknown>:0
                  at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback () <0x74c75c78 + 0x0000b> in <filename unknown>:0
                  pi@homeseerPi01:~/RaspberryIO $


                  I think the bug you are experiencing is the same problem as https://forums.homeseer.com/showthread.php?p=1305422

                  I'm working on it.

                  Could you post the output of the following command, so that I can confirm:
                  Code:
                  more /proc/cpuinfo
                  thanks

                  Comment


                  • #10
                    Follow up

                    Ok, I will follow the progress on that thread.
                    Thanks!

                    The output of the command is:

                    pi@homeseerPi01:~/RaspberryIO $ more /proc/cpuinfo
                    processor : 0
                    model name : ARMv7 Processor rev 5 (v7l)
                    BogoMIPS : 38.40
                    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idiv
                    t vfpd32 lpae evtstrm
                    CPU implementer : 0x41
                    CPU architecture: 7
                    CPU variant : 0x0
                    CPU part : 0xc07
                    CPU revision : 5

                    processor : 1
                    model name : ARMv7 Processor rev 5 (v7l)
                    BogoMIPS : 38.40
                    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idiv
                    t vfpd32 lpae evtstrm
                    CPU implementer : 0x41
                    CPU architecture: 7
                    CPU variant : 0x0
                    CPU part : 0xc07
                    CPU revision : 5

                    processor : 2
                    model name : ARMv7 Processor rev 5 (v7l)
                    BogoMIPS : 38.40
                    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idiv
                    t vfpd32 lpae evtstrm
                    CPU implementer : 0x41
                    CPU architecture: 7
                    CPU variant : 0x0
                    CPU part : 0xc07
                    CPU revision : 5

                    processor : 3
                    model name : ARMv7 Processor rev 5 (v7l)
                    BogoMIPS : 38.40
                    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idiv
                    t vfpd32 lpae evtstrm
                    CPU implementer : 0x41
                    CPU architecture: 7
                    CPU variant : 0x0
                    CPU part : 0xc07
                    CPU revision : 5

                    Hardware : BCM2835
                    Revision : a01041
                    Serial : 000000006087bb79
                    pi@homeseerPi01:~/RaspberryIO $

                    Comment

                    Working...
                    X