Announcement

Collapse
No announcement yet.

ERROR System is not a Raspberry Pi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TinkerThor
    replied
    Result of v. 3.0.0.8

    On the RPi side it seems much better:

    pi@homeseerPi01:~/RaspberryIO $ sudo ./run.sh
    Plugin: RaspberryIO Instance: HomeseerPi01 starting...
    Connecting to server at 192.168.0.11...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    May-09 15:20:22 INFO RaspberryIO version 3.0.0.8
    May-09 15:20:27 INFO Raspberry Pi running on Bcm2835 processor
    May-09 15:20:27 INFO Firmware rev10489921, board model B2 (Raspberry Pi 2 Model B)
    May-09 15:20:27 INFO Serial number: 000000006087bb79


    It's running and is stays connected to HS3.

    On the HS3 side, there is nothing appearing under Remote Plugins.
    It is possible to set the pin settings via the Plugins settings in the dropdown menu. Plugins - RaspberryIO and Config - HomeseerPi01. (My RPi is called HomeseerPi01).
    Under device management, the port I set up above is visible, but the name is unknown and there is no controls available to turn the pin on/of. The status is "no status".

    So, it seems fixed on the RPI side. I can see that the CPU is correctly reported now

    Leave a comment:


  • spud
    replied
    please test version 3.0.0.8 and let me know:

    https://www.dropbox.com/s/f4se1xshm7...ll_3-0-0-8.zip

    Leave a comment:


  • spud
    replied
    Actually, I think there is still a problem with version 3.0.0.7

    It looks like, recent Linux kernels have changed the way the RPi processor is reported. The underlying libraries that the plug-in uses need to be updated accordingly.
    I'm working on it, thanks for your patience

    Leave a comment:


  • spud
    replied
    I believe I have fixed the "System is not a RaspberryPi" error in version 3.0.0.7

    remote install package is available here: https://www.dropbox.com/s/dptjntnqch...0-0-7.zip?dl=0

    and the regular package is available from the Beta Testing thread

    Leave a comment:


  • chrisj
    replied
    cpuinfo output

    pi@raspi:~ $ more /proc/cpuinfo
    processor : 0
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
    vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 1
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
    vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 2
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
    vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    processor : 3
    model name : ARMv7 Processor rev 4 (v7l)
    BogoMIPS : 38.40
    Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
    vfpd32 lpae evtstrm crc32
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xd03
    CPU revision : 4

    Hardware : BCM2835
    Revision : a02082
    Serial : 00000000a6e7f141
    pi@raspi:~ $

    Leave a comment:


  • spud
    replied
    could you run the following command and post the output here:

    Code:
    more /proc/cpuinfo

    Leave a comment:


  • chrisj
    replied
    Exact Same Issue

    Getting this on remote Pi. I have Pi 3 Model B.

    root@raspi:/opt/RaspberryIO# ./run.sh
    Plugin: RaspberryIO Instance: raspi starting...
    Connecting to server at 192.168.199.110...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    May-06 18:13:37 INFO RaspberryIO version 3.0.0.5
    May-06 18:13:42 ERROR System is not a Raspberry Pi
    May-06 18:14:44 ERROR while creating device Raspberry Pi 3 Model B: Object reference not set to an instance of an object
    May-06 18:14:44 DEBUG Stack: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplicationeviceProperty_PlugData (int,HomeSeerAPI.Enums/eDeviceProperty,HomeSeerAPI.PlugExtraData/clsPlugExtraData)
    at Scheduler.Classes.DeviceClass.set_PlugExtraData_Set (HomeSeerAPI.IHSApplication hs, HomeSeerAPI.PlugExtraData+clsPlugExtraData value) [0x00013] in <0387f935cbb2430490cd0b7ee8040363>:0
    at HSPI_RaspberryIO.RaspberryPiApp.SetDeviceID (Scheduler.Classes.DeviceClass dev, System.String id) [0x00023] in <50d9361634d6430f9107f62c4a42b260>:0
    at HSPI_RaspberryIO.RaspberryPiApp.CreateDevice (System.String deviceName, System.String deviceID, System.Boolean showValues, System.Boolean root) [0x00039] in <50d9361634d6430f9107f62c4a42b260>:0
    May-06 18:14:44 DEBUG Setting direction to Output for Pin2
    May-06 18:15:45 ERROR while creating device GPIO 2: Object reference not set to an instance of an object
    May-06 18:15:45 DEBUG Stack: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr)
    at (wrapper remoting-invoke) HomeSeerAPI.IHSApplicationeviceProperty_PlugData (int,HomeSeerAPI.Enums/eDeviceProperty,HomeSeerAPI.PlugExtraData/clsPlugExtraData)
    at Scheduler.Classes.DeviceClass.set_PlugExtraData_Set (HomeSeerAPI.IHSApplication hs, HomeSeerAPI.PlugExtraData+clsPlugExtraData value) [0x00013] in <0387f935cbb2430490cd0b7ee8040363>:0
    at HSPI_RaspberryIO.RaspberryPiApp.SetDeviceID (Scheduler.Classes.DeviceClass dev, System.String id) [0x00023] in <50d9361634d6430f9107f62c4a42b260>:0
    at HSPI_RaspberryIO.RaspberryPiApp.CreateDevice (System.String deviceName, System.String deviceID, System.Boolean showValues, System.Boolean root) [0x00039] in <50d9361634d6430f9107f62c4a42b260>:0
    May-06 18:15:45 DEBUG Setting Reversed flag to False for Pin2
    May-06 18:15:45 DEBUG Setting direction to Input for Pin03

    Leave a comment:


  • spud
    replied
    Here it is:
    https://www.dropbox.com/s/7spvkqbtj9...ll_3-0-0-5.zip

    but I doubt this would change anything for your problem
    what model of RPi is it?

    Leave a comment:


  • mihaium
    replied
    Hey Spud.

    Is possible send me one address for download the RaspberryIO_remote_install_3-0-0-5.zip ?

    Thanks

    Leave a comment:


  • mihaium
    started a topic ERROR System is not a Raspberry Pi

    ERROR System is not a Raspberry Pi

    Hello.
    I have 4 Raspberry pi IO and 3 work verry well.
    But with 1 i have this error : "ERROR System is not a Raspberry Pi" after update to RaspberryIO_remote_3-0-0-6

    Is possibile help me?

    Thanks
    Attached Files
Working...
X