Announcement

Collapse
No announcement yet.

Config Page for multiple Remote Instances

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Config Page for multiple Remote Instances

    I've got a couple of pi's running this plugin, but only the latest to connect shows in the plugin management dropdown menu. I have root devices for all 3 pi's. At some point yesterday I think I was able to get to the page for the 2 pi's that are missing by changing the instance name in the url, but today that's not working. Am I doing something wrong here?

    Bonus question (feature request really) - Is it possible in a future revision to get the root device to show connectivity status so I can alarm on lost connectivity?
    Attached Files

  • #2
    Tried again this morning after updated the remote plugin files on RPI3-1 to 3.0.0.8 (from 3.0.0.6). RPI3-1 is still the only one that shows in the plugins dropdown menu, but now I'm able to get to the RPIZW-1 config by changing the instance name in the URL for the RPI3-1 config page. When I do the same for RPIZW-2, I get this error: "Error finding plugin in GenPage: Object reference not set to an instance of an object."

    Thoughts?

    Comment


    • #3
      Here's the log excerpt when the RPIZW's connect.

      Code:
      Jul-10 8:48:07 AM	 	RaspberryIO	INFO Serial number: 00000000e12a3ffc
      Jul-10 8:48:07 AM	 	RaspberryIO	INFO Firmware rev9437377, board model Unknown (Unknown)
      Jul-10 8:48:07 AM	 	RaspberryIO	INFO Raspberry Pi running on Bcm2835 processor
      Jul-10 8:48:00 AM	 	RaspberryIO	INFO RaspberryIO version 3.0.0.8
      Jul-10 8:47:59 AM	 	Info		Plugin RaspberryIO with instance RPIZW-2 has connected. IP:192.168.0.37:45362
      Jul-10 8:47:45 AM	 	RaspberryIO	INFO Serial number: 0000000019041a7f
      Jul-10 8:47:45 AM	 	RaspberryIO	INFO Firmware rev9437377, board model Unknown (Unknown)
      Jul-10 8:47:45 AM	 	RaspberryIO	INFO Raspberry Pi running on Bcm2835 processor
      Jul-10 8:47:38 AM	 	RaspberryIO	INFO RaspberryIO version 3.0.0.8
      Jul-10 8:47:36 AM	 	Info		Plugin RaspberryIO with instance RPIZW-1 has connected. IP:192.168.0.36:56648

      Comment


      • #4
        Ok, after rebooting both RPIZW's, the plugin dropdown menu shows both RPIZW-1 & RPIZW-2, but not RPI3-1. Though I can get to the RPI3-1 config page by change the instance name in the URL.

        Comment


        • #5
          this is a known bug in HS3 that I have been reporting multiple times to HST. Basically when one instance disconnects, HS3 removes the links for all instances.

          That being said, you should always be able to access it by changing the URL, not sure why it fails for one of your instance.

          Comment


          • #6
            I can get to all 3 config pages at the moment. As long as that holds true in the future, I can live with the HST bug. I know how responsive they are about fixing those...

            Comment

            Working...
            X