Announcement

Collapse
No announcement yet.

Raspberry Remote IO

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspberry Remote IO

    Hello,
    I am running jessie on a rapberry pi 3 and have installed the HS3 raspberry IO plugin on it. The homeseer server "sees" it as a remote plugin. However, it says "No license or Trial Expired". I purchased the license, and the register button for enabling it on the REMOTE plugin won't take it. "doesn't match product". Even though the plugin says "OK" and gives the proper IP address of the remote Pi. However, it does work to license on the raspberry pi that is the homeseer server. I have that disabled as I am not using the IO port on the server, just the remote Pi. I cannot configure devices on the remote pi due to the license issue (I suspect). I am also getting the message "System is not a Raspberry Pi" on the remote pi. I am running HS3 3.0.0.297 and Pi plugin version 3.0.0.5. How can I enable the licensing on the remote Pi now that I have purchased it for $29.95?
    Thanks,
    David

  • #2
    Remote pi 3.0.0.8

    Can someone tell me where the 3.0.0.8 version of the remote Pi plugin is located?
    Turns out that the remote Pi plugin only shows up on the Manage-> Plugins screen if I have the Pi plugin disabled on the Pi server. This would be bad if I was using the IO ports on the server as well.
    David

    Comment


    • #3
      I updated the remote Pi software from 3.0.0.5 to 3.0.0.8. Now I get a listing of the pins in the plugin configuration for the remote PI, and I no longer get the "This is not a Raspberry Pi" message.
      David

      Comment


      • #4
        You don't have to use the register button on the remote instance lines, once you have registered it for the local instance, it should be licensed for any instance (remote or local) and even if you don't use the local instance.

        Let me know if you have any other problem?

        Also I would update to version 3.0.0.9 which fixed a bug for RPi3:
        https://forums.homeseer.com/showthread.php?t=183857

        Comment


        • #5
          Thanks, I will look for the 3.0.0.9 upgrade.

          Just an update from the last post, while I was able to get the Remote Pi plugin to register and not give the error message, none of the functionality actually works. I set some pins as input and some as output, and I never get any states changing.

          Interestingly, I have a Jessie kernal version 4.4.x running the 3.0.0.5 version of the Pi remote plugin and it works perfectly. The Jessie kernal that I am running now is 4.7.x
          David

          Comment


          • #6
            Spud,
            The link that you provided appears to be the Raspberry Pi software for the HS3 Seer server (also a Pi). What about the software for the remote Pi? What version should I be running on that?
            Thanks,
            David

            Comment


            • #7
              Originally posted by dsieg61 View Post
              Spud,
              The link that you provided appears to be the Raspberry Pi software for the HS3 Seer server (also a Pi). What about the software for the remote Pi? What version should I be running on that?
              Thanks,
              David
              same version 3.0.0.9
              you can find a link for remote install of the 3.0.0.9 version in the user guide: https://forums.homeseer.com/showthread.php?t=183913

              Comment


              • #8
                Thanks, appears to be working properly now.
                David

                Comment


                • #9
                  Error Running Remote PI run.sh

                  I'm new with RaspberryPI's and the ZeeTroller S2 that I recently purchased.

                  I downloaded and installed your plugin on the Zee Troller. I didn't "enable' the plugin as I want to run it remotely on another RaspberryPI.

                  I am getting the error shown in the 'instance' of the plugin is showing that it is unlicensed. I tried clicking on the 'Register Online' and entered by license and password, but that didn't work.

                  Thanks,

                  BSR
                  Attached Files
                  Last edited by BraveSirRobbin; December 24th, 2017, 11:55 PM.
                  --------------------------------------------------
                  **** Do You "Cocoon"? ****

                  Comment


                  • #10
                    Originally posted by BraveSirRobbin View Post
                    I'm new with RaspberryPI's and the ZeeTroller S2 that I recently purchased.

                    I downloaded and installed your plugin on the Zee Troller. I didn't "enable' the plugin as I want to run it remotely on another RaspberryPI.

                    I am getting the error shown in the 'instance' of the plugin is showing that it is unlicensed. I tried clicking on the 'Register Online' and entered by license and password, but that didn't work.

                    Thanks,

                    BSR
                    You can just ignore the trial message, even if it says "trial" it will work after 30 days.

                    Comment


                    • #11
                      Originally posted by spud View Post
                      You can just ignore the trial message, even if it says "trial" it will work after 30 days.
                      Ah, thanks. Neat plugin with this remote PI feature! Also, Merry Christmas to you!
                      --------------------------------------------------
                      **** Do You "Cocoon"? ****

                      Comment

                      Working...
                      X