Announcement

Collapse
No announcement yet.

Issue on raspberry pi zero w

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue on raspberry pi zero w

    I did an install on a Raspberry Pi zero W with the atest Raspian. Any ideas here?

    pi@raspberrypizerow:~/RaspberryIO $ mono HSPI_RaspberryIO.exe server=192.168.0.5
    Plugin: RaspberryIO Instance: starting...
    Connecting to server at 192.168.0.5...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    Feb-09 22:11:56 INFO RaspberryIO version 3.0.0.12
    Feb-09 22:11:56 ERROR System.IO.FileNotFoundException: Could not load file or assembly or one of its dependencies.
    File name: 'Microsoft.VisualBasic, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
    at HSPI_RaspberryIO.WebConfig..ctor (System.String pageName) [0x0000b] in <6051eb39012e4822bf3daa2a5be39e54>:0
    at HSPI_RaspberryIO.RaspberryPiApp.Init () [0x00090] in <6051eb39012e4822bf3daa2a5be39e54>:0
    Feb-09 22:11:56 INFO Shutting Down plug-in
    Shutdown IO called
    Feb-09 22:11:56 INFO Shutting Down plug-in
    Connection lost, exiting
    Disconnected from server - client
    HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

    Plug-Ins Enabled:
    Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
    weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

  • #2
    try to install the VB package:

    Code:
    sudo apt-get install mono-vbnc

    Comment


    • #3
      That seems to have done it! I thought I did that one when I went through the instructions...
      HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

      Plug-Ins Enabled:
      Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
      weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

      Comment

      Working...
      X