Announcement

Collapse
No announcement yet.

Can't connect using Raspberry Pi Zero W

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't connect using Raspberry Pi Zero W

    ~/RaspberryIO $ sudo ./run.sh
    Plugin: RaspberryIO Instance: Test starting...
    Connecting to server at 192.168.10.2...
    Connection attempt #1
    Connected (HomeSeer API 3). Waiting to be initialized...
    Jul-07 14:50:45 INFO RaspberryIO version 3.0.0.12
    Jul-07 14:50:53 INFO Raspberry Pi running on Bcm2708 processor
    Jul-07 14:50:53 INFO Firmware rev9437377, board model Zero (Raspberry Pi Zero)
    Jul-07 14:50:57 INFO Shutting Down plug-in
    Jul-07 14:50:57 ERROR CreateHSDevices: Object reference not set to an instance of an object
    Disconnected from server - client
    System.NullReferenceException: Object reference not set to an instance of an object
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception& exc, System.Object[]& out_args) [0x00000] in <filename unknown>:0
    Connection lost, exiting
    System.NullReferenceException: Object reference not set to an instance of an object
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception& exc, System.Object[]& out_args) [0x00000] in <filename unknown>:0
    Jul-07 14:50:58 ERROR System.NullReferenceException: Object reference not set to an instance of an object
    at HSPI_RaspberryIO.RaspberryPiApp.ReadPinsConfigFromIni () [0x00000] in <filename unknown>:0
    Waiting 30 seconds before trying to reconnect
    Last edited by adanchenko; July 10th, 2018, 07:42 AM.

  • #2
    On Raspberry Pi 3 everything works perfectly. It's something with Zero...

    Comment


    • #3
      Nailed it.

      After 4 days of experimenting, I finally connected it.
      The previous guide to update mono on Raspberry pi zero didn't work for me. I have no idea why, must be something has changed.

      The working solution is:
      I started with downloading the latest Raspbian Stretch from the Pi foundation website.
      The first step was to update/upgrade repositories:

      sudo apt-get update
      sudo apt-get upgrade

      Then install all 3 mono versions:

      sudo apt-get install mono-devel

      The install will end with notification that some dependencies are missing and we need to fix that:

      sudo apt-get upgrade --fix-missing

      Then install the second one

      sudo apt-get install mono-complete

      And finally,

      sudo apt-get install mono-vbnc

      Raspberry Pi zero is slooooow, so it will take you, maybe, the whole day to update and install everything.

      After all mono versions are installed, you may follow the User guide to install RaspberryIO:
      https://forums.homeseer.com/showthread.php?t=183913

      After all these steps it works and connects without any problems.

      Hope this will help someone.

      Comment


      • #4
        I followed the steps above on a pi zero w, and it took about an hour total.
        Joe (zimmer62)

        BLSecurtiy, AC-RF2, RCS Serial Thermostats, RFXCOM SMarthome SwitchLinc, mcsXap, Global Cache GC100, SqueezeBox, TWA_ONKYOINTEGRA, BLLogMonitor, BLPlugins, BLRadar, BLSpeech, BLZLog.aspx, HSTouch (Windows, iPhone, iPod), USB Mimo touchscreens, VMWare Server, Vortexbox, Windows Home Server, MyMovies, Windows Media Center, X10, ZWave, and much much much more.

        Comment


        • #5
          Mine took something like 3-4 hours with lots of hiccups. Pi Zero is damn slow... But now it's rock solid, did not even touch it since July.

          Comment

          Working...
          X