Announcement

Collapse
No announcement yet.

Unknown heap type: #Strings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unknown heap type: #Strings

    My remote RaspberryIO suddenly stopped working. I reinstalled MONO, but still get this when starting:

    Code:
    Unknown heap type: #Strings
    
    * Assertion at metadata.c:939, condition `index < meta->heap_strings.size' not met
    
    Stacktrace:
    
    
    Native stacktrace:
    
    
    Debug info from gdb:
    
    [New LWP 1319]
    [New LWP 1318]
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
    0x76ea0ef8 in __libc_waitpid (pid=1320, stat_loc=0x7ec6a19c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    40      ../sysdeps/unix/sysv/linux/waitpid.c: No such file or directory.
      Id   Target Id         Frame
      3    Thread 0x763ff430 (LWP 1318) "mono" 0x76e9c7a4 in __pthread_cond_wait (cond=0x235420, mutex=0x235408) at pthread_cond_wait.c:187
      2    Thread 0x76acf430 (LWP 1319) "Finalizer" 0x76e9ea40 in do_futex_wait (isem=isem@entry=0x22a58c) at ../nptl/sysdeps/unix/sysv/linux/sem_wait.c:48
    * 1    Thread 0x76fb1000 (LWP 1317) "mono" 0x76ea0ef8 in __libc_waitpid (pid=1320, stat_loc=0x7ec6a19c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    
    Thread 3 (Thread 0x763ff430 (LWP 1318)):
    #0  0x76e9c7a4 in __pthread_cond_wait (cond=0x235420, mutex=0x235408) at pthread_cond_wait.c:187
    #1  0x00146908 in ?? ()
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)
    
    Thread 2 (Thread 0x76acf430 (LWP 1319)):
    #0  0x76e9ea40 in do_futex_wait (isem=isem@entry=0x22a58c) at ../nptl/sysdeps/unix/sysv/linux/sem_wait.c:48
    #1  0x76e9eaf4 in __new_sem_wait (sem=0x22a58c) at ../nptl/sysdeps/unix/sysv/linux/sem_wait.c:69
    #2  0x0015f1c4 in mono_sem_wait ()
    #3  0x0010d96c in ?? ()
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)
    
    Thread 1 (Thread 0x76fb1000 (LWP 1317)):
    #0  0x76ea0ef8 in __libc_waitpid (pid=1320, stat_loc=0x7ec6a19c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:40
    #1  0x0007a388 in ?? ()
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)
    
    =================================================================
    Got a SIGABRT while executing native code. This usually indicates
    a fatal error in the mono runtime or one of the native libraries
    used by your application.
    =================================================================
    
    Aborted

  • #2
    Never mind, I reinstalled RasperryIO, all good now

    Comment

    Working...
    X