Announcement

Collapse
No announcement yet.

How to Get 2 Relay SPDT Outputs and 3 Dry Contact Inputs On Raspberry Pi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi Jeanv, Here's the break-out board I used: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

    I actually used this because I had intended on hooking up a variety of I/O to this RasPi, and thought that some of the proposed uses might need circuitry I could just prototype right onto this board. It's overkill for a few dry contacts, honestly, and since it doesn't have thru-pins (at least not with the dual-row connector provided, this has to go on top of the relay hat. That's a little tricky because the relays are actually pretty tall and prevent this board from seating all the way down.

    Comment


    • #17
      dzee, yes in looking at the board, I agree it is overvill and add some complication to the layout. I trying to figure out the best way connect the Digital Inputs securely.. Maybe a board that breaks out the pins to screw terminals or just solder or jumper the pins.... thanks again!
      ---------------------------------------------------
      Jean-Marie G. Vaneskahian
      jean@vaneskahian.com
      ---------------------------------------------------

      Comment


      • #18
        It looks great and works perfectly!!!! Thanks so much for the recommendations, help, and this plugin!!

        Click image for larger version

Name:	IMG_0713.JPG
Views:	114
Size:	114.5 KB
ID:	1266509
        ---------------------------------------------------
        Jean-Marie G. Vaneskahian
        jean@vaneskahian.com
        ---------------------------------------------------

        Comment


        • #19
          Jeanv and dzee,

          I am trying to get this exact hardware to work with this plug in. I can control the relays via cmd line on the pi, however I can't for the life of me get to work from HS on my Windows box. The pi does create the remote plugin, I configure all the gpio pins to output and it creates the objects, however the objects do nothing on the pi.

          Any help would be appreciated.

          Dave

          Comment


          • #20
            I'm nowhere near my system right now but my first thought was whether the correct GPIO pins are configured.

            I don't mean to insult if you're very familiar with pi, but those pin numbers and GPIO numbers don't match so it always a mind twister to map one thing to another.

            Can you hear any of the relays click? Do any of the relays light? Do you see any blinking from traffic on the pi when you send a command from HS3?

            Sent from my SM-N975U1 using Tapatalk

            Comment


            • #21
              Hey dzee,

              Thanks for the fast response, and no insult taken.

              I have configured every GPIO pin in homeseer, as seen in the attached pdf.
              Raspberry.pdf

              The devices do get created within homeseer, and I have tried turning them on and off, even the logs on the pi says it has seen the commands it does nothing. No LED's no click.

              I must be missing something, perhaps on the pi side.



              Dave
              Attached Files

              Comment


              • #22

                EDIT AGAIN: I was finally able to D/L your screen shot PDF above and view it. Your relay board should be responding to what you've named Relay19 (relay 1 on the board), Relay25 (relay 2 on the board), and Relay20 (relay 3 on the board) if you have the same relay hat as I do.

                FROM EARLIER POST:
                If you're using the same relay board, then the GPIO pins should be set the same as mine above at 20, 21, and 26 for relay 1, 3, and 2 respectively (https://forums.homeseer.com/forum/an...31#post1265931)

                There are some jumpers on the relay board to enable you to use alternative GPIO pins. How are yours set? Are they jumpered across two pins or just connected to one pin? Just wondering if the manufacturer is defaulting them a different way.

                EDIT: Just thought of something else. So, I have run into a problem where I'm getting new devices created when the RPi reboots. The old ones are there, but they're either sluggish or don't work, but the new ones do. Sort your devices and make sure there is only one device per configured GPIO in the device list.

                Comment


                • #23
                  I am totally stumped.

                  The new board comes with 2 dip switches, off off is the first board, off on is the second, on off the third and on on for the 4th board.

                  I have double checked the devices and there is only one set.

                  For some reason the plugin on the RPi is not talking to the relay board, however using the following commands on a ssh session
                  works. That being said the commands only work if the plugin on the RPi is not running.
                  • Turn on channel No.1 relay

                  i2cset -y 1 0x10 0x01 0xFF
                  • Turn off channel No.1 relay

                  i2cset -y 1 0x10 0x01 0x00


                  Comment


                  • #24
                    The dip settings you mention make sense if the boards are #0, 1, 2, 3 in binary:
                    00 off-off
                    01 off-on
                    10 on-off
                    11 on-on

                    But, are you referring to different boards or all this on one board? How many relays per board? Can you send a link to the relay board(s) you bought?

                    Sent from my SM-N975U1 using Tapatalk

                    Comment


                    • #25
                      Originally posted by smithdavee View Post
                      I am totally stumped.

                      The new board comes with 2 dip switches, off off is the first board, off on is the second, on off the third and on on for the 4th board.

                      I have double checked the devices and there is only one set.

                      For some reason the plugin on the RPi is not talking to the relay board, however using the following commands on a ssh session
                      works. That being said the commands only work if the plugin on the RPi is not running.
                      • Turn on channel No.1 relay

                      i2cset -y 1 0x10 0x01 0xFF
                      • Turn off channel No.1 relay

                      i2cset -y 1 0x10 0x01 0x00

                      Wait a minute. Just clued in to your CLI commands. You're sending i2c commands? That's different than the GPIO protocol, and I'm not sure if RasberryIO does anything other than GPIO. Does this relay board run GPIO?

                      Sent from my SM-N975U1 using Tapatalk

                      Comment


                      • #26
                        want an easy solution, no cl commands try RaspberryIO (Spud), works well, have 1 raspberry pi for I/O and one for 8 port relay all managed by the spud module in HS

                        Comment


                        • #27
                          Thanks so much! I did use RaspberryIO plugin (
                          ---------------------------------------------------
                          Jean-Marie G. Vaneskahian
                          jean@vaneskahian.com
                          ---------------------------------------------------

                          Comment


                          • #28
                            Would someone be willing to put together a list of everything that would be needed to make a solution like this work? I am interested in using a solution like this to automate my garage doors but new to rpi and not really sure what all I need to get?

                            Comment


                            • #29
                              I do not understand your question Dweber85rc? Exactly what functions are you wanting to accomplish?
                              ---------------------------------------------------
                              Jean-Marie G. Vaneskahian
                              jean@vaneskahian.com
                              ---------------------------------------------------

                              Comment


                              • #30
                                Originally posted by jeanv View Post
                                I do not understand your question Dweber85rc? Exactly what functions are you wanting to accomplish?
                                I guess I am looking for some guidance on what "parts" to get to use a relay board on a rpi like this. Is it simply slap the hat on? I am looking for a way to control 2 garage door openers which and then have 6-8 No/nc sets of dry contacts.

                                Comment

                                Working...
                                X