Announcement

Collapse
No announcement yet.

Temp without decimal !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Temp without decimal !

    Hello,

    I want display the temperature with an icon in the status page, i've use this script :
    Code:
    sub main 
    hs.SetDeviceString ("#5"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("#5"))&"Deg.gif]" 
    end sub
    But I want remove the decimal to post only the temperature except for the degree !

    Did you have a script for ?

    Thanks !

  • #2
    Originally posted by yanacrux View Post
    Hello,

    I want display the temperature with an icon in the status page, i've use this script :
    Code:
    sub main 
    hs.SetDeviceString ("#5"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("#5"))&"Deg.gif]" 
    end sub
    But I want remove the decimal to post only the temperature except for the degree !

    Did you have a script for ?

    Thanks !
    The current supported temperature formats are °, °F and °C. The plug-in currently doesn't support just a numeric value.

    I think it may be easy to add this as a new feature. How are the temperature icons named? Something like 89.gif for 89 °? Would you want to display the current format in addition to displaying a temperature icon?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      With this script, i've the same format for all temperature :
      Code:
      Sub Main()
      hs.SetDeviceString ("#5"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("#5"))&"Deg..gif]"&" "& cstr(hs.devicevalue("#5"))&" Deg."
      hs.SetDeviceString ("#4"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("#4"))&"Deg..gif]"&" "& cstr(hs.devicevalue("#4"))&" Deg."
      hs.SetDeviceString ("#3"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("#3"))&"Deg..gif]"&" "& cstr(hs.devicevalue("#3"))&" Deg."
      hs.SetDeviceString ("T1"),"[img src=Images/HomeSeer/"& cstr(hs.devicevalue("T1"))&"Deg..gif]"&" "& cstr(hs.devicevalue("T1"))&" Deg."
      End Sub
      The icon "XX Deg." work correctly in the status view but i don't known why the icon "XX Deg." don't display in ultraview like temperature take with digimax sensor ???

      Comment

      Working...
      X