Announcement

Collapse
No announcement yet.

Unsupported-Ultra1wire3 Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unsupported-Ultra1wire3 Plugin

    I only had one wireless sensor connected and it died. I purchased a new one and the plugin shows the first data point with a note "Unsupported-Ultra1wire3 Plugin"

    When I look in the database there are lots of data points. I have restarted HS3 to no avail. I updated the plugin to 3.0.6405.17148. Still no resolution.

    I deleted the plugin and restarted HS3. I have an error in the log that says
    7/26/2017 9:43:14 PM ~!~Error~!~(1) Unable to initialize interface Ultra1Wire3 :Either no license or trial has expiredStartup Complete, 1 errors detected, check the log for more information.

    When I reinstall the plugin it has the license info and correct device info just as if I didn't delete the plugin.

    I'm thinking this is an HS issue and not necessarily an U1W3 issue.

    Thoughts? I'd really like to get this working again!

  • #2
    It seems to be displaying the data now, however, it still says unsupported plugin and it doesn't record the light levels, only humidity, pressure, temperature, and the counter.

    Comment


    • #3
      Hi, can you please post the details.xml file from the controller?
      Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

      Comment


      • #4
        Also, this morning it no longer says unsupported plugin (I did not update anything). When I look at the data in ultra1wire3.db3 The config table shows sensor_name in tblSensorConfig as unsupported (probably contributing to the unsupported plugin issue). I've attached a screen scrape of the .db3
        Attached Files
        Last edited by LikeAutomation; July 28th, 2017, 07:09 AM. Reason: Found the file

        Comment


        • #5
          Originally posted by LikeAutomation View Post
          Also, this morning it no longer says unsupported plugin (I did not update anything). When I look at the data in ultra1wire3.db3 The config table shows sensor_name in tblSensorConfig as unsupported (probably contributing to the unsupported plugin issue). I've attached a screen scrape of the .db3
          Thank you for posting the details.xml. Everything looks good. The device EDS0068 supports temperature, humidity, barometric pressure and light. Please confirm those values are being updated.

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            I've attached another screen shot. It did not create the light table and is not recording light levels. Also, when looking at the database I am only receiving one entry per hour. I have it set to read every 1 minute. The controller says it's reading every minute and the stats on the plugin are in the thousands so it appears the plugin sees it, however, the database does not reflect an entry every minute.
            Attached Files
            Last edited by LikeAutomation; July 31st, 2017, 06:08 AM. Reason: additional info

            Comment


            • #7
              The plug-in only tracks values for temperature, humidity, counter and pressure in the underlying database. There is an hourly table that is used to calculate the averages for the hour that gets inserted into the database for charting purposes.

              If your light HomeSeer device is not being updated, then please delete it so the plug-in can re-create it. Please confirm if that fixes the issue.

              Regards,
              Ultrajones
              Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

              Comment


              • #8
                May have been a miss-understanding. So the database does not track the light sensor so I won't be able to create a chart for Lux, correct? It did create a device in HS and it does change with the light levels.

                Comment


                • #9
                  Originally posted by LikeAutomation View Post
                  May have been a miss-understanding. So the database does not track the light sensor so I won't be able to create a chart for Lux, correct? It did create a device in HS and it does change with the light levels.
                  It doesn't today, but if you see a need for it, I could simply add it. Thoughts?
                  Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

                  Comment


                  • #10
                    I personally don't see a need for it at this time. So here is what I learned...

                    There are two databases. One is populated based on the frequency set in the device and in the plugin. The other averages the values during an hour and provides and hourly average in the charting. The "unsupported" was actually the default name of the element (temperature, pressure, etc). Once I changed that in HomeSeer the Chart reflected it. Temperature, humidity, pressure, and counter are all logged in the db, however, light levels are not. Simply a miss-understanding. It is working exactly as it should. Thanks for the patient responses!!!!

                    Comment


                    • #11
                      Feature Request

                      One thing that would be nice would be to add a Min and Max so I could see the full swing in a 24 hour period of Temp, Humidity, and Pressure.

                      Comment

                      Working...
                      X