Announcement

Collapse
No announcement yet.

Ultra1Wire3 counter looses suffix and offset on restarting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ultra1Wire3 counter looses suffix and offset on restarting

    Hi Ultra,
    I am using the OWServer and the Ultra1Wire3 plugin with a hobby board dual counter to track gas usage via a reed switch on the meter.

    In the device status graphics tab I set the suffix as 'm3' (cubic meters) and an offset to adjust the counter reading to match the gas meter reading.

    But when I restart HS3 the suffix reverts to 'Gallons' and the offset reverts to 0.

    I have set the plugin settings in plugin options to metric. Metric volume is cubic meters or liters.

    Could you have a look into this? Maybe it is something to to with the sensor subtype being set to water meter (there is no option for gas meter).

    Thanks, Marty.
    iCore5 Win 10 Pro x64 SSD

    HS3 Pro Edition 3.0.0.435 Windows

    BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

  • #2
    I just posted an update that add support for a gas meter. Can you give it a shot?

    Regards,
    Ultrajones
    Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

    Comment


    • #3
      Hi Ultra,
      Thanks for adding a gas meter as an option.
      The suffix now stays with a reboot. But the "Value Offset:" in the status/graphics page is lost when I reboot the HS server (see attached). I have it set as a negative value (-1047.66 to be exact) so that the device value matches the exact meter reading. But after a reboot it is set to 0 again.
      Is there some method of retaining this value?

      Marty
      Attached Files
      iCore5 Win 10 Pro x64 SSD

      HS3 Pro Edition 3.0.0.435 Windows

      BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

      Comment


      • #4
        Hi Ultra,
        Any progress with the offset issue? It's still reverting to 0 when I reboot HS.
        Marty
        iCore5 Win 10 Pro x64 SSD

        HS3 Pro Edition 3.0.0.435 Windows

        BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

        Comment


        • #5
          I think the rebuilding of the value/graphics pairs is clobbering the offset you enter. The next release (soon) will include a fix for this.

          Regards,
          Ultrajones
          Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

          Comment


          • #6
            Thanks Ultra.
            I'll keep an eye out for the update.
            Marty
            iCore5 Win 10 Pro x64 SSD

            HS3 Pro Edition 3.0.0.435 Windows

            BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

            Comment

            Working...
            X