Announcement

Collapse
No announcement yet.

Vizio TV control?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vizio TV control?

    ive seen the plugins for Sony and other TVs but has anyone dabbled with VIzio Smart TVs? I have 2 and would like to integrate them into my HS3 pro. I would rather not have to go get Sony TVs to accomplish my goals.

  • #2
    Nudge Nudge. Anyone have anything?

    Comment


    • #3
      Have you tried the MediaController plugin?
      HS 3.0.0.548: 1976 Devices 1156 Events
      Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

      Comment


      • #4
        Originally posted by sparkman View Post
        Have you tried the MediaController plugin?
        I did. Only decent feature is the WOL but no way to turn off, change inputs, or any volume control.

        Comment


        • #5
          The Vizio's seem to be wierd with dlna. I tried mediacontroller plugin and it could turn the TV on with wol once but then if it turned off the plugin had to be disabled before it would work again. I just bought a Vizio a d really would like to have a way to turn the thing off remotely with minimal expense because the kids have a habit of leaving the thing on when nobody is in the room.

          Comment


          • #6
            Originally posted by Dweber85rc View Post
            The Vizio's seem to be wierd with dlna. I tried mediacontroller plugin and it could turn the TV on with wol once but then if it turned off the plugin had to be disabled before it would work again. I just bought a Vizio a d really would like to have a way to turn the thing off remotely with minimal expense because the kids have a habit of leaving the thing on when nobody is in the room.
            I'd be happy to look at the WOL issue. Make sure you are on the latest version of the PI and use the WOL button/function on the "Device" and not the one you may find on player or remote devices. The PI was created where buttons would not do anything unless the device is on-line. I therefore made some changes and added a WOL function to the "device" device which should ignore the on-line status. Are you running this on Windows or Linux? I have an issue when it runs under Linux to get the MAC address for the given IP address (ARP request). This also means that the WOL would only know the MAC address AFTER the TV was on-line. The PI should record the last known MAC address but there hasn't been a lot of testing done so reasonable chance that there could be some issues. So check the .ini file to see if the MAC address was recorded and correct. If it is there, WOL (on the "device" device) should work.

            Comment


            • #7
              I like the Vizio TV's but never was able to do anything with them over the network. Finally bought into the global cache ecosystem several years ago and never looked back.

              Comment


              • #8
                Originally posted by Dweber85rc View Post
                The Vizio's seem to be wierd with dlna. I tried mediacontroller plugin and it could turn the TV on with wol once but then if it turned off the plugin had to be disabled before it would work again. I just bought a Vizio a d really would like to have a way to turn the thing off remotely with minimal expense because the kids have a habit of leaving the thing on when nobody is in the room.
                So I just reinstalled the PI and tested. This is on windows. The ini has the mac address of the TV. TV is hardwired ethernet. When the TV is on and the PI is first installed-it shows activated online. I can manually turn the TV off and the WOL works. Seems to work everytime. However if the device status goes to activated offline, such as the TV is off when the PI restarts or HS restarts, then WOL does not work. I see the event in the log that shows WOL runs but nothing happens on the TV. Or it will turn the TV on, but the status never goes to activated online.

                But more importantly I'm looking for a way to turn the TV off remotely without a lot of hassle.

                Comment


                • #9
                  Originally posted by Dweber85rc View Post

                  So I just reinstalled the PI and tested. This is on windows. The ini has the mac address of the TV. TV is hardwired ethernet. When the TV is on and the PI is first installed-it shows activated online. I can manually turn the TV off and the WOL works. Seems to work everytime. However if the device status goes to activated offline, such as the TV is off when the PI restarts or HS restarts, then WOL does not work. I see the event in the log that shows WOL runs but nothing happens on the TV. Or it will turn the TV on, but the status never goes to activated online.

                  But more importantly I'm looking for a way to turn the TV off remotely without a lot of hassle.
                  Can you post logs and screenshots ?

                  Comment

                  Working...
                  X