Announcement

Collapse
No announcement yet.

Run Airplay Speak on RPi?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Run Airplay Speak on RPi?

    I am trying to get this plugin installed, and I first did it from the plug-in interface, which didn’t work, then I tried the Linux install instructions from the sticky (which fails on libav since it seems to be deprecated), but ffmpeg is already installed.

    I get the error in the UI - “WARNING: Failed getting InterfaceStatus from AirplaySpeak - the interface was not found in the list of active interfaces, the list may need to be refreshed.”

    I did a full update/upgrade, and restarted HomeSeer. Still no joy.

    Any tips on getting this working?

    Thanks in advance for any help!

    #2
    I’d like to buy this plugin but I can’t do that with no support to get it running. I’ve followed all the posted (but very old) Linux instructions. Other than that, there is nothing.

    If this isn’t supported anymore that’s fine, just let me know. But the trial runs out in a couple days and without support I won’t be able to test, and I can’t buy it without confirming it works.

    HS3, RPi 4, want to airplay to Homepods on same network.

    Comment


      #3
      Okay, made a little progress. It loads, and sees all my airplay devices and HomePods.

      I disabled all of them except one HomePod. I have HomeSeer speak mirroring set to yes.

      I created a simple event to say something using HomeSeer speak, and I get an error from airplay speak about the .wav file not existing:
      Click image for larger version

Name:	38774F93-5CB7-4A42-BF8E-FA7B3703F903.jpeg
Views:	69
Size:	54.3 KB
ID:	1437490

      Comment


        #4
        Well, no thanks to any support, but got this sort of working. Now it shows only one HomePod at a time. Seems totally random which HomePod shows up. And the log shows that it sees all the HomePods when the plug in starts.

        Any thoughts on how to fix this?

        Comment

        Working...
        X