Announcement

Collapse
No announcement yet.

IPOD's

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IPOD's

    I figured when I read all the Apple stuff this might work on my Ipod.
    I guess it won't or I have something wrong. I get this error.
    Code:
    6/28/2013 3:18:16 PM ~!~Error~!~Calling GenPage for plugin, link: /airplayspeak_config Error: Could not load file or assembly 'System.Speech, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    6/28/2013 3:18:18 PM ~!~Error~!~Calling GenPage for plugin, link: /airplayspeak_config Error: Could not load file or assembly 'System.Speech, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    Thanks,
    Tim
    FB Page - https://www.facebook.com/pages/Capt-Tim/209398425902188

    HSTouch Layouts - https://www.facebook.com/media/set/?...5902188&type=3

    No, Im from Iowa. I only work in outer space. Captain Kirk

  • #2
    the error from your log shows that the system cannot load the speech synthesis engine.

    what is the .NET framework installed on your HS machine?
    does the HS speaker client work on your HS machine?
    when does this error appear?
    what is the version of the Airplay plugin you are testing?

    this is probably not related with the error you see, but I 'm not sure to understand what you are trying to do with your ipod. Are you trying to send some HS annoucements to your iPod? What kind of iPod is it?

    Comment


    • #3
      what is the .NET framework installed on your HS machine?
      2.0 and 4.0
      does the HS speaker client work on your HS machine?
      yes 2.5.0.80
      when does this error appear?
      As soon as I click the "Config" button in the Interfaces tab.
      what is the version of the Airplay plugin you are testing?
      Latest from the Updater

      this is probably not related with the error you see, but I 'm not sure to understand what you are trying to do with your ipod. Are you trying to send some HS annoucements to your iPod? What kind of iPod is it?
      Yes, I want to hear what HS says on my Ipod. It is a Ipod Touch iOS ver 6.1.3

      Thanks,
      Tim
      FB Page - https://www.facebook.com/pages/Capt-Tim/209398425902188

      HSTouch Layouts - https://www.facebook.com/media/set/?...5902188&type=3

      No, Im from Iowa. I only work in outer space. Captain Kirk

      Comment


      • #4
        Do I have to add more items to the Scripting References section of the settings.ini ?

        Thanks,
        Tim
        FB Page - https://www.facebook.com/pages/Capt-Tim/209398425902188

        HSTouch Layouts - https://www.facebook.com/media/set/?...5902188&type=3

        No, Im from Iowa. I only work in outer space. Captain Kirk

        Comment


        • #5
          .NET 2.0, 3.0, 3.5 uses CLR 2.0 (CLR = Common Language Runtime)
          .NET 4.0 uses CLR 4.0
          so my guess is that as HS2 target .NET 2.0, the CLR used is 2.0, but as you don't have 3.0 or 3.5 installed the System.Speech assembly does not exist on your system.

          so you need to install .NET 3.0 or 3.5
          alternatively I can provide an old version of the plugin which does not use this System.Speech assembly, but the quality of the speech synthesis will be low.

          also, I don't think the iPod Touch is natively an AirPlay receiver (it is an AirPlay sender), so it probably won't work unless you install an app which adds this capability.

          Comment

          Working...
          X