Announcement

Collapse
No announcement yet.

Bose Soundlink Air

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bose Soundlink Air

    Is the plugin compatible with the Bose Soundlink Air?

    My assumption is no considering it's not on the list and when I installed the plugin it didn't work and required me to reboot my speaker in order for other devices to use the speaker.

    Everytime I enabled the plugin, my speaker required me to reboot it work with other devices.


    Never was able to successfully send sounds to the speaker from HS3

  • #2
    Could you set log level to debug, and post your logs.

    Comment


    • #3
      Originally posted by spud View Post
      Could you set log level to debug, and post your logs.
      Attached you will find the log.

      Thank you for your help.
      Attached Files

      Comment


      • #4
        Originally posted by spud View Post
        Could you set log level to debug, and post your logs.
        There may be more to the issue than I thought. I am unable to play sounds on my AppleTV from HS3 either.

        The plugin detects the devices and doesn't show any errors in the log when I run events that use the Airplay plugin.

        However, as you can see from reviewing the log on my previous post, there are errors present when loading HS.

        BTW, the plugin sends sounds to the speaker client when enabled.

        Comment


        • #5
          Originally posted by spud View Post
          Could you set log level to debug, and post your logs.
          Any advice after reviewing my logs? I would really like to get this plugin working before the trail period expires.

          Comment


          • #6
            Sorry, I can t review your log right now, i am on vacation until jan 14th, and I have very limited internet access.

            for your apple Tv problem, try to add some before and after delay from the config page. if it still doesn t work, please try to capture a debug log, and post it here.

            Thanks

            Comment


            • #7
              Enjoy your well earned vacation w/ family
              Ubuntu 16.10 (64) | HSPro 3.0.0.297 | Z-Wave 3.0.1.124 | Server .94 | BL BackUp | BLOccupied | BLLock | Media Controller | Jowi HUE | HSTouch | DSC-Envisalink | I-Tunes DAAP | DirecTV | Restart | Honeywell WiFi | Weather XML | RFX Com | + Android .117 : IOS 8

              Comment


              • #8
                Originally posted by mgonzales100 View Post
                Any advice after reviewing my logs? I would really like to get this plugin working before the trail period expires.
                what version of the plugin do you use?
                could you post the TXT lines you got when the plugin discover your airplay speakers. It should look something like this:
                Code:
                DEBUG TXT Records =
                DEBUG txtvers = '1'
                DEBUG ch = '2'
                DEBUG cn = '0,1'
                DEBUG ek = '1'
                DEBUG et = '0,1'
                DEBUG sv = 'false'
                DEBUG da = 'true'
                DEBUG sr = '44100'
                DEBUG ss = '16'
                DEBUG pw = 'false'
                DEBUG vn = '65537'
                DEBUG tp = 'TCP,UDP'
                DEBUG vs = '105.1'
                DEBUG am = 'AirPort4,107'
                DEBUG fv = '76400.10'
                DEBUG sf = '0x1'
                Have you tried adding some delays for your apple TV problem?

                Comment


                • #9
                  Originally posted by spud View Post
                  what version of the plugin do you use?
                  could you post the TXT lines you got when the plugin discover your airplay speakers. It should look something like this:
                  Code:
                  DEBUG TXT Records =
                  DEBUG txtvers = '1'
                  DEBUG ch = '2'
                  DEBUG cn = '0,1'
                  DEBUG ek = '1'
                  DEBUG et = '0,1'
                  DEBUG sv = 'false'
                  DEBUG da = 'true'
                  DEBUG sr = '44100'
                  DEBUG ss = '16'
                  DEBUG pw = 'false'
                  DEBUG vn = '65537'
                  DEBUG tp = 'TCP,UDP'
                  DEBUG vs = '105.1'
                  DEBUG am = 'AirPort4,107'
                  DEBUG fv = '76400.10'
                  DEBUG sf = '0x1'
                  Have you tried adding some delays for your apple TV problem?
                  I'm using version 3.0.0.2 of the plugin.

                  I'm tried adding some delays to apple TV without success.

                  I've attached the startup log after a reboot and a log filtered by all airplayspeak activity.
                  Attached Files

                  Comment


                  • #10
                    For both Apple TV and Bose speakers, can you stream music from your HS machine to these speakers with iTunes? with another airplay software like Airfoil?

                    I believe your AppleTV is running a very recent firmware which may be the cause of the problem. Could you tell me the exact version of your AppleTV firmware?

                    Comment


                    • #11
                      Also, this may be a firewall problem. Try to disable temporarily any firewall and AV on your HS3 machine.

                      Comment


                      • #12
                        Originally posted by spud View Post
                        Also, this may be a firewall problem. Try to disable temporarily any firewall and AV on your HS3 machine.
                        I turned off the firewall and the Soundlink responded to event to speak the text. However, it didn't play the mp3 file. I don't have iTunes loaded on the HS computer if that matters. The speaker client plays the song and speaks the text.

                        Below, is the only error message I can find in the log.


                        Jan-28 12:03:59 AM AirplaySpeak ERROR Could not load type 'NAudio.Wave.MonoToStereoStream16' from assembly 'NAudio, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null'.
                        Last edited by mgonzales100; January 28th, 2014, 01:51 AM.

                        Comment


                        • #13
                          Originally posted by spud View Post
                          For both Apple TV and Bose speakers, can you stream music from your HS machine to these speakers with iTunes? with another airplay software like Airfoil?

                          I believe your AppleTV is running a very recent firmware which may be the cause of the problem. Could you tell me the exact version of your AppleTV firmware?
                          I'm able to stream music to both devices from iTunes on other computers. I don't have iTunes loaded on the HS computer. Maybe I need to lead iTunes on the HS computer.

                          The firmware version of my AppleTV is 5.2.1

                          Thanks for the assistance.

                          Comment


                          • #14
                            Originally posted by mgonzales100 View Post
                            I turned off the firewall and the Soundlink responded to event to speak the text. However, it didn't play the mp3 file. I don't have iTunes loaded on the HS computer if that matters. The speaker client plays the song and speaks the text.

                            Below, is the only error message I can find in the log.


                            Jan-28 12:03:59 AM AirplaySpeak ERROR Could not load type 'NAudio.Wave.MonoToStereoStream16' from assembly 'NAudio, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null'.
                            If you have installed version 3.0.0.4 of the plugin make sure you have NAudio.dll version 1.6.0.1 in bin/AirplaySpeak and delete the old version of NAudio.dll that you probably have in the HS3 root dir. BTW you should also delete Mono.Zeroconf.dll and Mono.Zeroconf.Provider.Bonjour.dll from the root dir, in version 3.0.0.4 all dependencies of the plugin are now in bin/AirplaySpeak.

                            Comment


                            • #15
                              Originally posted by spud View Post
                              If you have installed version 3.0.0.4 of the plugin make sure you have NAudio.dll version 1.6.0.1 in bin/AirplaySpeak and delete the old version of NAudio.dll that you probably have in the HS3 root dir. BTW you should also delete Mono.Zeroconf.dll and Mono.Zeroconf.Provider.Bonjour.dll from the root dir, in version 3.0.0.4 all dependencies of the plugin are now in bin/AirplaySpeak.
                              Deleting the files removed the error message. Thank you.

                              I'm also able to now stream text to both the AppleTV and the Soundlink.

                              I'm still unable to play a MP3 file on my Soundlink or AppleTV. Do I need iTunes on the HS computer.

                              The updated version corrected the "locking" issue which prevented other devices from streaming music to the Soundlink after the plugin first streamed speech.

                              Lastly, we I attempt to stream an audio file to an Airplay device and enable "forward to HS Speakers" the file is played on the HS computer.

                              Thanks for your assistance. I have 3 days left on my trial so I'm hoping to get this resolved within the next 24 to 48 hours. Would love to be able to purchase the plugin.

                              Comment

                              Working...
                              X