Announcement

Collapse
No announcement yet.

Error In SpeakDev calling a speak proxy plug-in

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error In SpeakDev calling a speak proxy plug-in

    Hello.

    I'm triying to get the Airplay Speaker working on HS3 but get the error

    "Error~!~In SpeakDev calling a speak proxy plug-in, exception is The input string has an incorrect format."
    (More or less as I have an Spanish OS, the exact text is "
    ~!~Error~!~In SpeakDev calling a speak proxy plug-in, exception is La cadena de entrada no tiene el formato correcto.
    ")

    I'm using Loquendo and saw your thread here http://board.homeseer.com/showpost.p...51&postcount=1 but in my system there isn't a "Wow6432Node" under "[HKEY_LOCAL_MACHINE\SOFTWARE".

    Thank you very much for your help.

    Mario.

  • #2
    does it work with regular windows voice (not Loquendo)?

    if you use a 32bits OS, try to look in
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens\
    and modify the Language attribute to upper case.

    Comment


    • #3
      Thanks for answer.

      No. It doesn't work with any voice. In fact in the plugin configuration the aren't voices to choose from, the list is empty (well, there is no list at all).

      I checked the Language attribute and it's already upper case.

      May be it's related:
      I have installed (I don't know how) Microsoft Mary and Mike voices and they aren't compatible with Windows 7 32 bits. If I choose any of these two voices at the Control Panel I get an error.
      The problem is that I can't find any way to delete them. I tried deleting them from the Tokens list with regedit but it doesn't fix the problem.
      In my HS2 machine these devices are also installed (is in my base virtual machine image I use for everything) but Airplay Speaker Plugin works fine. Go figure!

      Comment


      • #4
        it's strange that it works with the HS2 but not with HS3, it's basically the same code. What version of the HS2 plugin do you use?

        Does TTS work with the HomeSeer speaker client?
        If it works, one possible workaround is to add the following to your AirplaySpeak.ini
        Code:
        [TTS]
        use_speaktofile=true
        This tells the plugin to use HomeSeer TTS engine, and then the plugin just stream the file produced by HS to your Airplay device. But this results in poor audio quality compared to the direct method.

        Comment


        • #5
          Originally posted by spud View Post
          it's strange that it works with the HS2 but not with HS3, it's basically the same code. What version of the HS2 plugin do you use?
          I'm using 1.2.0.10

          Does TTS work with the HomeSeer speaker client?
          Yes, it does.

          If it works, one possible workaround is to add the following to your AirplaySpeak.ini
          Code:
          [TTS]
          use_speaktofile=true
          This tells the plugin to use HomeSeer TTS engine, and then the plugin just stream the file produced by HS to your Airplay device. But this results in poor audio quality compared to the direct method.
          Same result.

          Comment


          • #6
            I did some more tests to try to isolate the problem... I hope some of them gives you a clue in order to fix it.
            1. Reinstalled Windows 7 from scratch.
            2. Just after Windows 7 32 bits was ready I installed HS3, the update to the last version 3.0.0.68
            3. Installed Airspeak Plugin.
            4. I tried TTS with Anna voice and it worked. The Anna voice was in the Airspeak Plugin config page.
            So the default installation without third party voices worked fine.



            Now...
            • Installed Loquendo with just one voice (Carmen).
            • Started HS3 and in the log the error "Error~!~In SpeakDev calling a speak proxy plug-in, exception is The input string has an incorrect format." appeared.
            • Uninstalled the complete loquendo package and Airspeak worked fine again, showing the Anna voice in the list.
            • Uninstalled Carmen Voice
            • Tried and same error in the log, and the list with the voices was void. So the problem wasn't with the specific voice.
            • Uninstalled "Loquendo TTS 7 Spanish distribution" leaving installed the Engine and SDK and Airspeak worked fine again, showing the Anna voice in the list.
            I also tried with a different, more recent, version of "Loquendo TTS 7 Spanish distribution" it didn't fixed the problem.

            In the HS3 log with the Airspeak log level in debug appears:

            Mar-15 1:37:56 PM Error In SpeakDev calling a speak proxy plug-in, exception is La cadena de entrada no tiene el formato correcto. Mar-15 1:37:56 PM Speaker Speaker host added, Name: WIN-5VFMIBN3IPS Instance: Default IP address: 127.0.0.1 Mar-15 1:37:54 PM AirplaySpeak DEBUG en System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) en System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) en System.Speech.Internal.SapiAttributeParser.GetCultureInfoFro mLanguageString(String valueString) en System.Speech.Synthesis.VoiceInfo..ctor(VoiceObjectToken token) en System.Speech.Internal.Synthesis.VoiceSynthesis.BuildInstall edVoices(VoiceSynthesis voiceSynthesizer) en System.Speech.Internal.Synthesis.VoiceSynthesis..ctor(WeakRe ference speechSynthesizer) en System.Speech.Synthesis.SpeechSynthesizer.get_VoiceSynthesiz er() en HSPI_AIRPLAY_SPEAK.WebConfig.BuildTTSVoiceDropList() Mar-15 1:37:54 PM AirplaySpeak ERROR La cadena de entrada no tiene el formato correcto.
            Mar-15 1:37:56 PM Error In SpeakDev calling a speak proxy plug-in, exception is La cadena de entrada no tiene el formato correcto. Mar-15 1:37:56 PM Speaker Speaker host added, Name: WIN-5VFMIBN3IPS Instance: Default IP address: 127.0.0.1 Mar-15 1:37:54 PM AirplaySpeak DEBUG en System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) en System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) en System.Speech.Internal.SapiAttributeParser.GetCultureInfoFro mLanguageString(String valueString) en System.Speech.Synthesis.VoiceInfo..ctor(VoiceObjectToken token) en System.Speech.Internal.Synthesis.VoiceSynthesis.BuildInstall edVoices(VoiceSynthesis voiceSynthesizer) en System.Speech.Internal.Synthesis.VoiceSynthesis..ctor(WeakRe ference speechSynthesizer) en System.Speech.Synthesis.SpeechSynthesizer.get_VoiceSynthesiz er() en HSPI_AIRPLAY_SPEAK.WebConfig.BuildTTSVoiceDropList() Mar-15 1:37:54 PM AirplaySpeak ERROR La cadena de entrada no tiene el formato correcto.

            "La cadena de entrada no tiene el formato correcto. " = "The input string has an incorrect format."

            Please, tell me any other test I can do to help you fix this issue.

            Thank you very much.

            Mario.

            Comment


            • #7
              Hi Mario,

              This really looks like the hexadecimal problem I encountered and some other people have reported like here:
              http://stackoverflow.com/questions/1...correct-format

              Are you sure everything is ok in your registry make sure all the installed voices (and not just the one you want to use) have the language attribute set to a hexadecimal upper case number. If you are not sure to what to check please post some screenshots.

              Comment

              Working...
              X