Announcement

Collapse
No announcement yet.

Error when it tries to speak something

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when it tries to speak something

    I'm getting the following error every time I try to speak something and nothing get's spoken:

    ERROR Could not load type 'NAudio.Wave.MonoToStereoStream16' from assembly 'NAudio, Version=1.6.0.0, Culture=neutral, PublicKeyToken=null'.

    I have no idea what this means and what's wrong with my system. I'm running HS3 3.0.0.96 on Windows 7 32-bit.


  • #2
    I forgot to mention that AirplaySpeak worked fine under HS2 but on a different system (XP) with the same speaker so it's definitely not the speaker.

    Comment


    • #3
      You probably have an old version of NAudio.dll in your HS3 root dir, delete it. All dependencies of the plugin are now in bin/AirplaySpeak. So, delete Mono.Zeroconf.dll and Mono.Zeroconf.Provider.Bonjour.dll from your HS3 root dir as well.

      Comment


      • #4
        The error went away after I removed these 3 DLL's but it's still not working. Now I get:

        INFO Connection to Philips_Fidelio 29192E (10.0.1.27:1024) failed: Request failed, error RTSP/1.0 500 Internal Server Error

        after I start HS3.

        Comment


        • #5
          this error usually means there is something that blocks the traffic between HS and the airplay speaker. Make sure your firewall is completely disabled, the plugin use several ports and both TCP and UDP protocols. Make sure your A/V isn't blocking anything either.

          Comment


          • #6
            Yes! That was it! After I turned off Windows Firewall it started working. Thanks a lot!

            Comment

            Working...
            X