Announcement

Collapse
No announcement yet.

INFO Connection to AirPort (x.x.x.x:5000) failed: Request failed, read error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • INFO Connection to AirPort (x.x.x.x:5000) failed: Request failed, read error

    Spud,

    I'm getting a read error when sending to 1st gen Airport Express, device works fine when sending from multiple idevices, any ideas?


    Nov-27 11:56:05 AirplaySpeak DEBUG 27 Speaker.AfterSend()
    Nov-27 11:56:05 AirplaySpeak DEBUG 27 Speaker.SendSample() gets lock
    Nov-27 11:56:05 AirplaySpeak DEBUG 27 Speaker.SendSample()
    Nov-27 11:56:05 AirplaySpeak DEBUG 27 Speaker.BeforeSend()
    Nov-27 11:56:05 AirplaySpeak DEBUG Stack: at RTSPClient.ExecRequest(String Cmd, String ContentType, String Content, WebHeaderCollection hds, Boolean GetResponse, String& returnCode, Boolean parseHeaderOnError) at RTSPClient.Record(Int32 rtpseq, Int32 rtptime) at RAOPClient.Connect() at HSPI_AIRPLAY_SPEAK.Speaker.Reset()
    Nov-27 11:56:05 AirplaySpeak INFO Connection to AirPort (x.x.x.x:5000) failed: Request failed, read error
    Nov-27 11:56:03 AirplaySpeak DEBUG RECORD rtsp://x.x.x.x/0129212298 RTSP/1.0 CSeq: 3 Session: 80A37440 Range: npt=0- RTP-Info: seq=2897;rtptime=30230 User-Agent: iTunes/4.6 (Macintosh; U; PPC Mac OS X 10.3) Client-Instance: 135019D0A1F48F34
    Nov-27 11:56:03 AirplaySpeak DEBUG Audio-Latency, 11025
    Nov-27 11:56:03 AirplaySpeak DEBUG Transport, RTP/AVP/UDP;unicast;interleaved=0-1;mode=record;control_port=6001;timing_port=6002;server_port =6000
    Nov-27 11:56:03 AirplaySpeak DEBUG Audio-Jack-Status, connected; type=analog
    Nov-27 11:56:03 AirplaySpeak DEBUG Session, 80A37440
    Nov-27 11:56:03 AirplaySpeak DEBUG CSeq, 2
    Nov-27 11:56:03 AirplaySpeak DEBUG SETUP rtsp://x.x.x.x/0129212298 RTSP/1.0 CSeq: 2 Transport: RTP/AVP/UDP;unicast;interleaved=0-1;mode=record;control_port=50116;timing_port=50115 User-Agent: iTunes/4.6 (Macintosh; U; PPC Mac OS X 10.3) Client-Instance: 135019D0A1F48F34
    Nov-27 11:56:03 AirplaySpeak DEBUG CSeq, 1
    Nov-27 11:56:03 AirplaySpeak DEBUG Audio-Jack-Status, connected; type=analog
    Nov-27 11:56:03 AirplaySpeak DEBUG ANNOUNCE rtsp://192.168.42.53/0129212298 RTSP/1.0 CSeq: 1 Content-Type: application/sdp Content-Length: 184 User-Agent: iTunes/4.6 (Macintosh; U; PPC Mac OS X 10.3) Client-Instance: 135019D0A1F48F34 v=0 o=iTunes 0129212298 0 IN IP4 192.168.42.53 s=iTunes c=IN IP4 192.168.42.52 t=0 0 m=audio 0 RTP/AVP 96 a=rtpmap:96 AppleLossless a=fmtp:96 352 0 16 40 10 14 2 255 0 0 44100
    Nov-27 11:56:03 AirplaySpeak DEBUG 27 Speaker.Reset() gets the lock
    Nov-27 11:56:03 AirplaySpeak DEBUG 27 Speaker.Reset()
    Nov-27 11:56:03 AirplaySpeak INFO (AirPort): Eat My Shorts

  • #2
    for 1st gen Airport Express, you need firmware 6.3 minimum. Firmwares 6.1.1 or 6.2 are not supported by this plugin.
    if you don't know your firmware, capture a debug log when the plugin discovers the Airport Express and post it here.

    also, try to test with longer messages than "Eat My Shorts", very shorts messages can be problematic with some devices.

    Comment


    • #3
      Verified 6.3 firmware on Airport, tried changing the spoken text to "If you would like to check the status of your order, manage addresses, update your email, or customize many other options, please visit your personal My Account page." and an MP3, same result... Verified spoken text and mp3 both play fine when piped thru Pi running shairport.

      Comment


      • #4
        not sure what the problem is then, here, I have a 1st gen Airport Express with 6.3 that works just fine.
        could you try to power cycle the AE, disable any firewall and AV, and add 3 secs for Before delay and After delay in the config page.

        Comment


        • #5
          Strange, bouncing the Airport fixed it, Thanks...

          Comment

          Working...
          X