Announcement

Collapse
No announcement yet.

Airplay Speak HS3 Linux Installation Guide

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by stevenseh@gmail.com View Post
    OK, that worked. Thanks!
    I'm now at the installation step.
    How do I copy the zip you attached to the Zee S2?

    I tried pscp, but I'm getting an error message:

    Permission denied.
    Error code: 3
    Error message from server: Permission denied

    I suppose the target directory is /usr/local/HomeSeer/Updates3/Zips
    to transfer file to your Zee S2, you can use the sftp protocol (ssh file transfer protocol). Use a software like FileZilla and use the same user /password you used for ssh.

    Comment


    • #17
      I tried the file transfer with WinSCP, and it's giving me a permission error (details in previous post) when copying to the /usr/local/HomeSeer/Updates3/Zips folder. Something must be wrong with that folder, as I can copy the file elsewhere on the Zee S2.
      Am I dropping it in the correct directory?
      Thanks,
      Eric

      Comment


      • #18
        I deleted and re-created the Zips folder. It copied OK this time.
        I enabled the plug-in, but it does not work.
        There is a speaker in the config, but the screen looks different from the one in the user guide:

        Airplay Speakers Configuration
        ID Name Type Password Volume Enabled Delay Before Delay After Event Before Event After
        C8D5FEE6F013 iHome iW3 E6F013 Unknown

        0

        0


        Forward speak events to HS speakers:
        Delay before forwarding to HS speakers:
        0
        Log settings
        Log Level:
        Log to File
        File Log Level

        There is no TTS voice, for example.

        Another issue is that the speaker does not show up in the speaker client list of the event.

        And finally i get error messages executing the script to enable the speaker.:

        Sub Main(ByVal parms as object)
        Dim parmArray() As String
        parmArray = parms.ToString().Split(",")
        hs.PluginFunction("AirplaySpeak", "", "SetSpeakerEnabled", new Object() (parmArray(0), Convert.ToBoolean(parmArray(1))))
        End Sub

        the errors are:
        un-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (System.String[], System.Int32, System.StringSplitOptions)
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (System.String[], System.StringSplitOptions)
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (System.Char[], System.Int32, System.StringSplitOptions)
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (System.Char[], System.StringSplitOptions)
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (System.Char[], System.Int32)
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: Split (ParamArray System.Char[])
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: '(System.String)' of 6 initial candidates
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: After removing narrowing (except object) candidates for method 'Split', nothing was found
        Jun-26 12:06:52 PM Error Compiling script /usr/local/HomeSeer/scripts/Enable_iHome.vb: The import 'System.Core' could not be found.

        I'm also getting spammed with these messages in the log:


        Jun-26 12:05:11 PM AirplaySpeak DEBUG 13 Speaker.OnCheckStatusTimerEvent() gets the lock
        Jun-26 12:05:11 PM AirplaySpeak DEBUG 17 Speaker.OnCheckStatusTimerEvent()
        Jun-26 12:05:10 PM AirplaySpeak DEBUG 16 Speaker.OnCheckStatusTimerEvent() gets the lock

        Finally, when i manually add the speaker in THE event, and trigger it, i get this error : INFO Connection to iW3 (192.168.0.114:2253) failed: Request failed, error RTSP/1.0 500 Internal Server Error

        Jun-27 2:57:50 PM AirplaySpeak DEBUG 20 Speaker.AfterSend()
        Jun-27 2:57:50 PM AirplaySpeak DEBUG 20 Speaker.SendSample() gets lock
        Jun-27 2:57:50 PM AirplaySpeak DEBUG 20 Speaker.SendSample()
        Jun-27 2:57:50 PM AirplaySpeak DEBUG 20 Speaker.BeforeSend()
        Jun-27 2:57:50 PM AirplaySpeak DEBUG Stack: at RTSPClient.ExecRequest (System.String Cmd, System.String ContentType, System.String Content, System.Net.WebHeaderCollection hds, Boolean GetResponse, System.String& returnCode, Boolean parseHeaderOnError) [0x00000] in :0 at RTSPClient.ExecRequest (System.String Cmd, System.String ContentType, System.String Content, System.Net.WebHeaderCollection hds, Boolean GetResponse, Boolean parseHeaderOnError) [0x00000] in :0 at RTSPClient.Setup (Int32 controlport, Int32 timingport) [0x00000] in :0 at RAOPClient.Connect () [0x00000] in :0 at HSPI_AIRPLAY_SPEAK.Speaker.Reset () [0x00000] in :0
        Jun-27 2:57:50 PM AirplaySpeak INFO Connection to iW3 (192.168.0.114:2253) failed: Request failed, error RTSP/1.0 500 Internal Server Error
        Jun-27 2:57:49 PM AirplaySpeak DEBUG SETUP rtsp://192.168.0.108/3096923849 RTSP/1.0 CSeq: 2 Transport: RTP/AVP/UDP;unicast;interleaved=0-1;mode=record;control_port=50925;timing_port=59412 User-Agent: iTunes/7.6.2 ( Windows;N Client-Instance: 946E890429404AEA
        Jun-27 2:57:49 PM AirplaySpeak DEBUG CSeq, 1
        Jun-27 2:57:49 PM AirplaySpeak DEBUG Server, AirTunes/103.2
        Jun-27 2:57:49 PM AirplaySpeak DEBUG ANNOUNCE rtsp://192.168.0.108/3096923849 RTSP/1.0 CSeq: 1 Content-Type: application/sdp Content-Length: 184 User-Agent: iTunes/7.6.2 ( Windows;N Client-Instance: 946E890429404AEA v=0 o=iTunes 3096923849 0 IN IP4 192.168.0.108 s=iTunes c=IN IP4 192.168.0.114 t=0 0 m=audio 0 RTP/AVP 96 a=rtpmap:96 AppleLossless a=fmtp:96 352 0 16 40 10 14 2 255 0 0 44100
        Jun-27 2:57:49 PM AirplaySpeak DEBUG 20 Speaker.Reset() gets the lock
        Jun-27 2:57:49 PM AirplaySpeak DEBUG 20 Speaker.Reset()
        Jun-27 2:57:49 PM AirplaySpeak INFO (iW3): Hello there. Good morning.
        Jun-27 2:57:48 PM AirplaySpeak DEBUG calling SpeakToFile text=Hello there. Good morning. file=/usr/local/HomeSeer/Temp/AirplaySpeak20160627145748714.wav
        Jun-27 2:57:48 PM Event Event Trigger "Test Group Speak test"
        Jun-27 2:57:48 PM Event Event Test Group Speak test triggered by the event page 'Run' button.

        Looks like quite some things are wrong.
        Help please!
        Last edited by stevenseh@gmail.com; June 27th, 2016, 05:22 PM. Reason: More info

        Comment


        • #19
          Originally posted by chimera View Post
          Ok. It appears there are some compatibility problems with Airplay & Ubiquity. I fired up a windows vm to test if it was something to do with the Linux implementation but had the same almost instant drop outs on Windows. Now I read that lots of people are having problems with Ubuqiti and Airplay. Interestingly though the problems for me at least are not occurring with iTunes. I have re-setup my Apple Airport and the Airplay speak plugin is back to being it's old self. Man this is a minefield. I am going to send off some wireshark traces to Ubiquiti to see what they have to say.
          I gave up on Ubiquity as they weren't interested in troubleshooting. I've moved to a new brand and have the reliability and range that I'm looking for. Avoid Ubiquiti when using this plugin!

          Comment


          • #20
            Errors after install on HomeTroller Zee S2

            I've installed the AirplaySpeak plugin onto my HomeTroller Zee S2 (just got it) but I'm seeing the same error in the log as tfunk discusses here (https://forums.homeseer.com/showthread.php?t=185444).

            I tried to follow the steps in the prerequisites here (https://forums.homeseer.com/showthre...=airplay+linux) but it indicates that various other dependent packages are not installed.

            Is there a HomeTroller-specific guide for getting this to work?

            Great plugin-- can't wait to get it going!

            Thanks very much for any and all assistance!

            Comment


            • #21
              Originally posted by MichaelCreamer View Post
              I've installed the AirplaySpeak plugin onto my HomeTroller Zee S2 (just got it) but I'm seeing the same error in the log as tfunk discusses here (https://forums.homeseer.com/showthread.php?t=185444).

              I tried to follow the steps in the prerequisites here (https://forums.homeseer.com/showthre...=airplay+linux) but it indicates that various other dependent packages are not installed.

              Is there a HomeTroller-specific guide for getting this to work?

              Great plugin-- can't wait to get it going!

              Thanks very much for any and all assistance!
              Sorry for the very late reply.
              This problem is fixed in version 3.0.0.12, I have successfully tested the AirplaySpeak plug-in on the latest Zee2 version.
              I have also updated the guide at the beginning of this thread.

              Comment


              • #22
                Thanks for the guide, the plug-in would not start until I ran the commands, almost deleted the plug-in as it wasn't working. Now it works great and speaks through my Denon S720H amp and ceiling speakers. Very cool, haven't had a way to make HS3 speak before.

                Odd thing is plug-in only showed a 1 day trial, is that how it is supposed to be or should it not provide a 30 day trial? I ended up buying the plug-in since it is currently on sale, but found it odd that there was only a 1 day trial and thought you may want to look into this? I was also running EasyTrigger with 4 days left of its trial, could that have confused AirplaySpeak? But even after registering EasyTrigger, AirplaySpeak still only showed a 1 day trial...

                Comment


                • #23
                  Originally posted by numgis View Post
                  Thanks for the guide, the plug-in would not start until I ran the commands, almost deleted the plug-in as it wasn't working. Now it works great and speaks through my Denon S720H amp and ceiling speakers. Very cool, haven't had a way to make HS3 speak before.

                  Odd thing is plug-in only showed a 1 day trial, is that how it is supposed to be or should it not provide a 30 day trial? I ended up buying the plug-in since it is currently on sale, but found it odd that there was only a 1 day trial and thought you may want to look into this? I was also running EasyTrigger with 4 days left of its trial, could that have confused AirplaySpeak? But even after registering EasyTrigger, AirplaySpeak still only showed a 1 day trial...
                  If it's the first time you installed AirplaySpeak, it should have been a 30day trial. I don't know what could be causing this, and the licensing mechanism is entirely handled by HS3 itself, so I can't investigate more myself.

                  Comment


                  • #24
                    Thanks Spud, no worries since I purchased your plug-in now. One question, can I change the voice and rate of speech? I'm running on Linux. Thanks

                    Comment


                    • #25
                      Issued Solved. Apparently the "apt-get install libav-tools" failed since no avconv was found in the /usr/bin directory. Did an "apt-get purge libav-tools" then reran the installation and everything worked. Strange!

                      Might I humbly suggest when it doesn't seem to be working execute a "man avconv". If you don't get the instructions on avconv it's likely it didn't load.

                      Originally posted by spud View Post
                      Prerequisites:


                      Connect to your Homeseer machine using ssh, and run the following command:
                      Code:
                      sudo apt-get update
                      To auto discover the Airplay speakers on your network the plugin needs avahi-daemon to be installed and running (Avahi is the equivalent of Bonjour for Linux). On Zee2 or SEL it should already be installed and running, but if it's not run the following command:

                      Code:
                      sudo apt-get install avahi-daemon
                      To resample audio files the plugin also needs avconv. (On some distributions avconv is not available in this case use ffmpeg instead)

                      Code:
                      sudo apt-get install libav-tools
                      then from your HomeSeer directory (/usr/local/HomeSeer) edit the file speak_to_file.sh
                      Code:
                      sudo nano speak_to_file.sh
                      and replace its content with the following (replace avconv by ffmpeg on the third line if necessary)
                      Code:
                      #!/bin/sh
                      flite -o "$1_t" -t "$2"
                      avconv -i "$1_t" -y -ar 44100 "$1"
                      rm "$1_t"
                      Let me know if you have any problem.
                      Read the User Guide for more information.
                      I was getting the 44.1 Khz error on my Zee S2 so I follow the above instructions less adding Bonjour since it's already loaded. Now I'm getting the following error.

                      AirplaySpeak ERROR File /usr/local/HomeSeer/Temp/AirplaySpeak20180115183903678.wav

                      Also, I rebooted hs3 and I no longer see the local speaker client in the selection list nor the AirPlay client but they show them in the log.

                      BTW, If it's important I'm using Shairport-sync on the Pi. It would fine with iTunes.

                      Jan-15 6:47:31 PM Device Control Device: Virtual Status Room Status Office is On to On (100)
                      Jan-15 6:47:31 PM Event Event Trigger "Office Office - Status Any Lights On"
                      Jan-15 6:47:28 PM Device Control Device: Virtual Status Room Status Office is On to On (100)
                      Jan-15 6:47:28 PM Event Event Trigger "Office Office - Status Any Lights On"
                      Jan-15 6:47:26 PM Z-Wave Device: Lighting Office Right Desk Set to Dim 50%
                      Jan-15 6:47:26 PM Z-Wave Device: Lighting Office Left Desk Set to Dim 68%
                      Jan-15 6:47:22 PM Z-Wave Starting Z-Wave Polling for Network F9B23B15...
                      Jan-15 6:47:07 PM AirplaySpeak ERROR File /usr/local/HomeSeer/Temp/AirplaySpeak20180115184705552.wav does not exist
                      Jan-15 6:47:06 PM TTS Speak: ():Welcome to Home-Seer
                      Jan-15 6:47:06 PM AirplaySpeak INFO (Raspberrypi): Welcome to Home-Seer
                      Jan-15 6:47:05 PM Info System connected to MyHS Service successfully with license ID 98688.
                      Jan-15 6:47:05 PM Startup Start up complete.
                      Jan-15 6:47:05 PM Info System connected to MyHS Service, waiting for acknowledge...
                      Jan-15 6:47:05 PM Info Latest BETA update available is: 3.0.0.399
                      Jan-15 6:47:05 PM Info Latest update available is: 3.0.0.368
                      Jan-15 6:47:05 PM Startup Scripting is OK and is now running Startup.vb
                      Jan-15 6:47:05 PM Info Checking for updates...
                      Jan-15 6:47:05 PM Startup HSSentry is disabled in Setup, sentry will not be started.
                      Jan-15 6:47:05 PM Startup Starting Event Scheduler...
                      Jan-15 6:47:00 PM Startup Running the startup script Startup.vb
                      Jan-15 6:47:00 PM Startup Starting Find service...
                      Jan-15 6:47:00 PM Startup Updater services starting...
                      Jan-15 6:46:59 PM Web Server Web Server authorized local login successful from: 10.0.1.101 User: admin
                      Jan-15 6:46:59 PM Database Opening (Mode=Read/Write) up HomeSeer Energy database /usr/local/HomeSeer/Data/Energy/Energy.hsd
                      Jan-15 6:46:59 PM Speech Listening for remote speaker connections on port 10401
                      Jan-15 6:46:59 PM Startup Initializing Speaker Client Interface
                      Jan-15 6:46:59 PM Startup Start automation engine...
                      Jan-15 6:46:59 PM Web Server UPNP Discovery started
                      Jan-15 6:46:59 PM Web Server Web Server started on port 80
                      Jan-15 6:46:59 PM Web Server Local IP address is: 10.0.1.65
                      Jan-15 6:46:59 PM Z-Wave ************************************************************ *******************
                      Jan-15 6:46:59 PM Z-Wave STARTUP COMPLETE: All configured interfaces were successfully initialized.
                      Jan-15 6:46:59 PM Z-Wave ************************************************************ *******************
                      Jan-15 6:46:59 PM Startup HStouch server started, waiting for clients to connect.
                      Jan-15 6:46:59 PM HSTouch Server Server started on port 10200
                      Jan-15 6:46:58 PM Plug-In Finished initializing plug-in AirplaySpeak
                      Jan-15 6:46:58 PM AirplaySpeak INFO Resolved Service: AF31192A3A11 - Raspberrypi - 10.0.1.16 - 5000
                      Jan-15 6:46:58 PM AirplaySpeak INFO Found Service: AF31192A3A11@Raspberrypi
                      Jan-15 6:46:58 PM AirplaySpeak INFO AirplaySpeak version 3.0.0.12
                      Jan-15 6:46:58 PM Info Plugin AirplaySpeak has connected. IP:127.0.0.1:42361
                      Jan-15 6:46:57 PM Plug-In Interface AirplaySpeak is running as a trial, 30 days remaining.
                      Jan-15 6:46:57 PM Plug-In Finished initializing plug-in EasyTrigger
                      Jan-15 6:46:57 PM EasyTrigger INFO Found 25 device group value triggers
                      Jan-15 6:46:56 PM EasyTrigger INFO Refreshing list of device group value triggers to monitor
                      Jan-15 6:46:56 PM EasyTrigger INFO Found 0 random triggers
                      Jan-15 6:46:56 PM EasyTrigger INFO Refreshing list of random triggers to monitor
                      Jan-15 6:46:56 PM EasyTrigger INFO Found 0 schedule triggers
                      Jan-15 6:46:56 PM EasyTrigger INFO Refreshing list of schedule triggers to monitor
                      Jan-15 6:46:56 PM EasyTrigger INFO Found 0 device's value conditions that need monitoring
                      Jan-15 6:46:56 PM EasyTrigger INFO Found 0 device's value triggers
                      Jan-15 6:46:56 PM EasyTrigger INFO Refreshing list of device's value triggers to monitor
                      Jan-15 6:46:56 PM EasyTrigger INFO Found 0 device's string triggers
                      Jan-15 6:46:56 PM EasyTrigger INFO Refreshing list of device's string triggers to monitor
                      Jan-15 6:46:56 PM Z-Wave Internal: ............................................................ ..........
                      Jan-15 6:46:56 PM Z-Wave Internal: .............................. FINISHED ..............................
                      Jan-15 6:46:56 PM Z-Wave Internal: ............................................................ ..........
                      Jan-15 6:46:56 PM Z-Wave Internal is the SIS for the network.
                      Jan-15 6:46:56 PM Z-Wave Internal There is a SUC/SIS in the network.
                      Jan-15 6:46:56 PM Z-Wave Internal Controller is static lib.
                      Jan-15 6:46:56 PM Z-Wave Internal Controller chip type is ZW050x.
                      Jan-15 6:46:56 PM Z-Wave The interface's security support has been set.
                      Jan-15 6:46:55 PM Z-Wave Internal: Found 46 Z-Wave nodes in interface node ID 1 (Internal)
                      Jan-15 6:46:55 PM Z-Wave Internal: Z-Wave interface node ID: 1, Home ID: F9B23B15
                      Jan-15 6:46:55 PM Z-Wave Internal: Z-Wave Serial API version: 5
                      Jan-15 6:46:55 PM Z-Wave Internal: Z-Wave services for the SECURITY COMMAND CLASS were successfully started.
                      Jan-15 6:46:55 PM Z-Wave Internal: Controller firmware version: 4.32
                      Jan-15 6:46:55 PM Z-Wave Internal: Controller Manufacturer: Express Controls, ID=0x2, Type=0x5
                      Jan-15 6:46:53 PM EasyTrigger INFO EasyTrigger version 3.0.0.42
                      Jan-15 6:46:53 PM Info Plugin EasyTrigger has connected. IP:127.0.0.1:42358
                      Jan-15 6:46:53 PM Z-Wave Internal: Getting node information from controller...
                      Jan-15 6:46:53 PM Z-Wave Internal: The Z-Wave API Execution Thread was Started or Restarted.
                      Jan-15 6:46:53 PM Z-Wave Starting 'Z-Wave Health' Process Starter for (Warren Family)...
                      Jan-15 6:46:52 PM Z-Wave Internal: The Z-Wave Command Execution Thread was Started or Restarted.
                      Jan-15 6:46:52 PM Z-Wave Internal: ----------------------------------------------------------------------
                      Jan-15 6:46:52 PM Z-Wave Initializing Z-Wave interface Internal (Internal) on /dev/ttyAMA0
                      Jan-15 6:46:52 PM Z-Wave Internal: ----------------------------------------------------------------------
                      Jan-15 6:46:52 PM Z-Wave Internal: ============================================================ ==========
                      Jan-15 6:46:52 PM Z-Wave 465 Simple AV Control Command Class Control Commands have been loaded successfully.
                      Jan-15 6:46:52 PM Z-Wave 5 event actions were loaded from HomeSeer.
                      Jan-15 6:46:52 PM Plug-In Finished initializing plug-in Z-Wave
                      Jan-15 6:46:52 PM Z-Wave 0 event triggers were loaded from HomeSeer.
                      Jan-15 6:46:51 PM Z-Wave 85 total Z-Wave Data Objects loaded.
                      Jan-15 6:46:51 PM Z-Wave Network F9B23B15 has 85 device data elements.
                      Jan-15 6:46:51 PM Z-Wave 1 Networks were restored from the data in the database... Building data connections.
                      Jan-15 6:46:51 PM Z-Wave Loading Z-Wave Data Objects...
                      Jan-15 6:46:51 PM Z-Wave 1 total Z-Wave Network Objects loaded.
                      Jan-15 6:46:51 PM Z-Wave Loading Z-Wave Network Objects...
                      Jan-15 6:46:50 PM Z-Wave Database: Opening (Mode=Read Only) up HomeSeer database /usr/local/HomeSeer/Data/Z-Wave/Z-Wave2.db
                      Jan-15 6:46:50 PM Z-Wave InitIO called, plug-in version 3.0.1.130 is being initialized...
                      Jan-15 6:46:50 PM Info Plugin Z-Wave has connected. IP:127.0.0.1:42356
                      Jan-15 6:46:48 PM Startup Initializing Plug-Ins
                      Jan-15 6:46:48 PM Plug-In Found plug-in: Z-Wave, version: 3.0.1.130
                      Jan-15 6:46:47 PM Plug-In Found plug-in: PHLocation, version: 3.0.1.109
                      Jan-15 6:46:46 PM Plug-In Found plug-in: EasyTrigger, version: 3.0.0.42
                      Jan-15 6:46:25 PM Plug-In Found plug-in: AirplaySpeak, version: 3.0.0.12
                      Jan-15 6:46:24 PM Startup Checking for available plug-ins
                      Jan-15 6:46:24 PM Info Remote plug-in API interface started on port 10400
                      Jan-15 6:46:24 PM Startup This version of HomeSeer is registered as a HS3ZEES2 version.
                      Jan-15 6:46:24 PM Startup Creating Speaker Client Interface Object...
                      Jan-15 6:46:24 PM Startup HomeSeer version is: 3.0.0.368
                      Jan-15 6:46:24 PM Load Config Loading TIMERS...
                      Jan-15 6:46:24 PM Load Config Loading COUNTERS...
                      Jan-15 6:46:24 PM Load Config 207 total events loaded.
                      Jan-15 6:46:23 PM Load Config Loading Events...
                      Jan-15 6:46:23 PM Load Config Loading Event Groups...
                      Jan-15 6:46:23 PM Load Config 162 total devices loaded.
                      Jan-15 6:46:22 PM Database Loading Devices...
                      Jan-15 6:46:22 PM Database Opening (Mode=Read/Write) up HomeSeer LOG database /tmp/HomeSeerLog.hsd
                      Jan-15 6:46:21 PM Database Opening (Mode=Read Only) up HomeSeer database /usr/local/HomeSeer/Data/HomeSeerData.hsd
                      Jan-15 6:46:21 PM Startup Loading configuration file ...
                      Jan-15 6:46:21 PM Startup Database SAVE process started.
                      Jan-15 6:46:21 PM Startup Local voice recognition class started.
                      Jan-15 6:46:21 PM Startup Plug-In Interface class started.
                      Jan-15 6:46:21 PM Startup E-Mail RECEIVE class started.
                      Jan-15 6:46:21 PM Startup E-Mail SEND class started.
                      Jan-15 6:46:21 PM Startup Web server class started.
                      Jan-15 6:46:21 PM Startup Application interface class started.
                      Jan-15 6:46:21 PM Startup COM port classes started.
                      Jan-15 6:46:21 PM Startup Creating Class Objects...
                      Jan-15 6:46:21 PM Startup
                      Jan-15 6:46:21 PM Startup ************************************************************ ********************
                      Jan-15 6:46:21 PM Startup HomeSeer version 3.0.0.368 Edition: HS3 ZEE S2 Starting Now
                      Jan-15 6:46:21 PM Startup ************************************************************ ********************
                      Jan-15 6:46:21 PM Startup
                      Jan-15 6:46:18 PM Startup Settings Loaded.
                      Last edited by Timon; January 16th, 2018, 09:05 AM. Reason: Solved
                      HomeSeer Version: HS3 Standard Edition 3.0.0.531 | Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:02:17 UTC 2019)
                      Linux version: Linux auto 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
                      IP Address: 10.0.2.16 | Number of Devices: 417 | Number of Events: 667 | Available Threads: 399 | HSTouch Enabled: True

                      Enabled Plug-Ins: AirplaySpeak: 3.0.0.13 | BLBackup: 2.0.61.0 | EasyTrigger: 3.0.0.65 | LiftMaster MyQ: 1.3.7006.42100
                      mcsMQTT: 4.0.2.2 | PHLocation2: 3.0.0.53 | Pushover 3P: 0.0.0.45 | Z-Wave: 3.0.1.262

                      Z-Net version: 1.0.23 using a HomeSeer SmartStick+: 6.04 (ZDK 6.81.3)

                      Comment


                      • #26
                        Originally posted by Timon View Post
                        I was getting the 44.1 Khz error on my Zee S2 so I follow the above instructions less adding Bonjour since it's already loaded. Now I'm getting the following error.

                        AirplaySpeak ERROR File /usr/local/HomeSeer/Temp/AirplaySpeak20180115183903678.wav

                        Also, I rebooted hs3 and I no longer see the local speaker client in the selection list nor the AirPlay client but they show them in the log.

                        BTW, If it's important I'm using Shairport-sync on the Pi. It would fine with iTunes.
                        try to run the speak_to_file.sh script manually to see if it works as expected:

                        Code:
                        sudo speak_to_file.sh /usr/local/HomeSeer/Temp/AirplaySpeakTest.wav "This is a test"
                        it is supposed to generate a wav file in the Temp folder, so check that you don't get any error when running the script and that the file is generated.

                        Comment


                        • #27
                          Originally posted by spud View Post
                          try to run the speak_to_file.sh script manually to see if it works as expected:

                          Code:
                          sudo speak_to_file.sh /usr/local/HomeSeer/Temp/AirplaySpeakTest.wav "This is a test"
                          it is supposed to generate a wav file in the Temp folder, so check that you don't get any error when running the script and that the file is generated.
                          Thanks Spud. I got up early thing morning and have been debugging it and finally found the problem. For some reason the "sudo apt-get install libav-tools" failed so avconv never loaded. Not sure what happen but I ran an "sudo apt-get purge libav-tools" then installed again and everything worked fine.

                          Just one of those Murphy days I guess.

                          Anyway, I'm excited and will now start working on my Raspberry Pi Zero AirPlay speakers. So many way to do it with the different modules available for the Zero. I'd like to do one with status indicators that you could set from HS3. There is one board for the Zero that has two rows of 8 RGB LED which would make for a great status display built into the speaker. My test bed for that will be the Pimoroni Pirate Radio - Pi Zero W Project Kit which uses the Pimoroni pHAT BEAT for Raspberry Pi Zero. The kit is a bit expensive but it's good for a prototype to get started. Maybe you might be interested in adding support if it works out.
                          Last edited by Timon; January 16th, 2018, 09:23 AM.
                          HomeSeer Version: HS3 Standard Edition 3.0.0.531 | Mono JIT compiler version 5.20.1.19 (tarball Thu Apr 11 09:02:17 UTC 2019)
                          Linux version: Linux auto 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
                          IP Address: 10.0.2.16 | Number of Devices: 417 | Number of Events: 667 | Available Threads: 399 | HSTouch Enabled: True

                          Enabled Plug-Ins: AirplaySpeak: 3.0.0.13 | BLBackup: 2.0.61.0 | EasyTrigger: 3.0.0.65 | LiftMaster MyQ: 1.3.7006.42100
                          mcsMQTT: 4.0.2.2 | PHLocation2: 3.0.0.53 | Pushover 3P: 0.0.0.45 | Z-Wave: 3.0.1.262

                          Z-Net version: 1.0.23 using a HomeSeer SmartStick+: 6.04 (ZDK 6.81.3)

                          Comment


                          • #28
                            On Debian 9 it seems flite does not get installed automatically with libav-tools and therefore AirplaySpeak fails saying the wav file does not exist.

                            AirplaySpeak ERROR File /usr/local/HomeSeer/Temp/AirplaySpeak20180204153825718.wav does not exist

                            Solution was to separately install flite.. so while logged in as root I had to run the following commands, now AirplaySpeak works:

                            apt-get install avahi-daemon
                            apt-get install libav-tools
                            apt-get install flite

                            Comment


                            • #29
                              spud I seem to have an issue where when I ask it to play a file, it is passing my wave file to the speak_to_file.sh script. Here is my HomeSeer stats:

                              Code:
                              Current Date/Time: 3/8/2019 2:35:27 PM
                              HomeSeer Version: HS3 Standard Edition 3.0.0.500
                              Linux version: Linux parrha 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux System Uptime: 4 Days 3 Hours 29 Minutes 40 Seconds
                              IP Address: 192.168.2.253
                              Number of Devices: 247
                              Number of Events: 150
                              Available Threads: 399
                              HSTouch Enabled: True
                              Event Threads: 0
                              Event Trigger Eval Queue: 0
                              Event Trigger Priority Eval Queue: 0
                              Device Exec Queue: 0
                              HSTouch Event Queue: 0
                              Email Send Queue: 0
                              
                              Enabled Plug-Ins
                              3.0.0.13: AirplaySpeak
                              2.0.43.0: BLLAN
                              3.0.0.56: EasyTrigger
                              3.0.0.32: Ecobee
                              3.0.0.108: LutronCaseta
                              0.0.0.45: Pushover 3P
                              3.0.0.6: SonyTV
                              3.0.5960.36744: UltraSighthoundVideo3
                              3.0.1.252: Z-Wave
                              Here is a snippet of the error:
                              Code:
                              In SpeakDev calling a speak proxy plug-in, exception is ApplicationName='./speak_to_file.sh', CommandLine=''/usr/local/HomeSeer/Temp/AirplaySpeak20190308143949364.wav' 'iH vb dY 4. �� �{ "��b�s���-48b3�(������������
                              A lot more of the gibberish obviously as it tried to convert my entire wav file.

                              TTS is working great. Although I'm not using your version above, I'm using curl to pull from voicerss to get better voices. Screenshot of the event in case there is something there I screwed up.

                              Thanks!
                              Attached Files

                              Comment


                              • #30
                                Originally posted by Shawn Parr View Post
                                spud I seem to have an issue where when I ask it to play a file, it is passing my wave file to the speak_to_file.sh script. Here is my HomeSeer stats:

                                Code:
                                Current Date/Time: 3/8/2019 2:35:27 PM
                                HomeSeer Version: HS3 Standard Edition 3.0.0.500
                                Linux version: Linux parrha 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux System Uptime: 4 Days 3 Hours 29 Minutes 40 Seconds
                                IP Address: 192.168.2.253
                                Number of Devices: 247
                                Number of Events: 150
                                Available Threads: 399
                                HSTouch Enabled: True
                                Event Threads: 0
                                Event Trigger Eval Queue: 0
                                Event Trigger Priority Eval Queue: 0
                                Device Exec Queue: 0
                                HSTouch Event Queue: 0
                                Email Send Queue: 0
                                
                                Enabled Plug-Ins
                                3.0.0.13: AirplaySpeak
                                2.0.43.0: BLLAN
                                3.0.0.56: EasyTrigger
                                3.0.0.32: Ecobee
                                3.0.0.108: LutronCaseta
                                0.0.0.45: Pushover 3P
                                3.0.0.6: SonyTV
                                3.0.5960.36744: UltraSighthoundVideo3
                                3.0.1.252: Z-Wave
                                Here is a snippet of the error:
                                Code:
                                In SpeakDev calling a speak proxy plug-in, exception is ApplicationName='./speak_to_file.sh', CommandLine=''/usr/local/HomeSeer/Temp/AirplaySpeak20190308143949364.wav' 'iH vb dY 4. �� �{ "��b�s���-48b3�(������������
                                A lot more of the gibberish obviously as it tried to convert my entire wav file.

                                TTS is working great. Although I'm not using your version above, I'm using curl to pull from voicerss to get better voices. Screenshot of the event in case there is something there I screwed up.

                                Thanks!
                                Uncheck the "Speak the contents of the file" checkbox.
                                If the plugin detects the parameter is a file path, it will play the file.

                                Comment

                                Working...
                                X