Announcement

Collapse
No announcement yet.

Pico voice not working - .wav file not found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pico voice not working - .wav file not found

    After I installed some pico (from another thread: http://board.homeseer.com/showthread...ght=pico+voice ), I get the error log below - and no sound... -

    Aug-11 8:44:00 AM AirplaySpeak ERROR File /usr/local/HomeSeer/Temp/AirplaySpeak20160811084400192.wav does not exist
    Aug-11 8:44:00 AM AirplaySpeak INFO (iW3): Volume at 15
    Aug-11 8:44:00 AM AirplaySpeak DEBUG calling SpeakToFile text=Volume at 15 file=/usr/local/HomeSeer/Temp/AirplaySpeak20160811084400192.wav

    Looks like pico puts the file somewhere else?
    Any ideas?
    Thanks,
    Eric

  • #2
    Nobody ran in to this issue yet? I still could not figure out how this can be fixed...
    Any help is welcome!

    Comment


    • #3
      are you sure your speak_to_file.sh works?
      did you try to call it from the command line to test?
      Code:
      speak_to_file.sh test.wav "ths is a test"

      Comment


      • #4
        When I enter the command

        speak_to_file.sh test.wav "this is a test"

        in directory
        homeseer@HomeTrollerZeeS2 /usr/local/HomeSeer $

        I get this error message:

        -bash: speak_to_file.sh: command not found



        This is what I had in the speak_to_file.sh:

        ##!/bin/sh
        #flite -o "$1_t" -t "$2"
        #ffmpeg -i "$1_t" -y -ar 44100 "$1"
        #rm "$1_t"
        #!/bin/sh
        pico2wave -l en-US -w "$1" "$2"
        ffmpeg -i "$1_t" -y -ar 44100 "$1"
        #pico2wave -l en-GB -w "$1" "$2"

        at least when I was testing pico.

        To get the standard voice, I'm using

        #!/bin/sh
        flite -o "$1_t" -t "$2"
        ffmpeg -i "$1_t" -y -ar 44100 "$1"
        #rm "$1_t"
        ##!/bin/sh
        #pico2wave -l en-US -w "$1" "$2"
        #ffmpeg -i "$1_t" -y -ar 44100 "$1"
        ##pico2wave -l en-GB -w "$1" "$2"

        Comment


        • #5
          if I run

          pico2wave -l en-US -w test.wav "this is a test"

          it creates the test.wav file OK in the directory where I run it.

          Seems to me that that's as expected. Not sure why it doesn't put the output file in the right spot for the plugin to pick it up.
          Last edited by stevenseh@gmail.com; August 17th, 2016, 06:40 AM.

          Comment

          Working...
          X