Announcement

Collapse
No announcement yet.

Onkyo Connection Refused?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ryanoly
    replied
    I am a complete idiot. Having two systems has been confusing. I had the denon setup on both systems.

    After I deleted the denon from the system 1 i got it to work on the system i want it to work. I assume i was getting connection refused because the first system was already accessing it.

    Leave a comment:


  • ryanoly
    started a topic Onkyo Connection Refused?

    Onkyo Connection Refused?

    I uninstalled bldenon and reinstalled it. I can't get it working again. I can ping the reciever and the plugin creates the devices.

    I've tried several variations of deleting the devices and add it again. Reinstalled the plugin. I enabled debug and took a look at the log.

    I see connection refused on Onkyo. I assume that is because this code was probably based on the Onkyo plugin not because it actually thinks it is communicating with an Onkyo reciever.

    Below is an excerpt from the log. I could attach the whole thing. I also updated my reciever to the latest firmware. It is AVR-E300. I can ping the denon and access the web interface on the IP below.

    i'm starting to wonder if I have the wrong port number. I've tried a few of them. Honestly I don't remember what i used when i first had it setup.

    Not sure if this is an issue. But I do have two homeseers. Only one of them has the bldenon plug in enabled. Maybe if all else fails i'll try the other homeseer to see if i can get it to work.

    Is my license good for both homeseer controllers?g

    Receiver:
    ---------
    Number: 1
    Name: kids_denon
    ConnectionType: TCP
    ComPort:
    IpAddress: 192.168.0.210
    Port: 23
    PingFailuresForDisconnect: 3
    PingFailureCount: 0
    RawMessageDevice:
    Connected: False
    Restart1TimeHour:
    Restart1TimeMinute:
    Restart1TimeAMPM:
    Restart2TimeHour:
    Restart2TimeMinute:
    Restart2TimeAMPM:
    ShowZone2Devices: False
    ShowZone3Devices: False

    11/19/2017 9:25:29 AM : v2.0.45.0 - Connect_To_Denon_Receiver(): ERROR - Caught this exception connecting to Onkyo receiver - Connection refused
    11/19/2017 9:25:29 AM : v2.0.45.0 - Connect_To_Denon_Receiver() finished
    11/19/2017 9:25:29 AM : v2.0.45.0 - Check_Receiver_Connection() finished
    11/19/2017 9:25:29 AM : v2.0.45.0 - Check_Receiver_Restart() started
    11/19/2017 9:25:29 AM : v2.0.45.0 - Receivers() started
    11/19/2017 9:25:29 AM : v2.0.45.0 - Receivers(): allReceivers.length --> 1
    11/19/2017 9:25:29 AM : v2.0.45.0 - Receivers() finished
    11/19/2017 9:25:29 AM : v2.0.45.0 - Check_Receiver_Restart(): * Processing receiver -->
Working...
X