Announcement

Collapse
No announcement yet.

Issue with new version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with new version

    So, I updated all of my plugins from Blade (BLBackup, BLRfid, BLRadar, BLDenon) and as usual, needed to restart HS3Pro (3.0.0.398, Windows 10) for them to take. At startup, I got the following:
    6/7/2018 5:37:04 AM ~!~Error~!~Initializing plug-in(2): BLDenon Instance::Object reference not set to an instance of an object.STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()Startup Complete, 1 errors detected, check the log for more information.

    So, I decided to shut down HS3 and restart it. I did not get the BLDenon error, but I did get the following:
    6/7/2018 5:46:05 AM ~!~Error~!~Initializing plug-in(2): BLRadar Instance::Object reference not set to an instance of an object.STACK:Server stack trace: Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessag e(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Mess ageData& msgData, Int32 type) at HomeSeerAPI.IPlugInAPI.InitIO(String port) at Scheduler.clsHSPI.CheckInterfaces()


    So, something is amiss with these updates.

    Elliott

  • #2
    I have not seen this one before
    Looks like the error is coming from HS3 which is strange because the InitIO method was never changed in the any of the plugins

    Let me see if I can duplicate this when I update some of mine when I get home
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      As far as I know, this might happen if a plugin process is already running and HS3 is trying to start another one.
      HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
      Running on Windows 10 (64) virtualized
      on ESXi (Fujitsu Primergy TX150 S8).
      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

      Comment


      • #4
        Originally posted by Blade View Post
        I have not seen this one before
        Looks like the error is coming from HS3 which is strange because the InitIO method was never changed in the any of the plugins

        Let me see if I can duplicate this when I update some of mine when I get home
        Originally posted by Moskus View Post
        As far as I know, this might happen if a plugin process is already running and HS3 is trying to start another one.
        Thanks, all. I think I should reboot the computer and then see if the error comes up. I will do this later today and let you know. Elliott

        Comment


        • #5
          "Reboot and Rejoice"

          An old IT guy where I used to work used to tell us that if we had issues with our computer, before calling IT support, reboot your computer: "Reboot and Rejoice." So, he was right. I rebooted and rejoiced that the issue no longer exists.

          Elliott

          Comment


          • #6
            Glad to hear the reboot fixed it
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment

            Working...
            X