Announcement

Collapse
No announcement yet.

Just bought myself a Denon AVR-E400 receiver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just bought myself a Denon AVR-E400 receiver

    Now to play... and get the plugin communicating with it
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

  • #2
    Hi Bob, are you using HTTP commands to control the AVR?

    I have a 3313CI and I've been tinkering with the TELNET 'like' interface but I am having issues keeping the connection up for extended periods. For whatever reason it just hangs and my connection needs to be reset.

    I am using a keep-alive in the format of the MU? command. If I see the MUON/MUOFF status returned all is well, if I miss a couple I reset the TCP connection.

    For whatever reason it sometimes hangs the TCP server on the AVR and I am unable to connect for extended periods, even directly with a TELNET client.

    I've read that the port 23 interface can be flakey however the HTTP interface is pretty solid.

    The HTTP commands are not readily available and will take some Wireshark captures to reverse engineer what the web interface does.

    I was wondering what your experience has been?

    Cheers,

    Chris

    Comment


    • #3
      I have not had time to play with it yet but I do plan on improving BLDenon going forward
      Cheers,
      Bob
      Web site | Help Desk | Feature Requests | Message Board

      Comment


      • #4
        Hi there. SmartThings user here looking to potentially switch to HomeSeer. i'm checking out compatibility with all my other stuff. Does this plugin work with the Denon AVR-E400?

        Comment

        Working...
        X