Announcement

Collapse
No announcement yet.

HS3 conversion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 conversion

    no controls on the devices. At least lpitmans plugin had On/Off. Is it a bug or do I still have to script everything?

    It would be much easier to have controls on the devices, both for directly control from the web page and for HStouch.
    HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
    Running on Windows 10 (64) virtualized
    on ESXi (Fujitsu Primergy TX150 S8).
    WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

    Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

  • #2
    1. I am aware. I am really not sure what the point of the grouping is for the devices. I bet most people do not even use the device management page to control the devices. The disng their own interface in HSTouch or MainLobby to do all this.

    2. I am aware of this. It is on my list to do. You can use scripting calls to do most things.
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Originally posted by Blade View Post
      1. I am aware. I am really not sure what the point of the grouping is for the devices. I bet most people do not even use the device management page to control the devices. The disng their own interface in HSTouch or MainLobby to do all this.

      2. I am aware of this. It is on my list to do. You can use scripting calls to do most things.
      Hi Blade, and thanks for answering!

      1. The grouping makes sense when you (like me and many others) have a lot of devices and you want to sort them to access them faster.

      I have yet to add any Z-wave or RFXCOM devices to my HS3 server (and believe me there's alot of them) and I already have 185 devices!

      See the difference here:
      http://i.snag.gy/xeNC9.jpg


      2. I use the web interface alot. And I use HStouch on mobile alot. And that works only if the devices has buttons.

      And perhaps the most common use is HStouch or some other interface, but it is much easier to create HStouch interfaces if the buttons are already there. Just select the device and the command, and you're done.


      Thank you for your feedback again. If this is something that will be "fixed" later, I guess there's nothing to stop me from buying this plugin.

      I know you do quality work! That's why this had me puzzled...
      HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
      Running on Windows 10 (64) virtualized
      on ESXi (Fujitsu Primergy TX150 S8).
      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

      Comment


      • #4
        It is definitely something that will get fixed
        After all I have a Denon as well and I need it too

        Do me a favor and add a feature request on my web site for this so I can keep track of it and it does not get forgotten
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Originally posted by Blade View Post
          Do me a favor and add a feature request on my web site for this so I can keep track of it and it does not get forgotten
          Sure, not a problem.
          HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
          Running on Windows 10 (64) virtualized
          on ESXi (Fujitsu Primergy TX150 S8).
          WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

          Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

          Comment


          • #6
            Try 2.0.7 in the HS3 updater.
            I have added controls for the power, mute and volume devices.
            Let me know
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              I have posted 2.0.8 to the updater
              It has a dropdown for the input devices
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                Awesome! I'll have to test it when I get back home.
                HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                Running on Windows 10 (64) virtualized
                on ESXi (Fujitsu Primergy TX150 S8).
                WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                Comment


                • #9
                  I forgot to report back...

                  The controls look nice, but the only one that works is Zone Master, 2 and 3 "standby" and "On", and all mutes.

                  Nothing else...
                  HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                  Running on Windows 10 (64) virtualized
                  on ESXi (Fujitsu Primergy TX150 S8).
                  WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                  Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                  Comment


                  • #10
                    OK which devices are not working? The input ones?

                    Capture me a debug log of the issue and log a help desk ticket on my web site for it.
                    Attach the log zipped to the ticket
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Originally posted by Blade View Post
                      OK which devices are not working? The input ones?

                      Capture me a debug log of the issue and log a help desk ticket on my web site for it.
                      Attach the log zipped to the ticket
                      Great! Will do!
                      HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                      Running on Windows 10 (64) virtualized
                      on ESXi (Fujitsu Primergy TX150 S8).
                      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                      Comment


                      • #12
                        Is there any update regarding the issue with the inputs?

                        I've also got the same problem with the AVR x2000. I can power it on and into standbye. The volume control also works, though the volume status reports different to the device and app.

                        Currently just on the trial but would definitely purchase if these issues can be resolved.

                        I set the debug log to 1 but havent been able to see where the info is logged to.

                        Thanks
                        Chris

                        Comment


                        • #13
                          Blade, I know you have your attention divided on many cool projects (and I haven't been a fast replyer either).

                          But it would be really good to be able to give my amplifier a rest at night and when we are out...


                          I also thought I'd check to see if I could get the scripting functions to work instead, but I only get this:
                          Code:
                          jun-01 21:35:41	  	 Error	 Running script(2) &hs.PluginFunction("BLDenon", "", "SendDenonCommand", {1, "Master Power", "OFF"}), init error: Invalid character
                          jun-01 21:35:41	  	 Event	 Running script statement immediately: &hs.PluginFunction("BLDenon", "", "SendDenonCommand", {1, "Master Power", "OFF"})
                          ... which is weird as I've used hs.PluginFunction with great success earlier (and still do).
                          Last edited by Moskus; June 1st, 2014, 02:22 PM.
                          HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                          Running on Windows 10 (64) virtualized
                          on ESXi (Fujitsu Primergy TX150 S8).
                          WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                          Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                          Comment


                          • #14
                            Where are you running the script command from?

                            If you are running it from the Immediate script command area then it will not work
                            If you put it in a .vb script it will likely work

                            Try this:

                            Code:
                            Sub Main(Byval parm As Object)
                                hs.PluginFunction("BLDenon", "", "SendDenonCommand", New Object(){1, "Master Power", "OFF"})
                            End Sub
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Aha, I should have thought of that. It would just make sense if running that command as a immediate script would work...

                              However, in a script it still does not work. So the problem lies elsewhere, I guess...
                              HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                              Running on Windows 10 (64) virtualized
                              on ESXi (Fujitsu Primergy TX150 S8).
                              WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                              Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                              Comment

                              Working...
                              X