Announcement

Collapse
No announcement yet.

Serial ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Thank you Bob. Appreciate it.

    Originally posted by Blade View Post
    Yes I have that on my list too
    Don

    Comment


    • #17
      Originally posted by Blade View Post
      I would consider the serial beta right now. I cannot test it so I need someone to give it a go and let me know
      Installed without a hitch. Plugin inventoried the receiver and created the devices. Power, volume, input, and every other setting I've tried has worked.

      Will be able to give it a more thorough test this weekend, but so far...so good.

      Well done and thanks,

      - Jim -
      My home is smarter than your honor roll student.

      Comment


      • #18
        Ok...I've been trying really hard to break this....and I haven't been able to yet.

        - Jim -
        My home is smarter than your honor roll student.

        Comment


        • #19
          As a disgruntled Vera user I am currently evaluating Homeseer as a rip and replace option for my Automation.

          Getting this Onkyo plugin working would be a HUGE win for me and will seal the deal/move to Homeseer.

          I put one of my Integra receiver's in and have been testing it for a week. Some of the feedback seems off but my requirements are very simple as I am using dedicated receivers for music zone. Really only looking for volume and power control/status.

          I decided to add my 2 other receivers last night and now none of them are working, including the one that has been working for the past week.

          I am using TCP-->RS232 devices and a comport emulator to do the communication and they indicate when they send/receive data and it appears that the Plugin is no longer sending data.

          Any ideas on where to start troubleshooting this?

          Comment


          • #20
            Originally posted by WinoOutWest View Post
            As a disgruntled Vera user I am currently evaluating Homeseer as a rip and replace option for my Automation.

            Getting this Onkyo plugin working would be a HUGE win for me and will seal the deal/move to Homeseer.

            I put one of my Integra receiver's in and have been testing it for a week. Some of the feedback seems off but my requirements are very simple as I am using dedicated receivers for music zone. Really only looking for volume and power control/status.

            I decided to add my 2 other receivers last night and now none of them are working, including the one that has been working for the past week.

            I am using TCP-->RS232 devices and a comport emulator to do the communication and they indicate when they send/receive data and it appears that the Plugin is no longer sending data.

            Any ideas on where to start troubleshooting this?
            Try this script on the PC that is connected to the receiver. Adjust the com port as required.

            sub main()
            Dim PortNumber
            PortNumber=8
            hs.OpenComPort PortNumber,"9600,n,8,1",1,"",""
            hs.SendToComPort PortNumber, "!1PWR01" & vbcr
            hs.closeComPort PortNumber
            end sub

            IT should turn on your serial receiver. The below should turn it off...

            sub main()
            Dim PortNumber
            PortNumber=8
            hs.OpenComPort PortNumber,"9600,n,8,1",1,"",""
            hs.SendToComPort PortNumber, "!1PWR00" & vbcr
            hs.closeComPort PortNumber
            end sub


            If these work, it might be an issue with the plug-in. If not, your serial connection is wonky. I have a unit connected via Ethernet to dual serial device. My Z-Troller is on another one. I have two others controlling different gear. All have performed well. Lantronix UDS2100 I think is their model.

            I did have some issues when sending some commands via script and others by plug-in. The plug in stopped listening. A restart of the plugin restored service.

            Good luck.

            - Jim-
            Last edited by Mr_Resistor; June 30th, 2016, 08:24 PM.
            My home is smarter than your honor roll student.

            Comment


            • #21
              Thanks Jim,

              I was away for an extended long weekend and now need to get this working.
              I am a Homeseer newbie so how would I send the script?

              I have a high degree of confidence that this is a plugin issue because it worked fine when I had one receiver on the plugin and it works when I use a different tool to send the command (I have been using Eventghost and the Onkyo plugin they have to send the commands to my receivers via the same ethernet to RS232 adapter.

              Comment


              • #22
                Copy the text into a text file and save it in your HS3 scripts directory. Then create an event that runs that script. You'll have to modify it so it hits the correct serial port.

                So far, the Plug in has been pretty reliable for me. I don't use that receiver too often, but when I have, it's fired perfectly.

                - Jim -
                My home is smarter than your honor roll student.

                Comment


                • #23
                  OK-I setup the script files and the scripts run fine when I run them as an event.
                  My receiver turns on and off on demand. Went back to the plugin and the plugin still fails to transmit the commands. Both from the same machine with the same serial connection.

                  As aside, now that I have been introduced to scripts, can I use scripts the same way to send an http command like this: "http://192.168.2.220?HTPCOn" If I can do that then I can use my existing Eventghost setup to control things until I figure out what is wrong with the BLOnkyo plugin.

                  Comment

                  Working...
                  X