Announcement

Collapse
No announcement yet.

Any User guide for new users? 2 simple questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Any User guide for new users? 2 simple questions

    Hi Blade,

    I just bought the plug-in and have a 2 quick questions:

    I got a used CAV6.6 and installed a USB to RS-232 cable, so I have the CAV6.6 is hooked to the PC using Com3.

    In the plug-in settings under Options Menu, there is an option for:
    Com Port Control Type with 3 options:
    - HomeSeer
    - MSCommLib
    - SerialPort

    First question: What is the difference between these 3 options? So I can select the right one.

    Second Question:
    Under the Protocol there is RNET and RIO, is there a preference or what should be the default?
    I suspect is RNET but not sure.

    Hopefully I can get it all installed tonight and be up an running.

    I am sorry if I missed a guide but I looked in the plug-in and in your webpage and I couldn't find any info.


    Thanks
    Chris
    Last edited by clafa; October 18th, 2017, 09:33 PM.

  • #2
    HomeSeer com port control type and protocol is RNET
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Thank you

      Blade,
      Thank you, will test these settings tonight.
      Chris

      Comment


      • #4
        No response from Russond Cav6.6

        Hi Blade,

        I was able to do the changes you suggested, I also verified the Port settings and I confirmed the following for the Port I am using Com6:
        Bits per second: 19200
        Data bits: 8
        Parity: None
        Stop bits: 1
        Flow control: none

        If I enable the log for both send and receive in the plugin I see messages "sent to the receiver", but nothing back and no control over the functions.

        I tried both front and back RS232 connections (as well as changing the switch front/back).

        Do you know if there is a specific setting that needs to be 'activated' in the receiver for the RS232 signals to be received?

        by the way the receiver works by controlling it from the keypads.

        I have plugin version 2.0.137.0
        HS3 Pro Edition 3.0.0.293

        any help is appreciated.

        Thanks
        Chris
        Attached Files

        Comment


        • #5
          Capture me a debug log

          1. Disable the plugin (if the HSPI_BLRussound.exe process is still running then kill it)
          2. Edit the hspi_BLRussound.ini file and change debugLevel=true
          3. Save INI file
          4. Re-enable plugin

          Let it run for a minute and then turn off debug logging in the plugin options web page.

          Attach the BLRussound-Detailed.log file zipped
          It is located in the HS3 root folder
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            Logs attached

            Hi Blade,

            I have attached 1 log as you described (1 min running) "file named BL-Russound-Detailed"

            And last night I left the detailed debug log running hopefully you can see something, that file is named "BL-Russound-Detailed1"

            Thanks for your help
            Chris
            Attached Files

            Comment


            • #7
              The com port does not seem to be open for some reason.

              I will check more into the log tonight
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                @Chris

                The Win OS hardware settings is what configures the serial port. The plugin only utilizes the settings in the hardware.

                As Bob mentions. Shut down the plugin first.

                Go to System Properties / hardware / device manager / ports and your device.

                Whatever is showing as the port for your USB-Serial device is typically the port utilized.

                This is the only place to see what serial port is configured with your USB to serial cable.

                That said change it.

                Under advanced configure a free communications port and make sure it is set to default of 9600 baud...etc.

                Write this serial port down.

                Go to the plugin settings and match the comm port to the one written down.

                I have seen many times that the USB-Serial device drivers will utilize an already utilized port which can cause issues and

                many times opening and closing the serial port can cause it to bind up (gets constipated) and sometimes a reboot fixes the binding up of the serial port.
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                HS4 Pro - V4.0.5.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X
                HS4 Lite -

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                • #9
                  Back for more

                  Hi Blade and Pete,

                  I am back at home and retesting...,
                  I did what Pete mentioned of changing the Com Port on the USB to RS232 under device manager and the new com port is 9, still not able to control the Russound amp.

                  I searched online and found some people saying that only certain USB to Rs232 cables are supported? is this accurate info?

                  See post # 8 below:
                  http://www.avsforum.com/forum/36-hom...lp-please.html

                  I am going to buy a Rs232 cable male to female to test HEX codes through the Itach device....

                  Do you have any thoughts?
                  How can I check if com port 9 is 'open' if this is a possible issue since the plugin indicates its 'open'. see attached log.

                  Thanks
                  Chris
                  Attached Files

                  Comment


                  • #10
                    Delete any debug log you currently have for the plugin
                    Capture a new debug log following this:

                    1. Disable the plugin (if the HSPI_BLRussound.exe process is still running then kill it)
                    2. Edit the hspi_BLRussound.ini file and change debugLevel=true
                    3. Save INI file
                    4. Re-enable plugin

                    Once you see those Sent messages in the log then you can disable debug logging and attach the debug log here zipped and I will see if the com port got opened.

                    I have seen some usb to serial cables cause issues.
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Latest testing -do I have a dud?

                      Hi Blade,

                      OK, I tried 2 USB to RS232 cables with 2 different chipsets and they didn't work.

                      I bought a PCI card with 4 Serial RS232 ports, installed it, updated drivers, etc. So I now have 4 additional ports to test.


                      Note 1:
                      I started testing with a 'used com port 3' port and got an error on the log indicating:
                      "Error In OpenComPort, error opening port: Unable to obtain a handle to the COM port"
                      So I know the plug-in is seeing if the port is open.

                      Then I proceeded to test the 4 ports (com port 7,8,10,11) in both front an back of the amplifier, and same results unfortunately.. attached is the log.

                      Note 2: I have the antivirus and firewall turned off..just in case.
                      Either I have a dud or there is a problem

                      Thanks for your help.

                      Chris
                      Attached Files

                      Comment


                      • #12
                        There is an error in the log:

                        10/12/2017 10:19:12:476 PM : v2.0.137.0 - Open_Russound_Com_Port(): theMsg --> Error: Unable to obtain a handle to the COM port

                        The plugin is unable to open the com port - it is like something has it locked up.
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment


                        • #13
                          Thanks for all the HELP guys.

                          I will be posting all the settings that worked such as Baud rate, etc. so everyone can benefit.

                          Thanks
                          Chris

                          Comment


                          • #14
                            Glad you got it all sorted out
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment

                            Working...
                            X