Announcement

Collapse
No announcement yet.

Can't connect CAV6.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't connect CAV6.6

    Hello,

    Recently purchased HomeTroller Zee S2 (info from HomeSeer below).

    I am trying to connect a Russound CAV6.6 to HomeSeer. I am able to communicate with the CAV6.6 on my PC with a USB to Serial cable using Russound PC Tools.

    I am using the same cable to connect the HomeTroller and the CAV6.6 but I am not having any luck.

    This is all that is showing up on the log file:

    Dec-16 7:50:19 PM BLRussound start BLRussound plugin has been initialized Dec-16 7:50:17 PM BLRussound start Controllers have been loaded. Dec-16 7:50:15 PM BLRussound start BLRussound Debug Logging is Enabled! Dec-16 7:50:15 PM BLRussound start Loaded configuration successfully Dec-16 7:50:15 PM BLRussound start BLRussound version is: 2.0.138.0 Dec-16 7:50:15 PM BLRussound start Initializing BLRussound... Dec-16 7:50:14 PM Info Plugin BLRussound has connected. IP:127.0.0.1:49752 Dec-16 7:50:14 PM Plug-In Interface BLRussound is running as a trial, 30 days remaining.
    I have added the controller and on the options tab I have selected /dev/tty/USB0 for the Com Port and have selected RNET for the Protocol.

    I have tried plugging the USB cable into all USB ports on the HomeTroller and still nothing.

    I have read many of the forum threads for help but have had no luck.

    I am guessing that I am missing something very basic. Any help is appreciated.

    Thanks.

    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.368
    Linux version: Linux HomeTrollerZeeS2V2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux System Uptime: 0 Days 2 Hours 42 Minutes 45 Seconds
    IP Address: 192.168.0.115
    Number of Devices: 214
    Number of Events: 16
    Available Threads: 385

    Enabled Plug-Ins
    2.0.138.0: BLRussound
    3.0.2.4: OMNI

  • #2
    I see you are using linux - there could be a com port issue in the plugin having to do with linux
    Can you do the following:

    1. Disable the plugin
    2. Edit the hspi_BLRussound.ini file and change debugLevel=true
    3. Save the INI file
    4. Restart the plugin and let it run for 5 minutes, then disable debug logging in the options web page

    Attach the BLRussound-Detailed.log file zipped.
    It is located in the HS3 root folder
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Thanks for the quick reply.

      I will try to get the log as soon as possible. Right now I can't get into the linux tools as it is not recognizing what I wrote down as my system password when I set things up.

      UGH!

      Comment


      • #4
        Blade, PM sent.

        Comment


        • #5
          The ini file was set to true already.

          Here is the log from last night.

          Thanks.
          Attached Files

          Comment


          • #6
            That log is from Nov 29th
            Can you delete it and capture a new log from the plugin startup
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Now I know what happened. That is not my log. I must have downloaded a log from another thread to see what has happening within the log.

              Trying now to get mine.

              Comment


              • #8
                Slowly learning my way around in the Linux Tools window of HomeSeer.

                I was able to get the first 600 lines of the log using the head command and the last 600 using tail, saved to text editor in rtf format.
                Attached Files

                Comment


                • #9
                  OK I will have a look at the logs

                  I may have to hookup my CAV66 to my raspberry pi and test out the plugin to see if I notice anything.
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    One thing I did notice is that when I do not have the USB cable plugged in to the HomeTroller the only "Russound Com Port" option is /dev/tty/S0.

                    When I plug in the USB cable, the /dev/ttyUSB0 option becomes available. That is what I have selected along with RNET.

                    Comment


                    • #11
                      OK I setup my CAV66 on Linux and I know what the issue is
                      Apparently the checksum code is failing in linux but works perfectly in Windows
                      I am not sure why yet but am checking
                      Cheers,
                      Bob
                      Web site | Help Desk | Feature Requests | Message Board

                      Comment


                      • #12
                        Thank you for the update. Let me know if there is anything I can do on my end.

                        Comment


                        • #13
                          Try out 2.0.139 in the HS3 updater
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            I can now change the status of the buttons in HomeSeer, i.e when switching a zone on, the radio button in HomeSeer changes to on, but the keypad does not turn on.

                            When I select the source in HomeSeer to match the keypad and I turn the HomeSeer zone on, I can then change the volume. If I change the source in HomeSeer the keypad does not update and I can no longer change the volume since the source does not match.

                            I renamed the zones in options and restarted the plug-in and the device list did not update the names.

                            Comment


                            • #15
                              HomeSeer Log after starting plug-in.
                              Attached Files

                              Comment

                              Unconfigured PHP Module

                              Collapse

                              Working...
                              X