Announcement

Collapse
No announcement yet.

ST2 Tuner Setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ST2 Tuner Setup

    I recently found a decent deal on an old ST2 tuner so I picked it up (Along with another CAV unit). I read through the manual and believe I have it set up correctly on the Tuner side to communicate over RNET (Tuner1 set to Source 3 and Tuner 2 Set to Source 4). However it appears I need to set the 2 sources on the CAV6.6 to Peripheral for it to communicate to the CAV. I did try to just type Peripheral into the source name in the Plug-in but that did not work.

    I do not own any Keypads and the BLRussound Plugin has allowed me to get the first CAV working fine. Is there a way to set up the sources correctly using Blade's Plug-in so I do not have to buy a keypad to get the ST2 working over RNET, or do I just need to purchase whatever the cheapest keypad is (especially if I have to use it to configure the second CAV also, which I have not researched yet)?

    I haven't researched the programming software for the CAV yet either, so I could go that route if the Plugin will not let me configure it correctly.

    Thank You,
    Chris

  • #2
    It's been a while since I connected my tuner and CAV, but you can probably do it with the PC Power Tools software. That said, the software was old and not designed very well when I used it years ago, so unless it's been rewritten, be prepared to spend some time figuring out how to use it properly. As I recall it did not run under Windows 7, but it may be that it is just a 16 bit application. The last time I ran it I used an old XP laptop. I'd suggest trying to download it from the Russound website. Originally, it was a very expensive package (and no where near worth the price), but the last time I looked it was free. In any case, I'd recommend you consider getting an Uno S2 keypad. I find it very handy to have at least one available for programming.

    Mike____________________________________________________________ __________________
    HS3 Pro Edition 3.0.0.548

    HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

    Comment


    • #3
      Not sure if I am going to be of much help, but will try... I have 2 CAMs with an ST2. The ST2 is in CAM #1 as Source 1. The CAMs are connected with the network cables crossed (only way I know how to explain) and mine all work fine on all 12 keypads. I did not use keypads to program. On the CAM there is a dip switch for parallel.

      I also have the power tools and use it on a windows 7 and server 2012 machine. The key is to have a serial connection to the CAM (or CAV in your case) and then use popcap. The tools for it are in the instructions. If you cannot find it on the Russound site (took me a while to find it), ping me and I will get it to you. I found it much easier to program both the CAM and the keypads using powertools.

      Something in my head is saying having the tuners in the right order on the ST2 was the key. My ST2 has the AM/FM/XM. Somehow I got the XM to be the first source on the ST2 but it was my 3rd input on the first CAM. I do remember it took me a few tries with cables and dip switches to get it all to work.

      Hope it helps.

      Michael

      I went back at my server and looked and there are 2 versions of PC PowerTools. One is "ST" and the other is plain (one is for keypads). I use VCOM from IC Plus Corp to connect the powertools to the CAM. Make sure you "get setup" from the unit before you make changes. Then you have your starting setup. Also make sure you turn off BLRussond plugin. Once you have it working, you can then turn back on your plugin. Then the names populate the plugin.
      HS3Pro on Win2012R2
      Aeotec, Cooper, Cree, GE/Jasco, Intermatic, LIFX, Fortrezz, OSRAM, RCS, Trane, Zooz
      BLBackup, BLGData, BLRussound, BLSpeech, HSTouch, InvisaLink, HSBuddy, IFTTT, NetCAM, PHLocation, Pushover 3P, Random, UltraLighting3, weatherXML, ZigBee, Z-Wave

      Comment


      • #4
        I downloaded and installed the Power Tools and Power Tools ST. I set Tuner 1 as Source 1 and Tuner 2 as Source 2. I went into the CAV software and set up Source 3 and 4 as Tuner 1 and 2 and set both of their command types to peripheral. Finally I thought maybe the RNET connection might be the problem but I was able to be plugged into the CAV unit and upload from the ST2.
        ST2 Firmware 3.02.01 and CAV firmware 2.00.01

        Maybe the problem is with my BLRussound setup. I have the Tuner 1 Setup as:
        Number: 1
        Name: Tuner 1 (but I assume this does not matter)
        Source: 3-Tuner 1 (I named Source #3 Tuner 1 under the BLRussound Controller Setup

        I left Starting Bank, Starting Rack, Listneing mode, etc. as default

        On my device list I see the 10 devices for the tuner but most are blank and the only one that changes is the Power when I select that source on the tuner.

        Looks like I may have to contact Blade as I don't see much help for the tuner setup for the plugin. I was hoping I was just missing something simple that someone would catch.

        I havent even tried the second CAV yet, but I may also try to set it up with the tuner connected to it just to make sure it isn't my older CAV unit.

        I will look into finding a keypad also. if I had one I could see if I could control the ST2 Tuner 1 when Source 3 is selected.

        Thanks for the help!

        Comment


        • #5
          I want to send a shout out to Blade.

          I had purchased a keypad and about exhausted everything I knew how to do to get it working. I was actually about to reach out to him for help and noticed there was a BLRussound update. I installed the update (V 2.1.18.0) and I can control my Tuner with Homeseer!

          I appreciate you working behind the scenes and always improving your plug-ins.

          Comment

          Working...
          X