Announcement

Collapse
No announcement yet.

Plugin Stopped Communicating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Plugin Stopped Communicating

    Just noticed that this plugin has stopped working with nothing logging (debug on). Cannot control/send commands and am not receiving status. Here is what I have gathered so far:
    - from what I can remember, the plugin worked prior to the MSCommLib/Serial Port drop down box (just noticed this today); I've tried with both options and still no go
    - the plugin used to require me to click "Yes" to a UAC registry change for "MSCommControl.reg" upon launching HS3 as a user; this has not popped up since the plugin stopped working

    I have an MCA-C5 which had been working fine, but as I haven't been using it for a while I just noticed the issue randomly today.

    HS3 3.0.0.177
    BLRussound 2.0.52.0

    This is pretty much all that I see in the log:
    May-23 9:46:45 AM BLRussound start BLRussound plugin has been initialized
    May-23 9:46:45 AM BLRussound start Controllers have been loaded.
    May-23 9:46:45 AM BLRussound start BLRussound Debug Logging is Enabled!
    May-23 9:46:45 AM BLRussound start Loaded configuration successfully
    May-23 9:46:45 AM BLRussound start BLRussound version is: 2.0.52.0
    May-23 9:46:45 AM BLRussound start Initializing BLRussound...
    May-23 9:46:45 AM Info Plugin BLRussound has connected. IP:127.0.0.1:51014

    Your help is appreciated
    CJ

  • #2
    I am in the middle of updating the plugin to support multiple instances so please go back to this build:

    http://bladeplugins.no-ip.org/betas/...d_2-0-51-0.zip

    Shutdown HS3
    Extract the HSPI_BLRussound.exe to your HS3 root folder and overwrite it
    Restart HS3

    Let me know how that works
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Reverted to previous version as you instructed. Issue persists.

      May-23 10:47:19 AM Plug-In Finished initializing plug-in BLRussound
      May-23 10:47:19 AM BLRussound start BLRussound plugin has been initialized
      May-23 10:47:19 AM BLRussound start Controllers have been loaded.
      May-23 10:47:18 AM BLRussound start BLRussound Debug Logging is Enabled!
      May-23 10:47:18 AM BLRussound start Loaded configuration successfully
      May-23 10:47:18 AM BLRussound start BLRussound version is: 2.0.51.0
      May-23 10:47:18 AM BLRussound start Initializing BLRussound...
      May-23 10:47:18 AM Info Plugin BLRussound has connected. IP:127.0.0.1:53644

      Comment


      • #4
        Then it cannot be any changes I made in 2.0.52
        In 2.0.51 do you have any option to change the com port type?

        Do the following:

        1. Shutdown HS3
        2. Edit hspi_BLRussound.ini in the config folder and change debugLevel=true
        3. Save INI file
        4. Restart HS3

        Once HS3 is started for a minute, then disable debug logging in the BLRussound options page.

        Log a help desk ticket on my web site
        Attach the BLRussound-Detailed.log file zipped to the ticket

        I will then have a look
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          done. thanks

          Comment


          • #6
            The issue turned out to be UAC was enabled in Windows
            Disabling UAC fixed the issue
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Blade,

              I just install this plugin and not communicating with cav6 russound.

              Could you take a look at the log fie.

              Thank you

              Greg Mack
              Attached Files

              Comment


              • #8
                Blade,

                Will you get chance to look at the log file above.

                Thank you

                Greg

                Comment


                • #9
                  Blade

                  I need help getting this plugin to work, see my attachment above

                  Thanks

                  Greg

                  Comment


                  • #10
                    I installed the Russound plugin for the first time.

                    After testing it from my Vera on my HS3 server, I could also not get it to communicate.

                    Tried both serial modes (no documentation to use one over the other)...but never get status. It seems to load just fine.

                    Comment


                    • #11
                      What version OS are you using? If I remember correctly you have to download a driver to make it work. I am on 8.1 and it works flawless. I think 7 needed the driver.

                      Comment


                      • #12
                        Windows 8.1 x64. The Serial driver installed fine in Windows Device manager and I'm using the same USB to serial device model to successfully control the Somfy.

                        Comment


                        • #13
                          Search for the mslib driver and install that and set the config to mslib. That is what worked for me.

                          Comment


                          • #14
                            I searched google for MSLib and found nothing reliable.

                            Is this plugin supported still or abandoned?

                            Comment


                            • #15
                              I've seen this on my MCA-C5 as well. With the debug communication turned on, I see nothing in the log... Until I manually power off/on the controller then communication resumes. I've spoken to russound and they said that there's an option to communicate with the controller via ethernet using the RIO protocol. Thoughts Blade?

                              Comment

                              Working...
                              X