Announcement

Collapse
No announcement yet.

New Install Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Install Question

    Hello,

    I recently installed the BLRussound plugin. I have a CAA66 system with 6 keypads and 4 active inputs. I have added the Zone & Source names to the plugin. I then restarted the plugin but under my device list it still says c1z1, c1z2, etc for each zone. It should change the device names to reflect the Zone I entered correct? I have also tried to uninstall & reinstall the plugin. It seems the configuration carried over when it was reinstalled.

    A second issue I'm having is that each zone shows that the source is set it source 1 (media center) even though each zone is set to something else. The plugin allows me to change the source without issue, and as long as I change the source via homeseer it is correct. But when I change the source via the keypad homeseer does not recognize the change. I have attached a screen shot of my config if it helps.

    Finally, the device All Keypads Off works perfectly. However All keypads ON shows them as on in HomeSeer but does not actually turn on any of the keypads. I can turn them on and off individually without issue.
    Attached Files

  • #2
    The zone name will not change all devices - it used to do this a while ago but users did not like it so I allow you to change the devices to whatever you want

    When the plugin starts it should request all info from the each zone. Have you tried restarting the plugin.

    For the all ON keypads, can you capture me a debug log in the plugin of this and then attach the BLRussound-Detailed.log file zipped. It is in the HS3 root folder
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Originally posted by Blade View Post
      The zone name will not change all devices - it used to do this a while ago but users did not like it so I allow you to change the devices to whatever you want

      When the plugin starts it should request all info from the each zone. Have you tried restarting the plugin.

      For the all ON keypads, can you capture me a debug log in the plugin of this and then attach the BLRussound-Detailed.log file zipped. It is in the HS3 root folder

      Wow, thanks for the super quick response.

      That makes sense regarding the zone name. I know this may sound minor but is there a easy way to bulk rename each device? The plugin created 92 devices, renaming them one by one is going to be time consuming.

      I have tried to restart the plugin. Is that the only time it requests the status from each zone? Does it recognize when a keypad is used? I.E. Zone is changed, volume is pressed, power is turned off, etc and then update that status in Homeseer?

      I turned on debugging in your plugin. I then turned off all zones, turned on all zones, and attached a ZIP version of your log. Not that I will pretend that I can understand 1/10th of what is in your log, but one thing that jumps out at me is that it only shows the All Power Off command. I don't see the All Power On even though that button was pressed.
      Attached Files

      Comment


      • #4
        Two other things I noticed. ISON: True but none of the devices are on. Also in device mangement it looks like this:

        BLRussound Controller 1 Root 5/21/1929 11:00:00 AM
        BLRussound c1 All Keypads 5/21/1929 11:00:00 AM Off On

        The Last Change date & time are inaccurate. I've never see anything do that before.

        Comment


        • #5
          OK I will take a look at the log
          Can you provide me one more log

          Delete the old debug log and do the following:

          1. Disable the BLRussound plugin
          2. Edit the hspi_BLRussound.ini file and change debugLevel=true and save INI file
          3. Re-enable the plugin

          Once plugin has been running for a minute, disable debug logging and attach the new log zipped
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #6
            Done, see attached.
            Attached Files

            Comment


            • #7
              Will have a look when I get home from work tonight
              Is the turn on volume and background color reporting correctly?
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                I had to step out. Give me a few hours to get back and I will check and let you know.

                Comment


                • #9
                  I have a bizarre answer to your question: I turned the volume down to 0 in homeseer. I then used the keypad to increase the volume to MAX, which is 100 of course. Homeseer sees the volume go up but stops at 28. It never get to 100. I tried the test again using a starting volume of 30. I maxed it out on the keypad, and it makes it to 44. I then tried to reduce the volume to 0 on the keypad. The volume went back to 30 in HomeSeer.

                  Comment


                  • #10
                    Try 2.0.110 in the updater

                    Before you disable the plugin, change the "Com Port Control Type" on the options page to "HomeSeer"
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Done... whatever you did in the update resolved the source issue. Now they load and update correctly. However, the volume and ALL ON still do not work correctly.

                      Comment


                      • #12
                        Are you using the HomeSeer com port control type?
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment


                        • #13
                          Yes, it was incorrect at first, but I changed it after the update.

                          Comment


                          • #14
                            Have you restarted plugin after you changed it?
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Yes, as well as homeseer. I have not rebooted the PC.

                              Comment

                              Working...
                              X