Announcement

Collapse
No announcement yet.

windows path in linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • windows path in linux

    Hi All
    I am trying to run the BLRussound plugin on Pi (Linux). It doesn't work. Turned on debugging, and I see that there is a windows-style path for it to find the hspi_BLRussound.ini file. The first part is linux style with forward slash, and the second part is windows style ('\'\). I don't see a way to change this--I think it needs to be reworked in the plugin... This is in the Build_Controller_Dictionary() call.
    from the log:

    v2.0.119.0 - Build_Controller_Dictionary(): ERROR - Caught this exception - Could not find file "/usr/local/HomeSeer
    \Config\hspi_BLRussound.ini"

    Thanks!

  • #2
    Try 2.0.120 in the updater
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Thanks--worked and now it is correctly saving controller.
      But--still not working. Next question is what the device name should be. My serial port is /dev/tty0. should i have '0' as the port or tty0 or something else?
      Thanks!

      Comment


      • #4
        Com port should be /dev/tty0 if that is what it is
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          I don't believe /dev/tty0 is going to be a serial port for most if not all Linux builds...
          What is the physical interface? If its USB, the device would be something like /dev/ttyUSB0.
          If this is a raspberry pi and you are connecting directly thru the GPIO pins, the device may be /dev/ttyS0 or /dev/ttyAMA0.

          EDIT: make that defininte - seems that /dev/tty0 maps to /dev/console which is usually the HDMI display/USB keyboard...

          Comment


          • #6
            Thanks!
            I updated it to /dev/ttyUSB0 which seems to be valid device (I am using USB to rs232 on a raspberry pi).
            I rebooted the pi to fully restart homeseer, but no luck.
            I do still get this error in the detailed log (no error reported in the homeseer log)
            01/04/2017 08:46:39:070 PM : v2.0.120.0 - Verify_All_Controller_Homeseer_Devices_For_Source_Have_Contr ols(): processTheZone --> Fa
            lse
            01/04/2017 08:46:39:070 PM : v2.0.120.0 - Verify_All_Controller_Homeseer_Devices_For_Source_Have_Contr ols() finished
            01/04/2017 08:46:41:073 PM : v2.0.120.0 - Homeseer_Started_Check(): ERROR - Caught this exception - Could not resolve type with token 0100006a
            01/04/2017 08:46:46:074 PM : v2.0.120.0 - Is_Homeseer_Started() started
            01/04/2017 08:46:46:080 PM : v2.0.120.0 - Is_Homeseer_Started(): homeseerStarted --> True
            01/04/2017 08:46:46:080 PM : v2.0.120.0 - Is_Homeseer_Started() started


            This error repeats about every 17 seconds.

            Ideas?

            Comment


            • #7
              OK try this:

              1. Disable BLRussound
              2. Edit the hspi_BLRussound.ini file and change debugLevel=true and save the INI file
              3. Re-enable BLRussound

              Let it run for a minute and then turn off debug logging on the plugin options page

              Attach the BLRussound-Detailed.log file zipped
              It will be in the HS3 root folder

              BTW, what do you get if you run this in Linux:

              Code:
              dmesg | grep tty
              Cheers,
              Bob
              Web site | Help Desk | Feature Requests | Message Board

              Comment


              • #8
                dmesg gives me this:
                [ 0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=752 bcm2708_fb.fbheight=448 bcm2709.boardrev=0xa01041 bcm2709.serial=0x75dac23 smsc95xx.macaddr=B8:27:EB:5D:AC:23 bcm2708_fb.fbswap=1 bcm2709.uart_clock=48000000 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p6 rootfstype=ext4 elevator=deadline rootwait
                [ 0.001514] console [tty1] enabled
                [ 0.093593] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
                [ 3.455728] systemd[1]: Starting system-getty.slice.
                [ 3.463553] systemd[1]: Created slice system-getty.slice.
                [ 6.377707] usb 1-1.2: pl2303 converter now attached to ttyUSB0
                [ 6.388819] usb 1-1.3.4: pl2303 converter now attached to ttyUSB1

                will send debug log--

                Comment


                • #9
                  Here is the log file
                  Attached Files

                  Comment


                  • #10
                    I see this error which is stopping the plugin from fully initializing:

                    ERROR - Caught this exception - Could not resolve type with token 0100006a

                    This seems to point to an issue with mono
                    Have you installed the complete mono package?
                    Cheers,
                    Bob
                    Web site | Help Desk | Feature Requests | Message Board

                    Comment


                    • #11
                      Hi
                      I used the image from HS, which seems to have it installed. It seems like I have 4.0.2.5 installed, but when I tried to do mono-complete, that is just version 3.2.8. Do I need to uninstall and bild from scratch or ???
                      Thx

                      Comment


                      • #12
                        OK--a little sleuthing--sounds like debian doesn't update mono much, so added another repo, and that had up-to-date mono:
                        sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
                        echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
                        sudo apt-get update

                        Then did:
                        sudo apt-get install mono-complete mono-vbnc

                        That looks to be version 4.6.2.16 . Hope that is backward compatible...

                        But no joy... Rebooted the pi just in case. Still get the same error.

                        Comment


                        • #13
                          Hmmm I have not seen this error before
                          I am not sure what exactly is causing it in the code
                          I am going to put in some more debug logging and then post a new build
                          I will let you know shortly
                          Cheers,
                          Bob
                          Web site | Help Desk | Feature Requests | Message Board

                          Comment


                          • #14
                            Try 2.0.122 and capture the same debug log
                            Delete the old debug log first
                            Cheers,
                            Bob
                            Web site | Help Desk | Feature Requests | Message Board

                            Comment


                            • #15
                              Here is the file. Thanks for your help!
                              Attached Files

                              Comment

                              Working...
                              X