Announcement

Collapse
No announcement yet.

windows path in linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    This is a weird one

    01/05/2017 08:01:04:071 PM : v2.0.122.0 - Homeseer_Started_Check(): russoundComPort --> /dev/ttyUSB0
    01/05/2017 08:01:04:074 PM : v2.0.122.0 - Homeseer_Started_Check(): ERROR - Caught this exception - Could not resolve type with token 0100006a

    I print the com port and then I get the error. This makes no sense. It has not even tried to open the port yet. Do you have vbnc installed as well

    vbnc -version

    I have not seen this before. I wonder if anyone else is using BLRussound on a PI
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #17
      Yes I see I do have vbnc (must have been installed with mono?):

      Visual Basic.Net Compiler version 0.0.0.5943 (Mono 4.4 - master/8a804fd)
      Copyright (C) 2004-2010 Rolf Bjarne Kvinge. All rights reserved.

      Comment


      • #18
        From the dmesg:
        Code:
        [    6.377707] usb 1-1.2: pl2303 converter now attached to ttyUSB0
        [    6.388819] usb 1-1.3.4: pl2303 converter now attached to ttyUSB1
        Looks like there are two USB converters attached? Which one is connected to the Russsound?

        Perhaps verify the USB serial devices are present:
        Code:
        ls -l /dev/ttyUSB*
        'pl2303' indicates the chip the converter is based on - http://prolificusa.com/portfolio/pl2...ge-controller/

        Comment


        • #19
          Yes there were two connected when I ran that. I disconnected the one just to be sure. Here is output with just the Russound connection:

          [ 0.001520] console [tty1] enabled
          [ 0.093187] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
          [ 3.505734] systemd[1]: Starting system-getty.slice.
          [ 3.513260] systemd[1]: Created slice system-getty.slice.
          [ 6.257754] usb 1-1.5: pl2303 converter now attached to ttyUSB0

          Comment


          • #20
            And does the /devttyUSB0 device appear like this?
            Code:
            pi@rpi:~ $ ls -l /dev/ttyUSB0
            crw-rw---- 1 root dialout 188, 0 Jan  6 14:16 /dev/ttyUSB0

            Comment


            • #21
              Possibly a permissions issue? Check this out (at the bottom): https://www.raspberrypi.org/forums/v...ic.php?p=90223

              Comment


              • #22
                The user running the process needs to have rights to the character device (/dev/ttyUSB0). Easy way to do this is to add them to the 'dialout' group.

                Check what groups user is member of:
                Code:
                $ id -a
                uid=1001(homeseer) gid=1001(homeseer) groups=1001(homeseer)
                Add user homeseer to group dialout:
                Code:
                sudo usermod -a -G dialout homeseer

                Comment


                • #23
                  yes:
                  $ ls -l /dev/ttyUSB0
                  crw-rw---- 1 root dialout 188, 0 Jan 5 19:43 /dev/ttyUSB0

                  Comment


                  • #24
                    I am running this as me (bje01) not homeseer.
                    I did do the usermod command, but with bje01 rather than homeseer.

                    Comment


                    • #25
                      I found while experimenting that the extra permissions didn't appear right away; seemed that they were cached in the shell. I had to log out & back in before I could write to the device.

                      Comment

                      Working...
                      X