Announcement

Collapse
No announcement yet.

BLUSBUIRT 2.0.9.0 Didn't send IR - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BLUSBUIRT 2.0.9.0 Didn't send IR - Fixed!

    Hi,

    I noticed that the newer BLUSBUIRT 2.0.9.0 was available as a normal update for HS3 so updated over my existing 2.0.7.0.

    It broke my IR control

    The USB-UIRT would receive IR, and Homeseer could start an event with it, but it did not send out any IR commands.

    For example, I use my Sky UK remote control to turn everything on - Sky satellite (direct IR), motorised screen (IR from USB-UIRT), AV amp on (IR from USB-UIRT), Projector on (IR from USB-UIRT) as well as a lot of interspersed z wave power on commands. The z-wave commands all worked, but the IR didn't work from the USB-UIRT.

    I have now reverted it to 2.0.7.0 and all is well. Any ideas ?

  • #2
    Can u capture a debug log of it and attach it zipped
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Hi, i'll do it over the weekend since I have reverted to 2.0.7.0.

      I did a little bit of testing at the time:

      1. Events looked OK.
      2. Settings in the plug-in didn't appear to have anything new to stop it working.
      3. Manually pressing 'Send' in the plug-in did send the IR commands.
      4. There were no messages in the main log to show any failures when the event ran - it did show the z-wave devices in the sequence.

      It's just that IR wouldn't work in an actual event - or when the event was triggered manually.

      So to clarify, you need me to run 2.0.9.0 with BLUSBUIRT / Options / Debug-logging on, and run the event ? Then send the main log ?

      Comment


      • #4
        I am sure I can figure it out quickly once I see the debug log
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #5
          Well I re-installed 2.0.9.0 and again it doesn't work for me.

          1. Install 2.0.9.0
          2. Turn off BLUSBUIRT plug in.
          3. Restart HS3.
          4. Enable debug logging.
          5. Check SKY event - all z-wave devices work, but no IR control.
          6. Turn off debug logging.

          I found the detailed BLUSBUIRT log file, and have attached it to this post.

          The normal log file doesn't show anything interesting:

          Nov-07 14:10:41 BLUSBUIRT Info BLUSBUIRT Debug Logging Disabled!
          Nov-07 14:10:33 Z-Wave Device: Ground Lounge Projector Screen Power Set to 0
          Nov-07 14:10:33 Event Deleting event after run: "Delayed Actions Projector Screen Power (Delayed Action) - 2"
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:33 Device Control Device: Ground Lounge Projector Screen Power to Off (0)
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:33 Event Event Trigger "Delayed Actions Projector Screen Power (Delayed Action) - 2"
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:08 Device Control Device: Ground Lounge Lounge Top to Off (0)
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:08 Device Control Device: Ground Lounge Subwoofer power to On (255)
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:03 Z-Wave Device: Ground Lounge Projector Screen Power Set to 255
          Nov-07 14:10:03 Device Control Device: Ground Lounge Projector Screen Power to On (255)
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:03 Device Control Device: Ground Lounge Projector power to On (255)
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:10:03 Event Event Trigger "Sky ON Sky ON"
          (System)_07-Nov-2014 14:07:35.3518_Event Handler
          Nov-07 14:09:02 BLUSBUIRT Info BLUSBUIRT Debug Logging Enabled!

          And I cannot see any BLUSBUIRT activity there other than starting and stopping debug logging
          Attached Files

          Comment


          • #6
            I see the issue.
            Once I am home this afternoon I will fix it and get a new build in the updater and get you to try it out.
            I will reply here once done

            Go back to 2.0.8 until I release 2.0.10
            Cheers,
            Bob
            Web site | Help Desk | Feature Requests | Message Board

            Comment


            • #7
              Thanks for letting me know. I will test it as soon as I see it. It gets a lot of use here !

              Tim

              Comment


              • #8
                Should be done shortly
                Cheers,
                Bob
                Web site | Help Desk | Feature Requests | Message Board

                Comment


                • #9
                  OK try 2.0.10 in the updater and let me know
                  Cheers,
                  Bob
                  Web site | Help Desk | Feature Requests | Message Board

                  Comment


                  • #10
                    Hi Bob,

                    2.0.10.0 is working well. IR control is restored

                    Thank you !

                    Comment


                    • #11
                      What was added to the new version
                      HSPRO,HS3PRO, BLsecurity, , MCSxap, HSTouch Android, UltraGCIR, CM15a, USBUIRT, BLUSBUIRT, WIFIRGB, BLAB8SS, BLcontrol, BLGData, BLLAN,BLOccupied, BLRadar, BLVolume, iTunesDAAP, UltraGCIR3, Airplayspeak, BLalarm, BLbackup, BLLED, BLrandom, BLReminders, BLRF, BL Speech, Hyperion, IFTTT, KINECT, XBMC, MCSprinkers PRO, PHLocation, ULtrapioneer, Ultralog, ultraweatherbug, Z,troller, GC-100, GC WIFICC, GC-WIFI SERIAL, Nitrogen logic depth camera controllers,

                      Comment


                      • #12
                        I fixed the repeats not working
                        Cheers,
                        Bob
                        Web site | Help Desk | Feature Requests | Message Board

                        Comment

                        Working...
                        X