Announcement

Collapse
No announcement yet.

Forward or Next Button

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • huntley1
    replied
    It's working great! Thank you!

    I had the same error messages as before, but after a deleted the .ini and .ini.bak files again and restarted the plug-in to started working fine.

    Leave a comment:


  • ChrisH
    replied
    Version 3.9.8 has the times formatted as you suggested in the String. The Value should contain the integer seconds for use with a slider in HSTouch. Let me know how the upgrade goes. Disable the plugin, do the upgrade, then enable again.

    thanks,

    Leave a comment:


  • huntley1
    replied
    Thanks for all your help.

    Can the track times be formatted in the device string to mm:ss. I'm trying to figure out a way to do it myself in HST, but I'm not having any success. Is it possible?

    Leave a comment:


  • ChrisH
    replied
    I'm pleased to hear it is working again. I'll work on the update to get the time devices to report as an integer so you can use them on a slider in HSTouch. I'll add some additional error checking around that.

    While I'm in there do you have any other items on your wish list?

    thanks,

    Leave a comment:


  • huntley1
    replied
    I got it working again. I had to delete the BOSESoundTouch.ini and BOSESoundTouch.ini.bak files in the /usr/local/HomeSeer/Config folder.

    Leave a comment:


  • ChrisH
    replied
    I'm sorry to hear you are still getting an error. You should now be back on code that was working for you previously. Can you try deleting the plugin with the red x? Once that is done check in Device Management and remove any SoundTouch devices.

    Your license information will still be there when you add the plugin again. Also can you check for SoundTouch updates in the normal BOSE app? I know one recently went out. You might also try powering off your SoundTouch player which might prompt it for an update.

    thanks,

    Leave a comment:


  • huntley1
    replied
    I did the "upgrade" and I'm still getting the same error

    Leave a comment:


  • ChrisH
    replied
    Just to get back to a stable release I have revered back to the previous version. The new version of the plugin, 3.9.7 is really just the code you had no problem with, 3.9.5. I called it 3.9.7 so that you could "upgrade" from version 3.9.6 which was setting the string time values into the value integer as well so that we could use it on the slider in HSTouch.

    As usual, disable the plugin, do the upgrade then turn it back to enabled.

    Please let me know you are back to a stable working version and we can go from there. The floating point error you saw makes me think I need to add some validation of what comes back from the SoundTouch player before setting the Homeseer device.

    thanks!

    Leave a comment:


  • huntley1
    replied
    I'm getting the following error message in my log:
    Jul-31 11:06:44 AM Error Initializing plug-in(2): BOSESoundTouch Instance::TimeSpan does not accept floating point Not-a-Number values.STACK: Server stack trace: Exception rethrown at [0]: at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_remoting_wrapper (intptr,intptr) at (wrapper remoting-invoke) HomeSeerAPI.IPlugInAPI:InitIO (string) at Scheduler.clsHSPI.CheckInterfaces () [0x00098] in :0

    in the Plug-in manager I'm getting this warning in the plug-in status:
    WARNING: Failed getting InterfaceStatus from BOSESoundTouch - the interface was not found in the list of active interfaces, the list may need to be refreshed.

    I've tried enabling and disabling the plug-in and rebooting my controller as well.

    Leave a comment:


  • ChrisH
    replied
    In version 3.9.6.0 the two time devices now have the integer and string versions of the time in a track.

    Leave a comment:


  • ChrisH
    replied
    The plugin is just sending that keypress to the player. Push "Pause" on the Homeseer device it will send Pause to the SoundTouch player. Same for "Play" and "Stop", similar to what the remote control would be doing.

    Take a look at the actual SoundTouch app you have installed somewhere while you have music playing. They have a difference between internet radio and playing local media. They have one needing Pause to stop it and the other one needs a Stop.

    I will take a look at getting the two time devices into an integer.

    Leave a comment:


  • huntley1
    replied
    Hi,

    I'm noticing that there's no toggle from STOP to PLAY in HS3. The toggle from PAUSE to PLAY works fine. I have to select play in HS3 to get it out of STOP. This happens when the source in INTERNET_RADIO.

    Also, is there a work around for displaying the track time as an integer instead of a string? I'm trying to create a slider that moves along with the song, but in HSTouch the Status Tracking is only looking for a value for the image.

    Thanks

    Leave a comment:


  • huntley1
    replied
    Sweat!, I will check it out later today.

    Thank you!

    Leave a comment:


  • ChrisH
    replied
    Version 3.9.5 has a play status device (Play, Pause, Stop) created for any new SoundTouch player added. I also went ahead and created two time devices for song length and the current playing position in a song (seconds). You might want those on your HSTouch screens but it might be a bit jumpy as they will only update every few seconds after the refresh.

    Leave a comment:


  • huntley1
    replied
    I just tried it out and it works perfect. Much appreciate and thank you! I'm loving the plug-in.

    I might be pushing my luck right now, but I'll ask it anyway. is it possible to have a Play/Pause function for the tracks?

    Leave a comment:

Working...
X