Announcement

Collapse
No announcement yet.

I am missing something simple...setting the COM Port

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I am missing something simple...setting the COM Port

    I don't see any way to configure what COM port the plugin is using. It defaults to COM 1 and you can't change it. I checked the ini file and there is no entry for setting the COM Port there either.

    What am I missing?

    Thanks,
    Scott

    #2
    I do not use this plugin but this is "generally" accomplished via a setup button on the config page if the com port column is not editable. Also try to configure the plugin while physically on the HS server as the button may not be visible remotely.
    -Rupp
    sigpic

    Comment


      #3
      Originally posted by Rupp View Post
      I do not use this plugin but this is "generally" accomplished via a setup button on the config page if the com port column is not editable. Also try to configure the plugin while physically on the HS server as the button may not be visible remotely.
      Thanks, but no option on the setup page. And tried it on the server itself...same result.

      Comment


        #4
        Odd, as the description of the plugin states "Configuration web page is accessed through HomeSeers Setup-Interface link using standard HomeSeer API "

        Is there a link on the HS GUI for this plugin?
        -Rupp
        sigpic

        Comment


          #5
          Sorry, I wasn't clear in my response. There is a setup page that is accessed through the Homeseer Setup screen, but there is no option for a com port selection. I will post a screenshot in a minute.

          Comment


            #6




            Comment


              #7
              Scott,
              What version of HomeSeer are you running? I just tried it here with HS version 2.3.114 and none of my plugins have the ability to use the com port column. Must be a bug in the beta.
              -Rupp
              sigpic

              Comment


                #8
                Originally posted by Rupp View Post
                Scott,
                What version of HomeSeer are you running? I just tried it here with HS version 2.3.114 and none of my plugins have the ability to use the com port column. Must be a bug in the beta.

                Good catch...I'm on Beta 2.3.0.112 so I suspect you are correct....should I report this in the beta thread or will you take care of that?

                Thanks,
                Scott

                Comment


                  #9
                  Originally posted by scott12v View Post
                  Good catch...I'm on Beta 2.3.0.112 so I suspect you are correct....should I report this in the beta thread or will you take care of that?

                  Thanks,
                  Scott
                  Before reporting this. Are you seeing any errors in the HomeSeer log file when restarting HomeSeer? The plugin is shutting down on me because I haven't entered a valid ipaddress.
                  -Rupp
                  sigpic

                  Comment


                    #10
                    Originally posted by Rupp View Post
                    Before reporting this. Are you seeing any errors in the HomeSeer log file when restarting HomeSeer? The plugin is shutting down on me because I haven't entered a valid ipaddress.
                    I won't be able to try that until tonight when I get home, but I do not recall any errors other than the ones that seemed to be related to not finding the COM Port.

                    It sounds like you might have the ENABLE or DISABLE Network option set to Enabled. If you set it to Disabled, I wouldn't think it would look for an IP address.

                    Comment


                      #11
                      I just had a look at the TI-103 plugin and the com port column shows just fine so it leads me to believe the plugin is having an issue. Hopefully Larry will chime in on this issue.
                      -Rupp
                      sigpic

                      Comment


                        #12
                        The comm port assignment is on the HomeSeer Setup TAB next to the Enable plug-in Button...

                        The comm port will show N/A if Network is selected in the Plug-ins config page, to use the comm port, use the Plug-ins config page and Select Disable Network, make sure to Submit Changes...Now you can:

                        Go to HomeSeer Tools Tab - then click the Setup / Configuration Button - then click the Interfaces Tab - finally scroll down to the plug-in and you will see the comm port selection box in the CommPort column...

                        Like earlier posts...if you wish to use IP then a valid IP address MUST be specified and plug-in restarted. The plug-in uses a COMPORT or NETWORK IP not both at same time.
                        -Larry

                        A member of "The HA Pioneer Group", MyWebSite

                        Plugins:
                        VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

                        Hardware:
                        Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

                        Comment


                          #13
                          Originally posted by lpitman View Post
                          The comm port assignment is on the HomeSeer Setup TAB next to the Enable plug-in Button...

                          The comm port will show N/A if Network is selected in the Plug-ins config page, to use the comm port, use the Plug-ins config page and Select Disable Network, make sure to Submit Changes...Now you can:

                          Go to HomeSeer Tools Tab - then click the Setup / Configuration Button - then click the Interfaces Tab - finally scroll down to the plug-in and you will see the comm port selection box in the CommPort column...

                          Like earlier posts...if you wish to use IP then a valid IP address MUST be specified and plug-in restarted. The plug-in uses a COMPORT or NETWORK IP not both at same time.
                          Larry,
                          This isn't working with the latest beta of HomeSeer. I have set the option:
                          If ENABLED this will provide NETWORK support.
                          If DISABLED this will provide SERIAL-PORT support.
                          ENABLE or DISABLE Network: Disabled
                          Yet when I go to the Setup > Interfaces tab the COM Port column is still set to N/A
                          -Rupp
                          sigpic

                          Comment


                            #14
                            Originally posted by Rupp View Post
                            Larry,
                            This isn't working with the latest beta of HomeSeer. I have set the option:
                            If ENABLED this will provide NETWORK support.
                            If DISABLED this will provide SERIAL-PORT support.
                            ENABLE or DISABLE Network: Disabled
                            Yet when I go to the Setup > Interfaces tab the COM Port column is still set to N/A
                            Yep, this is what I am seeing too. You can see my screenshot above.

                            That being said, if this is related to me using the Homeseer beta, I can fully understand if I am out of luck (at least until the beta becomes official!)

                            Thanks,
                            Scott

                            Comment


                              #15
                              Thanks Rupp, that sounds like a HS change that I am un-aware of. Are they going to fix this or is the functionality going to change?
                              -Larry

                              A member of "The HA Pioneer Group", MyWebSite

                              Plugins:
                              VWS, AB8SS, lrpSpeak, Calendar, Arduino, Harmony, BlueIris, Sprinklers, ZipBackup...

                              Hardware:
                              Intel NUC8i7BEH1 running Windows 10 Pro headless, HS3 Pro, Plex running on Synology dual High Availability DS-1815+ NAS (24Tb each), Synology Surveillance Station running on DS-416 Slim (8Tb), Samsung SmartThings, Google Home, Alexa, Hubitat Elevation, ZNET, Ubiquiti UniFi Network, Davis Vantage Pro II Weather Station. Whole house speaker system using a couple of AB8SS switches. Vantage Pro II Weather Station, Rain8Net Sprinklers, Hubitat Elevation, Google Home, Alexa, DSC Security System, Ubiquiti UniFi Network.

                              Comment

                              Working...
                              X