No announcement yet.

My iTach wont learn my remote

  • Filter
  • Time
  • Show
Clear All
new posts

    My iTach wont learn my remote


    I have been trying for a while now to get my iTach to learn the IR codes for my BOSE sound system. One of these: Sound system I have the non GS system.

    I can teach the iTach the codes for my TV and that works, but the codes for the very simple 4 button remote wont work. I use both the iLearn and the HS3 plugin.

    Any ideas of what I should try? Is there another way to enter the codes, like a list somewhere on the web which has most remotes or something?

    Greatful for help, it is annoying to be able to control all devices but one.

    You may try RemoteCentral

    I also had problems with some remotes on the iTach. You will also need the iConvert routine to convert the hex codes to "sendir" commands.



      Thanks for your quick answer.

      I am not getting it to work. I tried all five different models. Perhaps I am doing something wrong.

      For the first one "Bose Lifestyle - Zone 1


        I am not familiar with the plugin but the best way to test the converted code is to cut the sendir command and past it into iTest and send the command to the iTach. Be sure that you have the correct port selected for the iTach "sendir moduleort, frequency, repeat, offset". If you are using IR Blaster the port will be "3". If you have discrete ir the port will be for the ir connected to the Bose (1,2, or 3). when you can get the Bose to respond from iTest you can then put the command in the plugin. Hope this helps.

        Looking at your "sendir command" I think you need "sendir 1:3,"etc for module 1 port 3 if you are using the wifi iTach

        Last edited by Bob_Linux_User; April 23, 2014, 06:09 PM.


          Ok, solved it. It seems iConvert is missing some information. So what I needed to do was to copy the hex codes from the internet site, convert them using iConvert, copy the output and paste that into iLearn connected to my iTach. From there I can test that the code is working.

          I then need to copy that code again, I did it into notepad to remove any line feeds, dont know if its needed. Then copy that into the global cache homeseer plugin. That works for me.

          One think I am a bit annoyed over is that both iLearn and the plugin crashes or hangs temporarily quite a lot. I think the plugin does work when the codes are added and just executed.

          Edit: Correction, volume seems to be a problem. Since you need to click over and over again to raise or lower the volume there does not seem to be time for... something... so the plugin hangs when doing it. Not sure yet if it comes loose after a while, but restarting the homeseer web interface and the plugin seem to be the fastest way to get back to testing.

          Edit2: It seems the plugin does not hang, its just verrrrry slow. If I hit the volup button I created 10 times on my server side, then run over to the TV I can see the series of volup commands go into the receiver, one by one with ~1s between. And while that is happening, nothing else can be done.
          Last edited by Agwan; April 24, 2014, 02:33 AM.


            It seems like the problem is not just for the BOSE system. None of my remotes seems to be able to be read by iLearn or the HomeSeer plugin.

            Is this a problem many have, or is it just me? If I send the IR code to iLearn and it gets some data in there, why would that always not be the data the remote sent so that I can send it again?