Announcement

Collapse
No announcement yet.

Setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setup

    Hi All,

    I have been unlucky in getting the initial setup working. I put in the correct info as far as I can tell but my hub never is discovered.

    Click image for larger version

Name:	Screen Shot 2017-01-24 at 2.26.49 PM.jpg
Views:	1
Size:	45.8 KB
ID:	1210454

    Thanks,

    Jason

  • #2
    Can you sent me the logging during the scan of the activities and devices with debug on.

    Also on what device and OS are you running Homeseer on?
    Regards,

    Rien du Pre
    The Netherlands
    Using:
    Homeseer PRO latest HS4 BETA on a Raspberry
    Plugin's:
    RFXCOM, mcsMQTT, Z-Wave

    Comment


    • #3
      Where do I do that? I have debugging on. I use a Mac. Zee S2.

      Comment


      • #4
        Originally posted by serky View Post
        Where do I do that? I have debugging on. I use a Mac. Zee S2.
        I mean the normal Homeseer logging.
        Regards,

        Rien du Pre
        The Netherlands
        Using:
        Homeseer PRO latest HS4 BETA on a Raspberry
        Plugin's:
        RFXCOM, mcsMQTT, Z-Wave

        Comment


        • #5
          Plugin: Harmony Hub Get Devices ApplicationName='/usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux_arm.exe', CommandLine='xxxxxxx@xxx.com xxxxxxxxxx 192.168.2.84 list_devices_raw', CurrentDirectory='', Native error= Access denied-

          i assume it is stating my password is incorrect. i didn't want to show it. i have the same password on the hub as the config page so not sure what is happening.

          Comment


          • #6
            Originally posted by serky View Post
            Plugin: Harmony Hub Get Devices ApplicationName='/usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux_arm.exe', CommandLine='xxxxxxx@xxx.com xxxxxxxxxx 192.168.2.84 list_devices_raw', CurrentDirectory='', Native error= Access denied-

            i assume it is stating my password is incorrect. i didn't want to show it. i have the same password on the hub as the config page so not sure what is happening.
            Hi,

            Open a session to your ZEE and execute the following 2 commands:

            Code:
            cd /usr/local/HomeSeer/bin/HarmonyHub/
            sudo chmod +x harmonyhubcontrol_linux_arm.exe
            It should work as soon as you did this.
            Regards,

            Rien du Pre
            The Netherlands
            Using:
            Homeseer PRO latest HS4 BETA on a Raspberry
            Plugin's:
            RFXCOM, mcsMQTT, Z-Wave

            Comment


            • #7
              Can I do this from a MacBook?

              I tried with terminal and received this:




              Jasons-2016-MacBook-Pro:~ jason$ cd /usr/local/HomeSeer/bin/HarmonyHub/
              -bash: cd: /usr/local/HomeSeer/bin/HarmonyHub/: No such file or directory
              Jasons-2016-MacBook-Pro:~ jason$ sudo chmod +x harmonyhubcontrol_linux_arm.exe
              Password:
              chmod: harmonyhubcontrol_linux_arm.exe: No such file or directory
              Jasons-2016-MacBook-Pro:~ jason$

              Comment


              • #8
                Yes.

                But you first have to setup a ssh session to the zee using Terminal.

                Like ssh pi@192.168.0.185

                In you're in, execute the commands

                Originally posted by serky View Post
                Can I do this from a MacBook?

                I tried with terminal and received this:




                Jasons-2016-MacBook-Pro:~ jason$ cd /usr/local/HomeSeer/bin/HarmonyHub/
                -bash: cd: /usr/local/HomeSeer/bin/HarmonyHub/: No such file or directory
                Jasons-2016-MacBook-Pro:~ jason$ sudo chmod +x harmonyhubcontrol_linux_arm.exe
                Password:
                chmod: harmonyhubcontrol_linux_arm.exe: No such file or directory
                Jasons-2016-MacBook-Pro:~ jason$
                Regards,

                Rien du Pre
                The Netherlands
                Using:
                Homeseer PRO latest HS4 BETA on a Raspberry
                Plugin's:
                RFXCOM, mcsMQTT, Z-Wave

                Comment


                • #9
                  ssh: connect to host 192.168.2.84 port 22: Connection refused

                  Comment


                  • #10
                    Try,

                    ssh homeseer@192.168.0.185 and supply the correct password.
                    Regards,

                    Rien du Pre
                    The Netherlands
                    Using:
                    Homeseer PRO latest HS4 BETA on a Raspberry
                    Plugin's:
                    RFXCOM, mcsMQTT, Z-Wave

                    Comment


                    • #11
                      Thanks Rien du Pre,

                      I get to the password part and can't get in. I am using the password on the unit. I never changed it. Is there a different password I should be using?

                      Thanks,

                      Jason

                      Comment


                      • #12
                        Mac Access

                        Hi Serky,
                        I had very similar challenges to you. I am also using a Mac. here's what I did:

                        (1) Open up a terminal window (Go to Applications, Utilities, Terminal)
                        (2) check your router to see the IP address for HometrollerZee or other Hometroller device
                        (3) Type ssh homeseer@192.168.1.114 (or whatever your IP address was from step (2).
                        (4) Enter a password. Either "hsthsths3" if you haven't changed it, or your new password.
                        (5) Then type "cd /usr/local/HomeSeer/bin/HarmonyHub/" and hit return
                        (6) then type "sudo chmod +x harmonyhubcontrol_linux_arm.exe"
                        (7) Then go back to your Homeseer Webpage and go to Manage Plug-ins.
                        (8) First disable, then re-enable the Harmony plug-in.
                        (9) Go to your Harmony plug-in Device page and you should see your activities and devices. Let me know if you get stuck. -- Bob

                        Comment


                        • #13
                          Password

                          Try this password: hsthsths3

                          Comment


                          • #14
                            Bob,

                            Thanks so much. I see the Hub now. That was awesome.

                            If you don't mind and can lead me in the proper direction:

                            How would I create an event? For example when I use the Harmony to turn the TV on, I would like Homeseer to run the music off button.

                            I have been trying to set this up but am unclear without a little more direction.

                            Jason

                            Comment


                            • #15
                              Bob,

                              I was able to create this but it does not work. Have any experience with Events?

                              Does it know power os on based off the commands sent?



                              Click image for larger version

Name:	Screen Shot 2017-02-02 at 10.31.05 PM.jpg
Views:	1
Size:	33.5 KB
ID:	1188778

                              Thanks,

                              Jason

                              Comment

                              Working...
                              X