Announcement

Collapse
No announcement yet.

Not detecting devices or activities on linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rien du Pre
    replied
    Please see this thread for the solution. https://board.homeseer.com/showthrea...id=8&styleid=1
    Last edited by Rien du Pre; April 23, 2017, 11:32 AM.

    Leave a comment:


  • mrraptor
    replied
    No connection to Harmony Hub

    I have the same problem.

    Cannot find any device.

    Using linux debian Jessie 8.7

    Current Date/Time: 21/04/2017 10:52:52
    HomeSeer Version: HS3 Standard Edition 3.0.0.297
    Linux version: Linux raspberrypi 4.4.34-v7+ #930 SMP Wed Nov 23 15:20:41 GMT 2016 armv7l GNU/Linux System Uptime: 0 Days 15 Hours 24 Minutes 44 Seconds
    IP Address: 192.168.1.xxx
    Number of Devices: 217
    Number of Events: 55
    Available Threads: 399

    Enabled Plug-Ins
    3.0.0.32: EasyTrigger
    3.6.5.0: Harmony Hub
    3.0.0.68: HSTouch Server
    30.0.0.34: RFXCOM
    3.0.1.87: Z-Wave

    Leave a comment:


  • chrisgreene11
    replied
    You are running on an ARM processor, so using harmonyhubcontrol_linux_arm.exe.

    This isn't the one I recompiled I am afraid; it was the one for x86 processor.

    What version of Linux are you running?

    Leave a comment:


  • rjh2
    replied
    No activities or devices

    Devices and activities do not show up when scanning. Log info is:

    Plugin: Harmony Hub Get Activities ApplicationName='/usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux_arm.exe', CommandLine='hunter.r.39@rjhunters.com <my password here> 192.168.1.2 list_activities_raw', CurrentDirectory='', Native error= Cannot find the specified file-

    On a ZS2
    Plugin version 3.6.5.0
    Current version is: HS3 ZEE S2 Edition 3.0.0.313
    Hub is working perfectly.
    Hub and Alexa are working perfectly
    IP, login and password are correct (pinged, retyped several times) (I will set the IP address to static later in my router - no need to remind me that DHCP may issue another address.)

    Leave a comment:


  • chrisgreene11
    replied
    Permission given...have attached to this post as a ZIP.

    Please let me know how you get on, and please make sure you set the executable permissions correctly:

    Backup current file: mv /usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe /usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe.orig

    File goes in: /usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe

    Permissions Command: chmod 755 /usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe


    Chris
    Attached Files

    Leave a comment:


  • chrisgreene11
    replied
    Hi everyone,

    I have this compiled on jessie/sid (Ubuntu 14.04.1 LTS (GNU/Linux 3.16.0-031600-generic i686)), which is the latest OS that stock SEL units are shipped with (as far as i am aware).

    All working as expected (as far as i have tested, which is so far just scanning devices and activities, of which all appear!).

    I am waiting for Rien to confirm happy for me to share. I will send over to you when I can with instructions - I would be interested to hear peoples experiences.

    Thanks

    Chris

    Leave a comment:


  • chrisgreene11
    replied
    Yes please. I will of course treat your code in confidence (not that I would understand it anyway - I am a sys admin, not a coder) - happy to compile for the current SEL (Ubuntu 14.04) and supply to those in need

    Leave a comment:


  • Rien du Pre
    replied
    I can share the source with you, so it can be complied on any platform you like.

    I'm not familiar with Linux and this has been a struggle for me every time a compiling issue arises

    Leave a comment:


  • chrisgreene11
    replied
    Also, listing versions doesn't display the one needed, which also points towards the lack of 'GLIBCXX_3.4.21' being the problem:

    /usr/lib/i386-linux-gnu# strings libstdc++.so.6 | grep GLIBCXX
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBCXX_3.4.14
    GLIBCXX_3.4.15
    GLIBCXX_3.4.16
    GLIBCXX_3.4.17
    GLIBCXX_3.4.18
    GLIBCXX_3.4.19
    GLIBCXX_DEBUG_MESSAGE_LENGTH

    Edit: Upgrading libstdc++6 to 6.2.0-3ubuntu11~14.04 did not help. I now get GLIBCXX_3.4.21, however get the following error instead:

    usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe: relocation error: /usr/local/HomeSeer/bin/HarmonyHub/harmonyhubcontrol_linux.exe: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC1Ev, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

    The app seems to have been complied with a GCC version that isn't compatible with the versions installed on the factory SEL units.
    Last edited by chrisgreene11; March 28, 2017, 02:38 PM.

    Leave a comment:


  • chrisgreene11
    replied
    So, from a standard build SEL (Ubuntu 14.04 LTS), fully updated using apt, i get the following error when setting the application file 'harmonyhubcontrol_linux.exe' to 755 and just running (with and without command line options):

    ./harmonyhubcontrol_linux.exe: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./harmonyhubcontrol_linux.exe)

    This has to be it i guess - if it cant run via CLI, then it probably isn't going to work via the main interface.

    Rien, do you have any thoughts on this?

    Leave a comment:


  • chrisgreene11
    replied
    What works, exactly?

    My permissions are already set to 755 on that file and pressing Create HS Activity devices and Create HS hub devices creates one Harmony Hub device, labelled as Powered Off (it isnt) but still doesn't display any of my activities or devices when trying to scan - still the same error. Am also seeing the following in the log since creating that device:

    Exception in Hub_Polling_Timer_Elapsed : Conversion from string "" to type 'Integer' is not valid.

    Leave a comment:


  • lunkan
    replied
    Same here, can't get devices created. Pi3, HS3 Standard.
    From log:Plugin: Harmony Hub Test Get Active Activity output for:Hub1: -

    To get devices and activities in the plugin I needed to change permissions on harmonyhubcontrol_linux_arm.exe from 0644 to 0755.
    (in usr/local/HomeSeer/bin)

    Edit: It works if If I first "press" Create HS Activity device(s) and then "press" Create HS Hub device(s)
    Last edited by lunkan; March 19, 2017, 02:38 PM.

    Leave a comment:


  • chrisgreene11
    replied
    Did this ever get resolved? I am having the same issue on an SEL.

    Leave a comment:


  • akkie71
    replied
    I'm experiencing the same issue.
    HS3 Standard on Raspberry Pi2 (Ubuntu Mate)
    See the logging below:

    Feb-22 8:01:51 PM Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: -
    Feb-22 7:56:51 PM Plug-In Finished initializing plug-in Harmony Hub
    Feb-22 7:56:50 PM Info Plugin Harmony Hub has connected. IP:127.0.0.1:51370
    Feb-22 7:56:48 PM Plug-In Interface Harmony Hub is running as a trial, 28 days remaining.
    Feb-22 7:56:36 PM Info Plugin Harmony Hub with instance: has disconnected
    Feb-22 7:56:36 PM Plug-In Shutting down Plug-In: Harmony Hub
    Feb-22 7:55:44 PM Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: -
    Feb-22 7:54:44 PM Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: -

    Leave a comment:


  • Rien du Pre
    replied
    Originally posted by DeLicious View Post
    I was trying this out with my hub, but it's not detecting devices or activities.

    All I get in the log is:

    Feb-17 10:10:37 PM Harmony Hub Plugin: Harmony Hub Test Get Devices output for :Hub1: -
    Feb-17 10:10:35 PM Harmony Hub Plugin: Harmony Hub Test Get Activities output for :Hub1: -

    I confirmed that I had it set up with the right username and password, and I double-checked the IP address several times, including pinging it and making sure it was responsive. Is there anything else I can try in order to get my devices and activities sync'd?
    Is debug enabled ?
    I need more logging to investigate.

    Leave a comment:

Working...
X