Announcement

Collapse
No announcement yet.

Missing activities and International characters does not decode propertly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing activities and International characters does not decode propertly

    Attached Files
    Last edited by janjoh; November 29th, 2016, 01:05 PM.

  • #2
    Debug for Get Activities

    nov-29 19:10:07 Harmony Hub Plugin: Harmony Hub Test Get Activities output id is PowerOff
    nov-29 19:10:07 Harmony Hub Plugin: Harmony Hub Test Get Activities output for :Hub1: ----1---PowerOff -
    nov-29 19:10:04 Harmony Hub Plugin: Harmony Hub Running Windows version of HarmonyHubControl
    nov-29 19:10:04 Harmony Hub Plugin: Harmony Hub OS type is 0
    nov-29 19:10:02 Z-Wave Device: Lower Floor Kitchen Island Lights - Momentary power usage Set to 11,6 (W)
    nov-29 19:08:37 Harmony Hub Error Exception in Hub_Polling_Timer_Elapsed : Conversion from string "" to type 'Integer' is not valid.
    nov-29 19:08:37 Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: 16359735 -

    Comment


    • #3

      Comment


      • #4

        Comment


        • #5
          oh.. the devices have populated now.. but still only 1 activity.

          Comment


          • #6
            nov-29 19:43:37 Harmony Hub Error Exception in Hub_Polling_Timer_Elapsed : Conversion from string "" to type 'Integer' is not valid.
            nov-29 19:43:37 Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: 16359735 -

            Comment


            • #7
              Originally posted by janjoh View Post
              nov-29 19:43:37 Harmony Hub Error Exception in Hub_Polling_Timer_Elapsed : Conversion from string "" to type 'Integer' is not valid.
              nov-29 19:43:37 Harmony Hub Plugin: Harmony Hub Test Get Active Activity output for:Hub1: 16359735 -
              The plugin only finds just 1 activity. Can you sent me the .ini file of the plugin and the list of activities you expect ?
              Regards,

              Rien du Pre
              The Netherlands
              Using:
              Homeseer PRO latest HS4 BETA on a Raspberry
              Plugin's:
              RFXCOM, mcsMQTT, Z-Wave

              Comment


              • #8
                Originally posted by Rien du Pre View Post
                The plugin only finds just 1 activity. Can you sent me the .ini file of the plugin and the list of activities you expect ?
                [Settings]
                cb_debug_checked=1
                Hub_Polling_Interval=5
                OS version=Windows
                Architecture=x86
                [Hub1]
                cb_hub1_checked=1
                [EMAIL=[redacted]

                Comment


                • #9
                  Here are the activities.
                  Attached Files

                  Comment


                  • #10
                    Can you do a rescan of the activities, or did you do that allready several times ?
                    Regards,

                    Rien du Pre
                    The Netherlands
                    Using:
                    Homeseer PRO latest HS4 BETA on a Raspberry
                    Plugin's:
                    RFXCOM, mcsMQTT, Z-Wave

                    Comment


                    • #11
                      Originally posted by Rien du Pre View Post
                      Can you do a rescan of the activities, or did you do that allready several times ?
                      I have done that several times. The result is always the same.

                      Comment


                      • #12
                        Originally posted by janjoh View Post
                        I have done that several times. The result is always the same.
                        OK.

                        Go to the <Homeseer> root folder on your system and execute the following command:
                        bin\Harmonyhub\HArmonyHubControl <logitech userid> <logitech password> <ipaddress of the hub> list_activities

                        And sent me the output
                        Regards,

                        Rien du Pre
                        The Netherlands
                        Using:
                        Homeseer PRO latest HS4 BETA on a Raspberry
                        Plugin's:
                        RFXCOM, mcsMQTT, Z-Wave

                        Comment


                        • #13
                          Originally posted by Rien du Pre View Post
                          OK.

                          Go to the <Homeseer> root folder on your system and execute the following command:
                          bin\Harmonyhub\HArmonyHubControl <logitech userid> <logitech password> <ipaddress of the hub> list_activities

                          And sent me the output
                          Here you go.
                          Attached Files

                          Comment


                          • #14
                            Ok this proves there is no problem in the plugin.

                            Now we have to find out why your activities are not detected.

                            Can you remove the slash between TV and Netflix in that activity and try again?
                            Regards,

                            Rien du Pre
                            The Netherlands
                            Using:
                            Homeseer PRO latest HS4 BETA on a Raspberry
                            Plugin's:
                            RFXCOM, mcsMQTT, Z-Wave

                            Comment


                            • #15
                              Originally posted by Rien du Pre View Post
                              Ok this proves there is no problem in the plugin.

                              Now we have to find out why your activities are not detected.

                              Can you remove the slash between TV and Netflix in that activity and try again?
                              Can i trigger a sync via the plugin?

                              (I am at work, i have removed the slash, but of course i need to trigger a sync of the hub)

                              Comment

                              Working...
                              X