No announcement yet.

Did the 2.1 upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

    Did the 2.1 upgrade


    Thanks, I went to 2.1 and all seems OK.

    Now installed the plugin through the updater, but can not get past the interface setup paged. Once I hit the config button, I get an error in the logfile
    GetHtml:The web page could not be builtbject refence is not pointing to an instance of an object.

    help appreciated !

    Also, were does the plugin keep the IR codes so I can paste them in ...? I have too many to re-learn them.



    Hi Evja,

    GetHtml:The web page could not be built because the object refence is not pointing to an instance of an object.
    Hmmm, it seems like I ran into that at one point in the 2.1 series as well. I'm running at the moment and all is well. What build are you running?

    Also, where does the plugin keep the IR codes so I can paste them in ...? I have too many to re-learn them.
    I hear ya on that! The codes are stored in the remotes folder under whatever folder you installed the IRTrans stuff; usually
    C:\Program Files\IRTrans\remotes
    The file is called hs2_signals.rem. To HS, all of the codes are in one big remote. If you cut and paste, you'll want to copy over any timings as well and renumber as appropriate.




      Just in case you want to try a new build, I'm attaching build 106. I believe the only difference is that the IRTrans.NET.dll is targeted to version 2.0 of the .net framework just like the plug-in itself.
      Attached Files


        Hi YoYo,

        I was on 2.1.66 with no luck. went backto 2.1.43 same issue.
        Reinstalled .net2 to be sure, no change. Tried reinstalling the plugin through the updater, but issue remains the same.

        Not sure where to go next, how did you get it working if you had the same error before ?

        Also, I don't see the hs2_remotes in my Irtrans remotes folder. all my other ones are there, but HSdoes need seem to create it. As I cannot go to the config page of the plugin, is that were the .rem file gets created or once you add a new device ? I have tried adding a device, but no file appears to be created.




          Some success


          Have been f'ing around wiht HS and did manage to get it learn signals and add those the hs2_signals.rem file. It properly shows codes learned.

          I am still not able however to get to the config page, same error as before. Looking up the error on google it shows the call is refering to an undefined object, or the object does not exist.

          Since you are calling the HS config page, what is referring to ? A web page, or so ?

          If we get that to work I am all up and running again.....




            Hi Jan,

            I appreciate your patience on this... Looks like everything is working OK except for the config page?

            Just to be sure, I copied over the latest version of the plug-in, posted above, and tested access to the config page with HS 2.1.43, all worked fine.

            Then, I updated to 2.1.68 and tested again, still all fine.

            I wish I could remember the context in which I had received the message myself. I thought it was back on version 2.1.8. I remember getting the message, reviewing the code and thinking, no problem here; then downloading the latest beta at the time, which I think was 2.1.43 and the problem went away. I guess I had just assumed it had been a problem in the one of the beta builds. I have it installed on 3 different PCs with different configurations and none are giving any problems...

            If you haven't already done so, would you consider installing build 106 of the plug-in attached to one of the messages earlier in this thread? To do so, you would just replace the existing 2 files with the ones in the archive, and they both reside in the HomeSeer program folder.

            Let me know how it goes...



              Did the upgrade to new build of plugin, but issue remains the same. Also tried HS2.1.75, but no change.

              IR sending and learning is fine however, which is the bit that counts !




                Thanks for trying it, Jan.

                I guess I'll have to dig into things a bit deeper and see if I can reproduce it on my end. Luckily, there's not much to config with this plug-in .

                I'm attaching the config file that the plug-in uses if you want to edit the default settings. As I recall, the plug-in won't actually create a config file until you change a particular setting. it just uses the default settings of "localhost" for the IRTrans Server PC, "false" on Use zones, and "False" on debugging.

                The file is just an ordinary xml file which you can edit with any text editor to change whatever setting you'd like. However, changing things this way will require you to restart HomeSeer to see the effects, (or maybe disabling, then enabling the plug-in via the Interfaces tab).

                The file belongs in the Config folder under your HS 2 installation folder...
                Attached Files