No announcement yet.

Cannot get IRTRans Server to load at startup

  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot get IRTRans Server to load at startup

    I am new to IRTrans so pardon me if I am missing something easy. When I reboot my PC and place IRTrans in the startup folder along with HS I get an error that IRTrans cannot load. When I click OK and then manually start IRTrans it works fine. I have tried a few programs that put a delay on your startup items so that IRTrans starts then HS start or vice-vera but either way I cannot get IRTrans to work unless I manually start the program. I have HS reboot everyday since it seems to run better this way so having IRTrans auto-load is really important in my setup. Anyone have any suggestions.

    I can successfully run IRTrans server at startup using HS 2.2, IRTrans Server, and Win2K SP4.

    Have you checked the event log for errors? Also, on the outside chance that it's related to the plugin you might check that error log, too. I think it defaults to C:\IRTransLog.txt. The debug settings are in hspi_IRTrans.Settings.xml.


      It looks like that ast around 5:57am this morning my server restarted. Here are the error logs:

      In IRTrans Log:

      IRTrans Warning : Debug Mode activated. Waiting 10 secs...
      05:57:04.7968750 : STATUS 3 : IRTrans Warning : Debug Mode activated. Waiting 10 secs...
      31/03 05:57:14.8125000 : STATUS 3 : StartConnectionMonitor: Starting thread ConnectionMonitorThread
      31/03 05:57:14.8125000 : STATUS 3 : SupportsIRMatch() called, returning true
      31/03 05:57:14.8125000 : STATUS 3 : MaxDevices() called
      31/03 05:57:14.8125000 : STATUS 3 : MaxKeys() called
      31/03 05:57:14.8125000 : STATUS 3 : MaxZones() called
      31/03 05:57:16.0312500 : STATUS 3 : irtCreateInstance: irt instance could not be created: Cannot connect to IRTrans Server
      31/03 05:57:16.0312500 : STATUS 3 : IRTrans Error : Connection attempt to localhost has failed. Will retry every 30 seconds...
      31/03 05:57:46.9375000 : STATUS 3 : irtCreateInstance: irt instance could not be created: Cannot connect to IRTrans Server

      The HS Log says about the same things.


        Also, when IRTrans first starts up I get this error message:

        IRServer Version 5.7.19
        [0]: IRTrans LAN: IR VER: E5.05.09 ETH VER: L1.05.08 SN: 23909 MAC: 00-50-c2-52-75-aa
        Could not open Remote Database (No folder 'remotes' /Access rights ?)

        Once I say OK and then maually start IRServer everything is fine.


          Hi plessdude,

          FYI, it is not critical that the IRServer start before HS, although it is generally desirable. Generally, if HS and IRTransTray/IRServer are launched at the same time, IRTransTray/IRServer will be executing well in advance of HS due to it's small size; i.e. it just loads a lot quicker.

          Nonetheless, the IRTrans plug-in will get along fine even if IRTransTray/IRServer is not running at the time the plug-in initializes. What happens is that it periodically (about once every 30 seconds), tries to connect to IRServer until it is successful. This means that you are free to shut down IRServer and restart it while HS is running will no ill effect. That's what you're seeing in the log snippet you included above...

          Now, about the startup problem, I'm just taking a guess here, but it would appear that the startup folder is not set on the shortcut you've created. In other words, the program is launching, but cannot find the data files because it's looking in the wrong folder. Assuming a standard installation, the Start in: field would also be set to "C:\Program Files\IRTrans\"

          I doubt it's an access rights problem because you say you can start it manually just fine. Maybe take another look at the shortcut you've placed in the startup folder and let us know what you discover....



            Thanks for the help. I checked to see if the shortcut was pointing to the right directory and it is. One thing I have noticed is that the icon for a lan server connection is not in the IRtrans program folder. I have to use the shortcut it makes in Start Menu folder. Maybe this is the issue. The Start Menu folder shortcut does point to IRTrans folder on my c-drive but there is no icon there. I tried using the IRServer Icon in the acutal Program folder but that one appears to be for USB connections. I reinstalled the software but still get the same result.


              Well I still cannot figure out what the issue was even after cleaning out the registry and starting from scratch. The only way I was able to make it work was by downloading a startup manager and placing the shortcut to the LAN icon on my desktop and linking from there. I have to keep the icon on the desktop or it won't work. After 5 hours of trial and error I am just happy it actually works.


                Hi plessdude,

                Well maybe it is a security issue. Once your system starts and the desktop is displayed, can you click Start | All Programs | Startup | IRTransTray without errors? I had assumed you were always trying to launch it from there. I still think something is screwed up with the shortcut you've placed in the Startup folder. I can think of no good reason why it shouldn't launch on startup...

                I guess the only thing the startup mgr is doing is launching it from the desktop shortcut, rather than the Startup folder. That has to be a significant clue... Perhaps try creating a shortcut in the Startup folder from scratch??

                I'm sorry we're not much help to you on this, just haven't had any issues in this area...


                  Thanks YoYo. I assumed this was an issue with my setup and not the program. I tried putting the shortcut in all kinds of places. No luck. Only want s to work when I put in on the desktop and set it so it opens 45 seconds after Homeseer starts. I hate Windows!!!! If they only made Homeseer for the Mac life would be easier.