Announcement

Collapse
No announcement yet.

There was no device found at the IP address.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • There was no device found at the IP address.

    I have two Harmony hubs, each linked to a Harmony Touch remote. I've had these working for a little while now.
    With the first hub, I am using the free plug-in (I don't need activity updates in HomeSeer, just the ability to set the activity and to control devices).
    Tonight, I tried to add the 2nd hub to the free plug-in, but it won't connect/doesn't see it. So, I thought I would give your plug-in a try. It's not working with it either. I get this in the log.
    Dec-11 9:09:29 PM MeiHarmonyHub: Error The Connection to Hub with ID failed with stack trace: at System.Net.Sockets.TcpClient..ctor(String hostname, Int32 port) at HarmonyHub.Client.Connect(Int32 heartbeatInterval)
    Dec-11 9:09:29 PM MeiHarmonyHub: Error The Connection to Hub with ID failed with message: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.28:5222
    I have the other plug-in disabled for this hub, but still controlling the other hub. I've tried changing this hub's IP address (Static from the router), but that doesn't change anything. I can ping it with no errors from the HomeSeer PC. It also works fine from the phone ap. I've also tried depowering the hub and repowering it. I've also tried it with the Windows firewall turned off.

    Would anyone have any further troubleshooting steps for me to try to resolve this? Below are the HomeSeer details.
    System Information
    Current Date/Time: 12/11/2018 9:19:33 PM Central Standard Time
    HomeSeer Version: HS3 Pro Edition 3.0.0.435 (Windows)
    HomeSeer: Is Registered
    Operating System: Microsoft Windows 10 Pro - Work Station
    OS Version: 10.0.17134 Service Pack: 0.0
    System Uptime: 0 Days 1 Hour 39 Minutes 39 Seconds
    User Name and Access Level: xxxxxxxxxxx(Admin)
    LAN IP Address: 192.168.1.45 (server)
    Client IP Address: 192.168.1.116 (Joe-PC)
    External IP Address: 127.0.0.1 (server) Unable to get WAN IP, MyHS and Find service disabled in setup
    Network Adapter: Adapter -> Intel(R) 82567V-2 Gigabit Network Connection IP: 192.168.1.45/24 MAC: 00:1D:72:BEC:89
    Network Adapter: HomeSeer Adapter -> Loopback Address (localhost) IP: 127.0.0.1
    Web Server Port: 81
    Number of Devices: 472
    Number of Events: 406
    Event Last Ran: Weather : Get Small Radar png, Ran at 12/11/2018 9:16:32 PM
    Number of unique event scripts used: 1
    Connected Speaker Clients: SERVER (127.0.0.1)EFAULT, SERVER (192.168.1.88):KITCHEN, SERVER (192.168.1.117):GARAGE, SERVER (192.168.1.119):HALL
    Plug-Ins Enabled: BLBackup:,BLUPS:,BLShutdown:,drhsIpPlugIn:,BLSpeech:,Pushove r 3P:,BLOnkyo:,NetCAM:,PHLocation:,Insteon:,Z-Wave:,Harmony Hub:,MeiHarmonyHub:,Harmony Hub:Bedroom
    Processor Type and Speed: Intel64 Family 6 Model 23 Stepping 10 at 2.18 GHz
    Modules/Threads: 169 Modules, 141 Threads
    Available Threads: 400
    System Processes/Load: 152 Processes, 4% Load
    Free / Total Physical Memory: 5.56 GBytes / 7.97 GBytes (70% free)
    Free / Total Virtual Memory: 6.66 GBytes / 9.22 GBytes (72% free)
    HomeSeer Memory Used: 125 Mbytes
    Plug-In Memory Used: 14 EXE Plug-Ins using 386 Mbytes

  • #2
    Since this appears to be an issue between both plugins, I'm going to ask if perhaps this hub is far from your wireless access point? Also note that I have heard that the quality of power supply can adversely affect the wifi in the hub (I hear they used a pretty crappy wifi module in them and a bad power supply can cause it to not work all that well).

    I also have this notice about their wifi and if you have your router automatically choosing the best channel: https://forums.homeseer.com/forum/au...12#post1242512

    edit: sorry, I don't know what I was doing when I first typed this message. Fixed it to make more sense.
    MeiAutomtion Home

    Comment


    • #3
      Thanks. It remains a mystery to me. I do think it's something about the hub, and not the plugins. I have tried it in the same room as the router, as well as where it goes. I've tried it powered by the wall wart it came with, as well as with the USB from a PC. The router says the signal is good. The phone app shows it as the correct IP address, and doesn't have trouble connecting to it.

      As cheap as they are (used/refurbished), I'm going to get another one to see if it is some fault with this one. Also, I'm not sure I have it set up right. On the PC app, it shows the hub as having no devices and no activities, but it does have both when using the Harmony Touch, or the phone app. I suspect that I will also try doing a factory reset on both the hub and the remote. I just have to work myself up to it because of the pain of redoing all the settings for the buttons and the screen again. Maybe this weekend...

      Comment


      • #4
        yeah, I've had to do a couple of factory resets on hubs (I have 5) for various reasons. I've noticed that when restoring it it asks me if I want to restore from another remote and I can choose the config for that hub. Of course they don't tell you the name only the number of devices and activities so it's a crap shoot sometimes.

        Since you don't see anything in the PC app, I wouldn't do the above and just start from scratch. It's painful, but I would want to make sure I can see it in the PC app. Granted, I don't use my phone for adding devices/activities, i use the PC app for that.
        MeiAutomtion Home

        Comment


        • #5
          Well, a factory reset of both the hub and the touch didn't change anything. I rebuilt the devices and activities from scratch (I deleted the remote and hub from my account before the factory reset).
          The only real difference that I see between the working pair and the non-working one is that the working one is at hub software version 4.15.201, and then non-working is at 4.15.206.

          I guess I'll get another hub and try that.

          Comment


          • #6
            OK, so you are the first user affected by this. Read this post: https://forums.homeseer.com/forum/au...etwork-control

            Firmware 206 removed local access to the hubs. I just found out tonight. I'm going to update one of my hubs and try and find a a way around it, but for now, the only way to get around it is to roll back the firmware to at least .201

            There are instructions here (I think in German) to go back to an earlier version of the firmware: https://www.harmony-remote-forum.de/...ic.php?t=13699

            If you use chrome, it will ask to translate the page for you. I haven't had a chance to upgrade a hub and then try and roll it back yet. Like I said I just found out tonight about this issue with .206.
            MeiAutomtion Home

            Comment


            • #7
              same issue here, on one of my 4 hubs, i blocked internet access to alll hubs immediatly, and try a downgrade tonight on the broken hub.
              Regards Bart
              ------------------------------------------
              Win7 64Bit on Intel NUCI7 with SSD
              HSPRO 3.
              Devices; 1370 Events; 691

              Jon00 Scripts, JowHue, HSTouch, Plugwise, Z-wave, Ultranetatmo, Ultracam, PHlocation, BLUSBUIRT, MeiHarmony, Buienradar, MEiUnifi Pushover 3P, Random, Nest HSPhone and Blueiris

              Visonic Powermax Alarm System (HS3) Interface: http://www.domoticaforum.eu/viewtopic.php?f=68&t=11129

              Comment


              • #8
                Thanks. It makes a lot more sense now. I guess I'll have an extra hub now...

                Comment


                • #9
                  The firmware downgrade process worked for me. I also blocked all internet access from the hubs IP addresses. I found that I still couldn't add that 2nd hub to HomeSeer. Looking at the logs, it was because it couldn't get a token. I unblocked that hub from the internet and then I could add it. After that, I blocked it again.

                  I guess this (blocking it) will work till I need to add a device or activity...

                  Comment


                  • #10
                    I haven’t used my MeiHarmony plug in for a while - trying to use it again to no avail. Looks like last activity was mid-2018. My firmware is .250 - do I need to roll that back to .201 or has this since been fixed. In my troubleshooting before finding this thread, I removed the plug-in and deleted the devices. Re-installed the plug-in and discovered the hub, but now cannot add devices: control devices button doesn’t show me the hub, just ‘————‘.

                    Edit: There is one device that showed up. MeiHarmony Root, with last change time about 30 minutes ago. Nothing listed in the ‘control’ area.

                    Edit2: I found this site to downgrade for XMPP ‘beta’ to allow local access. It put me to version .210. I’m back to being connected!
                    Here’s the link (in English): https://www.theverge.com/2018/12/21/...ome-automation

                    Thank you - hope this helps someone else.

                    Comment


                    • #11
                      Hi OmahaRob ,

                      With the latest firmware you need to enable the XMPP API which is disabled by default. Follow the directions in the thread below to "opt in".

                      Ken

                      https://forums.homeseer.com/forum/au...plugin-to-work

                      Comment


                      • #12
                        Thank you, kenm.

                        Comment

                        Working...
                        X