Announcement

Collapse
No announcement yet.

ALERT !!! Harmony Hub firmware v4.15.206 breaks/removes local network control.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ALERT !!! Harmony Hub firmware v4.15.206 breaks/removes local network control.


    **_Stay on 201 or lower_**

    Hey guys and gals caught this on reddit. Luckily mine had not updated yet. so i blocked access into as well as out of my network from the address at the following links via tomato router firmware . I am sure any firewall rule would work as well. Hopefully this works as i can't find a way to turn off auto updates on the harmony hub.
    Hope this saves some of us some headaches!
    I got the addresses from here:
    https://support.myharmony.com/en-hn/...based-products

    addresses that i blocked :

    svcs.myharmony.com
    pubsub.pubnub.com
    content.dhg.myharmony.com
    logging.dhg.myharmony.com
    myharmony.com
    sus.dhg.myharmony.com

  • #2
    Can you please link to the Reddit post about this?

    Sent from my Pixel 2 XL using Tapatalk

    Thanks,
    Frank

    Comment


    • #3
      Thanks for that. I blocked mine from the internet as well. This is unfortunate as I do not believe they can be reconfigured without connecting to their servers, when they will likely force an update.

      Let's hope this gets sorted soon.
      Randy Prade
      Aurora, CO
      Prades.net

      PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

      Comment


      • #4
        Found the Reddit post for those that want to follow it:

        https://www.reddit.com/r/logitechhar...e_integration/


        I'll try and see what I can find out. I can't believe they would do this after years of allowing local control.

        Sent from my Pixel 2 XL using Tapatalk

        Thanks,
        Frank

        Comment


        • #5
          I am also seeing calls to this url: ps-959.pubnub.com
          t might be best to do a wildcard block on the main domain: *.pubnub.com.

          So far all of my hubs are still on .201. I will pull the phone app apart again and see what they are doing. I'm also going to let one of my hubs update to .206 so I can try and get the plugin working with that version.
          Thanks,
          Frank

          Comment


          • #6
            Originally posted by sirmeili View Post
            I can't believe they would do this after years of allowing local control.

            Just like Apple, Google and all the rest, they want to monetize every aspect. They just hate it when we can find convenience in their products without their control over the use.

            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Originally posted by rprade View Post
              Just like Apple, Google and all the rest, they want to monetize every aspect. They just hate it when we can find convenience in their products without their control over the use.
              But it is not like they are offering us a way to do it where they make money. As a matter of fact, this could cost them some money (though granted perhaps not that much). I will likely try and call Logitech and get someone on the phone to see if they can give me answers even though I know they won't care.
              Thanks,
              Frank

              Comment


              • #8
                Originally posted by MattLau
                my log is full of theses since 6 pm. I just disabled logs in the plugin.
                Code:
                 
                Dec-16 18:29:53 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with message: No route to host
                Dec-16 18:29:45 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with stack trace: at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in <567e8c646c2d4dfb817eaad732e570bc>:0 at HarmonyHub.Client.Connect (System.Int32 heartbeatInterval) [0x00040] in <4440a71514154d3c8db66fb219eeead2>:0
                Dec-16 18:29:45 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with message: No route to host
                Dec-16 18:29:37 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with stack trace: at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in <567e8c646c2d4dfb817eaad732e570bc>:0 at HarmonyHub.Client.Connect (System.Int32 heartbeatInterval) [0x00040] in <4440a71514154d3c8db66fb219eeead2>:0
                Dec-16 18:29:37 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with message: No route to host
                Dec-16 18:29:29 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with stack trace: at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in <567e8c646c2d4dfb817eaad732e570bc>:0 at HarmonyHub.Client.Connect (System.Int32 heartbeatInterval) [0x00040] in <4440a71514154d3c8db66fb219eeead2>:0
                Dec-16 18:29:29 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with message: No route to host
                Dec-16 18:29:21 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with stack trace: at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in <567e8c646c2d4dfb817eaad732e570bc>:0 at HarmonyHub.Client.Connect (System.Int32 heartbeatInterval) [0x00040] in <4440a71514154d3c8db66fb219eeead2>:0
                Dec-16 18:29:21 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with message: No route to host
                Dec-16 18:29:13 MeiHarmonyHub: Error The Connection to Hub with ID 282f07b9-61de-4bbb-adcd-58a082d3ee7e failed with stack trace: at System.Net.Sockets.TcpClient..ctor (System.String hostname, System.Int32 port) [0x0006d] in <567e8c646c2d4dfb817eaad732e570bc>:0 at HarmonyHub.Client.Connect (System.Int32 heartbeatInterval)
                I blocked all the adress mentionned in this thread 10 minutes ago. My two hubs works but the logging error wasnt interrupted.
                Can you open the phone app, go to one of the hubs that is having the issue, to the settings and about and see what version of the hub software it is running? I want to know if this is related to this issue or not.
                Thanks,
                Frank

                Comment


                • #9
                  Originally posted by sirmeili View Post

                  Can you open the phone app, go to one of the hubs that is having the issue, to the settings and about and see what version of the hub software it is running? I want to know if this is related to this issue or not.
                  I removed my post. I just tested one of my two hubs.

                  I realized my cat ( or my girlfriend) pulled the plug from the wall by accident.
                  The log did mention just one of the hub so that was suspicious.

                  Comment


                  • #10
                    I think it was written 4.15.201. I have been logged out of the app

                    Comment


                    • #11
                      Rather than blocking specific sites I just blocked the IP addresses for both of my hubs from accessing the internet at all.

                      Does anyone see any issues with this?

                      Ken

                      Comment


                      • #12
                        I don't think so and it probably a better idea if you ask me, but I'll wait and see if someone else has an opinion on it.
                        Originally posted by kenm View Post
                        Rather than blocking specific sites I just blocked the IP addresses for both of my hubs from accessing the internet at all.

                        Does anyone see any issues with this?

                        Ken
                        Sent from my Pixel 2 XL using Tapatalk

                        Thanks,
                        Frank

                        Comment


                        • #13
                          Originally posted by kenm View Post
                          Rather than blocking specific sites I just blocked the IP addresses for both of my hubs from accessing the internet at all.

                          Does anyone see any issues with this?

                          Ken
                          Should be fine. I just added mine to a rule to drop requests for all protocols. This is the same rule I use for my security cameras.
                          Randy Prade
                          Aurora, CO
                          Prades.net

                          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

                          Comment


                          • #14
                            I've attempted to block my hubs by IP in my Unifi USG. Anyone know how I can test if it's working?
                            Thanks,
                            Frank

                            Comment


                            • #15
                              Well, even though I had those domains blocked last night, 3 of my hubs updated to .206 and no longer work. I'll have to try and revert them and block their internet access.
                              Thanks,
                              Frank

                              Comment

                              Working...
                              X