Announcement

Collapse
No announcement yet.

Logitech Local API Access - How to get the current version of the plugin to work

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by sirmeili View Post
    Are you running this in Linux? I've seen this sometimes with Linux.

    Sent from my Pixel 2 XL using Tapatalk
    Yes I'm on linux on a PI, is ther annything I can do to make it work

    Comment


    • #47
      Originally posted by Paul32 View Post
      See error message in screenshot
      I am getting the exact same error just as I am trying out this plugin. I have my hub updated to .210 and when I do a Add by IP, I get a "There was no device found at the IP address." and the exact same error is logged in HomeSeer's log. So I cannot add my Harmony hub at all right now. I'm using a HomeSeer SEL Pro. So it's Linux. I'm hoping for a fix. Do really want to buy this plugin but right now I cannot get it to work at all.

      Here's my error log which is pretty much identical to Paul32's
      Jan-04 14:59:50 MeiHarmonyHub: Error The Connection to Hub with ID failed with stack trace: at System.Runtime.Serialization.Json.JsonSerializationReader.De serializeGenericCollection (System.Type collectionType, System.Type elementType) [0x00000] in :0 at System.Runtime.Serialization.Json.JsonSerializationReader.Re adObject (System.Type type) [0x00000] in :0 at System.Runtime.Serialization.Json.TypeMap.Deserialize (System.Runtime.Serialization.Json.JsonSerializationReader jsr) [0x00000] in :0 at System.Runtime.Serialization.Json.JsonSerializationReader.Re adObject (System.Type type) [0x00000] in :0 at System.Runtime.Serialization.Json.JsonSerializationReader.Re adRoot () [0x00000] in :0 at System.Runtime.Serialization.Json.DataContractJsonSerializer .ReadObject (System.Xml.XmlReader reader, Boolean verifyObjectName) [0x00000] in :0
      Jan-04 14:59:50 MeiHarmonyHub: Error The Connection to Hub with ID failed with message: Expected element 'item', but found 'Harmony' in namespace ''. Error at (1,247)

      Comment


      • #48
        This error is due to a third party library (Newtonsoft.Json) not parsing correctly on some linux Installs. I've verified the config coming back is correct, but it's not parsing it correctly (the same config will parse correctly on my windows machine). I will update the version of that library as I think there is a newer version and release it into the beta stream. I will report back once I have released it. I will try and get that done tonight for you all.
        Thanks,
        Frank

        Comment


        • #49
          Also can you both tell me what version of Mono you are running?
          Thanks,
          Frank

          Comment


          • #50
            Okay in my case it is caused by the Mono version. Once I updated Mono it is working. Thanks.

            Comment


            • #51
              Originally posted by phoenix View Post
              Okay in my case it is caused by the Mono version. Once I updated Mono it is working. Thanks.
              Glad to hear it. Are you on Mono 5 now? and do you know what you were on before? I think some users have this even on later versions of Mono. It's a very frustrating bug unfortunately.
              Thanks,
              Frank

              Comment


              • #52
                Originally posted by sirmeili View Post
                Also can you both tell me what version of Mono you are running?
                I have: Mono JIT compiler version 3.2.8

                Comment


                • #53
                  Originally posted by Paul32 View Post

                  I have: Mono JIT compiler version 3.2.8
                  I think upgrading to mono 5 can fix this, but Obviously take a backup before doing it. Otherwise you might have to wait for me to try the new version of NewtonsoftJSON.

                  As an aside, is this the linux version running a Pi or are you running the Pi version of HS3 (I want to keep track on which installs these issues happen).
                  Thanks,
                  Frank

                  Comment


                  • #54
                    Make sure you use Tools | Setup | Lab to export the events first before upgrade Mono. Then after Mono upgrade, use Import Events to import it back. Otherwise, all event triggers will be gone after upgrade from 3.2.8 to 5.x. I made that mistake to upgrade Mono without doing it. And then I had to roll it back to 3.8 to get my events back.

                    Comment


                    • #55
                      phoenix , would you mind giving me directions to:

                      check the version of Mono on an SEL
                      update mono to 5 on the SEL?

                      If you could it would be greatly appreciated.
                      Thanks,
                      Frank

                      Comment


                      • #56
                        Originally posted by sirmeili View Post

                        I think upgrading to mono 5 can fix this, but Obviously take a backup before doing it. Otherwise you might have to wait for me to try the new version of NewtonsoftJSON.

                        As an aside, is this the linux version running a Pi or are you running the Pi version of HS3 (I want to keep track on which installs these issues happen).
                        Update:
                        It is my "test" PI self made with HS3 Full (not a hometroller Zee)
                        I treid to upgrade mono, but no succeed yet
                        I did this lines:
                        sudo apt-get update
                        sudo apt-get upgrade
                        It was doing a lot!!
                        But still mono 3.2.8

                        But the good news is I enabled the plug-in on my running systeem (Self made HS3 Full SEL on Linux, with Mono JIT compiler version 5.4.1.6)
                        And it works

                        If you now how to upgrade mono, I can test it!

                        Comment


                        • #57
                          Originally posted by Paul32 View Post

                          Update:
                          It is my "test" PI self made with HS3 Full (not a hometroller Zee)
                          I treid to upgrade mono, but no succeed yet
                          I did this lines:
                          sudo apt-get update
                          sudo apt-get upgrade
                          It was doing a lot!!
                          But still mono 3.2.8

                          But the good news is I enabled the plug-in on my running systeem (Self made HS3 Full SEL on Linux, with Mono JIT compiler version 5.4.1.6)
                          And it works

                          If you now how to upgrade mono, I can test it!
                          Update:
                          Finaly i have: Mono JIT compiler version 5.10.1.20
                          And now it also works on my PI

                          Comment


                          • #58
                            Originally posted by sirmeili View Post
                            phoenix , would you mind giving me directions to:

                            check the version of Mono on an SEL
                            update mono to 5 on the SEL?

                            If you could it would be greatly appreciated.
                            Check version of Mono on an SEL go to Tools | System | Linux Tools. Login as the homeseer user. Then put in

                            mono --version

                            That will give you the mono JIT compiler version.

                            To upgrade Mono on the SEL follow HomeSeer's instruction below. But before doing so make sure to export events using Tools | Setup | Labs and click on Export Event to export it to a file on the HomeSeer. And after mono is upgraded and verified that version is 5.x use the Tools | Setup | Labs and click on Import Events to import it back. Otherwise all even triggers will be gone and you cannot edit to get it back. You have to create new ones.

                            Here's HomeSeer's own instruction on upgrade Mono

                            https://helpdesk.homeseer.com/articl...-sel-to-mono-5

                            It is probably better to perform the Mono upgrade using putty over ssh than using Linux tools over the web.

                            You can download putty client from https://www.chiark.greenend.org.uk/~...ty/latest.html

                            SSH to your homeseer and login as the same homeseer user. Then execute all the commands in the putty console instead of using Linux tools.

                            The mono version if you upgrade now should be

                            Mono JIT compiler version 5.18.0.225 (tarball Wed Jan 2 21:25:26 UTC 2019)

                            Comment


                            • #59
                              Hi Folks,

                              Where do we stand on this, now... I've been out of town and out of touch for over 2 weeks. My understanding is that .210 doesn't fix the issue after 1/1/2019 and I note that there is a new beta, which I have downloaded and installed. Am I good to go or do I still need to do something with the Harmony Hub?
                              HomeSeer Version: HS3 Pro Edition 3.0.0.500
                              Operating System: Microsoft Windows 10 Pro - Work Station

                              Enabled Plug-Ins:
                              2.1.0.119: AmbientWeather | 3.0.21.0: BLLock | 2.0.24.0: BLUPS | 1.3.6.0: Device History | 3.0.0.56: EasyTrigger | 3.1.0.7: MeiHarmonyHub | 3.0.6681.34300: UltraCID3 | 3.0.6644.26753: UltraLog3 | 3.0.6554.33094: UltraMon3 | 3.0.0.91: weatherXML | 3.0.1.245: Z-Wave | 3.0.51: HS Touch Designer | 3.0.0.40 Z-Seer+

                              Comment


                              • #60
                                Originally posted by ewkearns View Post
                                Hi Folks,

                                Where do we stand on this, now... I've been out of town and out of touch for over 2 weeks. My understanding is that .210 doesn't fix the issue after 1/1/2019 and I note that there is a new beta, which I have downloaded and installed. Am I good to go or do I still need to do something with the Harmony Hub?
                                This should still work. .210 is still working for me locally. I didn't even know there was a new beta, but I will look into it.

                                Logitech is supposed to roll this back into their main releases again (from my understanding). I don't know of we'll need to do anything or of updates will roll out automatically once it is mainstream again. I'm hoping they are smart about it.
                                Thanks,
                                Frank

                                Comment

                                Working...
                                X