Announcement

Collapse
No announcement yet.

2/15/19 - New Firmware for Hubs available which may break plugin until you do this...

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    2/15/19 - New Firmware for Hubs available which may break plugin until you do this...


    Logitech added in the ability to opt in to XMPP. The firmware released today will break the plugin until you do the following:

    In HS3: Make sure you are running version 3.1.012 or later. This is currently in the Beta section of the updater.

    On your Harmony Hub:

    Note: See this article on how to check which firmware version you are on - https://support.myharmony.com/how-to...-your-firmware



    By default, Harmony firmware will keep XMPP disabled. For those of you already using the special firmware version 4.15.210 with XMPP access, when your hub upgrades to 4.15.250, you can easily re-enable it by:



    • Perform a sync from your LCD screen based Harmony remote, by going to Menu > Settings > Sync Remote, or



    • From your Harmony app, go to: Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP

    Full announcement:

    Update to accessing Harmony Hub’s local API via XMPP

    Hello folks,



    I am here with an update regarding Harmony XMPP access.



    Back in December 2018, Harmony released a firmware update that addressed several security vulnerabilities - including disabling access to the Hub’s local API via XMPP. After hearing the frustrations from some members of our community, we paused on our firmware update while we assessed the situation. An optional firmware, version 4.15.210, was then created and uploaded onto a MyHarmony tool that allowed for manual installation. This version allowed access to XMPP only for those that wanted it and understood the potential risks of the use of the option. Ultimately we decided to continue this support and make this access available as an opt-in option for firmware versions going forward.



    We’re pleased to announce that beginning with firmware version 4.15.250 and Harmony app version 5.6 for iOS and Android, the option to enable XMPP can now be found in the mobile app settings. We plan to roll out this new firmware starting this Friday, February 15, 2019.



    Note: See this article on how to check which firmware version you are on - https://support.myharmony.com/how-to...-your-firmware



    By default, Harmony firmware will keep XMPP disabled. For those of you already using the special firmware version 4.15.210 with XMPP access, when your hub upgrades to 4.15.250, you can easily re-enable it by:



    • Perform a sync from your LCD screen based Harmony remote, by going to Menu > Settings > Sync Remote, or



    • From your Harmony app, go to: Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP



    You will not need to use the cumbersome firmware update process as you did in December. If you experience any issues, please let us know. Going forward, future firmware updates will respect your current setting, so this should be a one-time action on your part. Should you encounter any issues, please let us know here.





    DISCLAIMER:

    By enabling XMPP connection you are disabling a critical security feature required to safeguard you against vulnerabilities. This connection may create an unsecured local access point vulnerable to be hacked. We recommend all users disable this connection.



    By enabling the XMPP connection, you expressly assume risks and exposures to your network and all connected devices. Further, enabling this connection and/or making unauthorized modifications to Logitech software, you void all warranty and agree to hold Logitech harmless from any claim arising from your use of this product and in no event shall Logitech be liable for any direct, indirect, punitive, incidental, special or consequential damages arising out of or connected with the use or misuse of any of its products.
    (source: https://community.logitech.com/s/que...l-api-via-xmpp)
    MeiAutomtion Home

    #2
    Well, at least they gave a few hours notice this time...

    Comment


      #3
      Originally posted by joegr View Post
      Well, at least they gave a few hours notice this time...
      would have been nice if they could see the previous firmware version and determine if they should set that setting after the upgrade if it was on the beta before.
      MeiAutomtion Home

      Comment


        #4
        Thanks for the heads up on this sirmeili
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


          #5
          Anybody gotten this to work after the update? I only get "AuthToken swap failed."

          Tried both with version 3.1.0.6 and 3.1.0.8

          Comment


            #6
            My hubs haven't updated to .250 yet. They are still on 206. The android app does have the new setting, and I've set that to enabled. For now I have the plugin disabled.

            Comment


              #7
              Per the above I went into settings for both my hubs and enabled the XMPP API. Prior to doing this I did not check my version of the software. Afterwards I synced my hubs. Then I checked the software version. It stayed at 4.15.210 and didn't update to .250.

              I am hopeful as is mterry63 that by choosing to enable the XMPP API in settings that when the hub does update to .250 I won't have any problems.

              Comment


                #8
                Originally posted by cfrudolphy View Post
                Per the above I went into settings for both my hubs and enabled the XMPP API. Prior to doing this I did not check my version of the software. Afterwards I synced my hubs. Then I checked the software version. It stayed at 4.15.210 and didn't update to .250.

                I am hopeful as is mterry63 that by choosing to enable the XMPP API in settings that when the hub does update to .250 I won't have any problems.
                I hope you have more luck than me. My hub was already on .250 and it just won't connect.

                Comment


                  #9
                  Originally posted by torerikk View Post

                  I hope you have more luck than me. My hub was already on .250 and it just won't connect.
                  Have you tried reverting to .210? Not a optimal long term solution but none of my hubs have updated yet. I'll try and force my test hub tonight.

                  Sent from my Pixel 2 XL using Tapatalk

                  MeiAutomtion Home

                  Comment


                    #10
                    How do you force an update?


                    Sent from my Pixel 2 using Tapatalk

                    Comment


                      #11
                      Originally posted by mterry63 View Post
                      How do you force an update?


                      Sent from my Pixel 2 using Tapatalk
                      I try doing a sync from my phone, but that didn't work.

                      Sent from my Pixel 2 XL using Tapatalk

                      MeiAutomtion Home

                      Comment


                        #12
                        I am just getting mine set up and the plugin is not sensing anything from the hub. My hub updated as soon as I opened the software. I enabled XMPP and still not working, so I guess you can add me to the list that aren'e working. Please let us know if you figure out a solution for this.

                        Comment


                          #13
                          Originally posted by cfrudolphy View Post
                          Per the above I went into settings for both my hubs and enabled the XMPP API. Prior to doing this I did not check my version of the software. Afterwards I synced my hubs. Then I checked the software version. It stayed at 4.15.210 and didn't update to .250.

                          I am hopeful as is mterry63 that by choosing to enable the XMPP API in settings that when the hub does update to .250 I won't have any problems.
                          I did the same for my 3 hubs; currently all are .210

                          Comment


                            #14
                            Originally posted by RGMessick View Post

                            I did the same for my 3 hubs; currently all are .210
                            How do you determine the software version of your hub?

                            Comment


                              #15
                              Mine are still at .210. The IOS app itself says it updated 4 days ago, but it does not show any XMPP option.

                              Comment

                              Working...
                              X