Announcement

Collapse
No announcement yet.

2/15/19 - New Firmware for Hubs available which may break plugin until you do this...

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by MNB View Post
    Question, I initially thought I could perform step 1) which sync the Remote but I was never offered the option of Enable/Disable XMPP, I ended up using my iPad App to perform step 2 as the PC version of Harmony also did not offer the ability to change XMPP am I missing something?

    1) Perform a sync from your LCD screen based Harmony remote, by going to Menu > Settings > Sync Remote, or
    2) From your Harmony app, go to:
    Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP
    both of my HUBs had updated to v.250 and indicated that XMPP was enabled but I noticed that the PI did not recognized one of my hub (got a bunch of error messages) so I basically disabled and re-enabled both Hubs and am now up and running without the previous errors..

    I used the "Discover Hubs" button which found both hubs, it was interesting to note that the previous hub Ids had dashes amongst the various alpha numeric (kind of MAC address style) the new update has both removed those dashes and the ID seems to have changed and is slightly longer - general observation, Mike
    Correct. I have a fix that I'm about to release which will auto run the discover on startup and adjust the IDs so that you don't lose your settings and don't have duplicate hubs.
    MeiAutomtion Home

    Comment


      #32
      Please note that you must be running 3.1.0.12 or later. 3.1.0.12 is currently in the Beta section of the Updater. Once a few people check it out and verify everything is working, I will release it as a production release.
      MeiAutomtion Home

      Comment


        #33
        My hubs finally updated to .250 and I loaded 3.1.0.12. I wound up deleting all my hubs and adding them again, but the PI had been dead for me since 206 rolled out, and I never bothered to update to 210. I had set the XMPP option to enabled in the Android app prior to the .250 upgrade and it was enabled after the upgrade.

        Everything seems to be working, I controlled activities and devices on 2 of my 3 hubs. My wife was watching TV on the 3rd so I elected not to poke that bear I'm sure it's fine as well.

        Nice to have everything back up and running, I have a few events in mind. My DirecTV Now App doesn't remember to select favorites when it starts on the Roku, I can set it programmatically now.

        I can also setup some Alexa routines for selecting channels by voice. These IP based TV apps are a pain without channel numbers.

        Comment


          #34
          Originally posted by sirmeili View Post
          Please note that you must be running 3.1.0.12 or later. 3.1.0.12 is currently in the Beta section of the Updater. Once a few people check it out and verify everything is working, I will release it as a production release.
          After updating the plugin to 3.1.012 everything seems to be working again. Thanks!

          Comment


            #35
            After updating hub firmware to 4.15.250 and plugin to 3.1.0.12. connecting and sending commands to the hub from HomeSeer works again. Unfortunately that seems not the case for activity detection. Changing activity trough the remote does not get picked up by the plugin unless i manually disable/enable the plugin.

            Downgrading the hub firmware back to .210 made activity detection (my main use for the plugin) work again.

            Comment


              #36
              Originally posted by Blob View Post
              After updating hub firmware to 4.15.250 and plugin to 3.1.0.12. connecting and sending commands to the hub from HomeSeer works again. Unfortunately that seems not the case for activity detection. Changing activity trough the remote does not get picked up by the plugin unless i manually disable/enable the plugin.

              Downgrading the hub firmware back to .210 made activity detection (my main use for the plugin) work again.
              I will run some tests tonight to see if I can reproduce.
              MeiAutomtion Home

              Comment


                #37
                Originally posted by Blob View Post
                After updating hub firmware to 4.15.250 and plugin to 3.1.0.12. connecting and sending commands to the hub from HomeSeer works again. Unfortunately that seems not the case for activity detection. Changing activity trough the remote does not get picked up by the plugin unless i manually disable/enable the plugin.

                Downgrading the hub firmware back to .210 made activity detection (my main use for the plugin) work again.
                I am testing now but I too believe there is something wrong relating to activities. Numerous errors in HomeSeer Log.

                Comment


                  #38
                  So I downgraded my hubs to .210 and re-enable the firewall rules I had set to block internet access and prevent auto update. I am on plugin version 3.1.0.12 and everything seems to work as before, no HomeSeer Log errors. Something must have changed in hub firmware .250 Blocking internet access to the hubs is not ideal long term but at least it works for now!

                  Comment


                    #39
                    I updated the beta but didn't have to do anything on the Harmony app. Seems to be working ok which is good because I constantly have issues with the phone app connecting to the hub. It's endless!!!
                    HSPro on a Supermicro Atom|Z-Net
                    Elo touchscreen client, Android Phones and Tablets, Xbox One
                    Global Cach/Ultra-GCIR | Etherrain | Jon00 | Sonos | Blue Iris | URC Whole Home Remotes | Philips Hue | Nest | Grandstream | Leviton | Aeon Labs | Cooper | Kwikset | Evolve | Envisalink/DSC | Amazon Alexa/IFTT

                    Comment


                      #40
                      Originally posted by Mario23 View Post
                      I updated the beta but didn't have to do anything on the Harmony app. Seems to be working ok which is good because I constantly have issues with the phone app connecting to the hub. It's endless!!!
                      Had the same issue, I did the synchronisation on the iphone apps and it did work after.

                      Comment


                        #41
                        Originally posted by DMT View Post
                        So I downgraded my hubs to .210 and re-enable the firewall rules I had set to block internet access and prevent auto update. I am on plugin version 3.1.0.12 and everything seems to work as before, no HomeSeer Log errors. Something must have changed in hub firmware .250 Blocking internet access to the hubs is not ideal long term but at least it works for now!
                        Did you enable the XMPP communication in the phone app as described above? I also believe you need to do a sync afterwards (My hub did that automatically after enabling XMPP though)
                        MeiAutomtion Home

                        Comment


                          #42
                          Originally posted by DMT View Post

                          I am testing now but I too believe there is something wrong relating to activities. Numerous errors in HomeSeer Log.
                          If possible can you turn on debug logging, reproduce the errors and send me the logs ([HS3 install dir]/Logs/MeiHarmonyHubYYYYMMDD.log (where YYYYMMDD is the date))
                          MeiAutomtion Home

                          Comment


                            #43
                            I too have enabled XMPP but still am unable to connect with the plug-in - Add me to the list of not functioning....AGAIN !

                            Comment


                              #44
                              Originally posted by sirmeili View Post

                              Did you enable the XMPP communication in the phone app as described above? I also believe you need to do a sync afterwards (My hub did that automatically after enabling XMPP though)
                              Yes, I had enabled XMPP prior to the hub updating to .250 and yes, a sync is automatically initiated next time you touch the remote.

                              Comment


                                #45
                                Originally posted by sirmeili View Post

                                If possible can you turn on debug logging, reproduce the errors and send me the logs ([HS3 install dir]/Logs/MeiHarmonyHubYYYYMMDD.log (where YYYYMMDD is the date))
                                I will let one of my hubs update again later and turn on debugging. Many thanks for your help.

                                Comment

                                Working...
                                X