Announcement

Collapse
No announcement yet.

2/15/19 - New Firmware for Hubs available which may break plugin until you do this...

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #76
    Originally posted by Blob View Post

    Found any hints in de log?
    Can you do me a favor and take a screen shot of hte "General Settings" for the plugin? What I'm looking for is the setting for when you have it set to update the device.
    MeiAutomtion Home

    Comment


      #77
      Originally posted by sirmeili View Post

      Can you do me a favor and take a screen shot of hte "General Settings" for the plugin? What I'm looking for is the setting for when you have it set to update the device.
      I have it set to "On activity start" as this worked great (and still does), except with fw .250. I tried all three settings, but no difference. Activity is still only updated after disconnect/connect.

      Click image for larger version

Name:	2019-03-03_22h08_53.png
Views:	122
Size:	14.2 KB
ID:	1289691

      Comment


        #78
        Ok
        That might be why. I default to when the hub updates it's internal I'd. I will run some tests and see why this no longer works. Hopefully have a fix tonight.

        Sent from my Pixel 2 XL using Tapatalk

        MeiAutomtion Home

        Comment


          #79
          Originally posted by Blob View Post

          I have it set to "On activity start" as this worked great (and still does), except with fw .250. I tried all three settings, but no difference. Activity is still only updated after disconnect/connect.

          Click image for larger version

Name:	2019-03-03_22h08_53.png
Views:	122
Size:	14.2 KB
ID:	1289691
          So it works on mine just fine. Can you go to the activity Device and check for the "Value" in the Status graphics screen for the activity you are expecting to start? According to the logs it should be 13546018.

          I also see that in your logs I get the message that the activity is starting, but my logging for the code that is fired based off that is never run.

          What kind of system are you running this on? (sorry if I already asked this).
          MeiAutomtion Home

          Comment


            #80
            Originally posted by sirmeili View Post

            So it works on mine just fine. Can you go to the activity Device and check for the "Value" in the Status graphics screen for the activity you are expecting to start? According to the logs it should be 13546018.

            I also see that in your logs I get the message that the activity is starting, but my logging for the code that is fired based off that is never run.

            What kind of system are you running this on? (sorry if I already asked this).
            The activity device value looks ok. (seems logical to me, as it updates fine immediaitely after a disconnect/connect)

            Click image for larger version  Name:	2019-03-04_04h06_24.png Views:	1 Size:	6.2 KB ID:	1289779
            Click image for larger version  Name:	2019-03-04_03h46_14.png Views:	1 Size:	9.2 KB ID:	1289776

            I have "HS3 Pro Edition 3.0.0.435" running on "Microsoft Windows 7 Ultimate - Work Station"

            It might be important to keep in mind while diagnosing the problem that when i run both hubs on .210 everything works as expected. If i just enable the firewall rule on my router allowing the hubs to phone home (and don't even touch the HomeSeer system), the hubs automatically update to .250 and the new troublesome activity behavior starts. If I then only flash the hubs back to .210 everything starts working again

            Comment


              #81
              Originally posted by Blob View Post

              The activity device value looks ok. (seems logical to me, as it updates fine immediaitely after a disconnect/connect)

              Click image for larger version Name:	2019-03-04_04h06_24.png Views:	1 Size:	6.2 KB ID:	1289779
              Click image for larger version Name:	2019-03-04_03h46_14.png Views:	1 Size:	9.2 KB ID:	1289776

              I have "HS3 Pro Edition 3.0.0.435" running on "Microsoft Windows 7 Ultimate - Work Station"

              It might be important to keep in mind while diagnosing the problem that when i run both hubs on .210 everything works as expected. If i just enable the firewall rule on my router allowing the hubs to phone home (and don't even touch the HomeSeer system), the hubs automatically update to .250 and the new troublesome activity behavior starts. If I then only flash the hubs back to .210 everything starts working again
              I will be PMing you shortly.
              MeiAutomtion Home

              Comment


                #82
                I'm running into the exact same issues as Blob. On latest .250, XMPP is enabled but activity is not updating except for connect/disconnect.

                Comment


                  #83
                  Originally posted by guppstir View Post
                  I'm running into the exact same issues as Blob. On latest .250, XMPP is enabled but activity is not updating except for connect/disconnect.
                  What do you have set for "Update Activity Device:" in the general settings of the plugin? Do you also have it set to "On Activity Start"?

                  Edit: Is it possible that your firewall is blocking the discovery process? If you have a hub that is on .250, you can open the settings file (/Config/MeiHarmonyHub/HSPI_MeiHarmonyHubs_KnownHubs.json) and for any updated hubs, the format for the UniqueId shoudl be a 40 character alpha numeric string. If it is the old format it will be a 36 character string with 4 dashes and the rest alpha numeric in this format xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx.
                  MeiAutomtion Home

                  Comment


                    #84
                    Originally posted by Blob View Post

                    The activity device value looks ok. (seems logical to me, as it updates fine immediaitely after a disconnect/connect)

                    Click image for larger version Name:	2019-03-04_04h06_24.png Views:	1 Size:	6.2 KB ID:	1289779
                    Click image for larger version Name:	2019-03-04_03h46_14.png Views:	1 Size:	9.2 KB ID:	1289776

                    I have "HS3 Pro Edition 3.0.0.435" running on "Microsoft Windows 7 Ultimate - Work Station"

                    It might be important to keep in mind while diagnosing the problem that when i run both hubs on .210 everything works as expected. If i just enable the firewall rule on my router allowing the hubs to phone home (and don't even touch the HomeSeer system), the hubs automatically update to .250 and the new troublesome activity behavior starts. If I then only flash the hubs back to .210 everything starts working again
                    ** PROBLEM SOLVED

                    Thanks to Sirmeili's great support we now know it had to do with the device Technology Address still being in the old format (with dashes).
                    Luckily the plugin already has a way to fix this with a just few simple steps:
                    1. Take a full backup of your settings (I did not need it, but just in case)
                    2. In hub management add another hub with the same IP address
                    3. A button called "Fix UID" will appear.
                    4. Press it. This should copy all the settings from the old hub to the new one at the same IP and remove the extra hub.

                    Everything running smooth now. I'm verry happy. Thanks Sirmeili

                    Comment


                      #85
                      Originally posted by Blob View Post

                      ** PROBLEM SOLVED

                      Thanks to Sirmeili's great support we now know it had to do with the device Technology Address still being in the old format (with dashes).
                      Luckily the plugin already has a way to fix this with a just few simple steps:
                      1. Take a full backup of your settings (I did not need it, but just in case)
                      2. In hub management add another hub with the same IP address
                      3. A button called "Fix UID" will appear.
                      4. Press it. This should copy all the settings from the old hub to the new one at the same IP and remove the extra hub.

                      Everything running smooth now. I'm verry happy. Thanks Sirmeili
                      I'm supper happy that fixed it for you.

                      just for some background:

                      I use a new discovery process on plugin start up to find hubs. If it finds a hub with the same IP, but the new UID format and there is an existing hub with the old format, I copy over the settings from the old device to a new one and save it. The only time this won't work is if for some reason Discovery is blocked by a firewall or another reason.

                      I tried to automate the "fix" for the change in UIDs on the hubs, but I guess it's not going to work for everyone (which is why I left the manual fix in place )
                      MeiAutomtion Home

                      Comment


                        #86
                        That fixed it! Thanks for your support. I followed Blob's instructions! I had the old format in there.

                        Comment


                          #87
                          Originally posted by sirmeili View Post

                          I'm supper happy that fixed it for you.

                          just for some background:

                          I use a new discovery process on plugin start up to find hubs. If it finds a hub with the same IP, but the new UID format and there is an existing hub with the old format, I copy over the settings from the old device to a new one and save it. The only time this won't work is if for some reason Discovery is blocked by a firewall or another reason.

                          I tried to automate the "fix" for the change in UIDs on the hubs, but I guess it's not going to work for everyone (which is why I left the manual fix in place )
                          This is more of a feature request...
                          How difficult would it be to add something that would allow the user (me) to replace an existing hub with a previously unused one? I think that Logitech makes it possible to copy the programming from one hub to another, but even if I put it at the same IP address, it would have a different ID, and the existing hub already has the new ID format.

                          Alternately, is there an easy way to edit the plug-in config/data files to accomplish this?

                          Comment


                            #88
                            I was planning on adding a Harmony remote and hub this weekend and connecting it with HS3. It seems like things will not work as seamlessly as I has hoped. Should I stay away from the whole thing due to functionality and security concerns? I’m a HS newbie and just want reliability, not more ongoing ‘projects’ and concerns.


                            Sent from my iPad using Tapatalk

                            Comment


                              #89
                              Originally posted by wiegmanc View Post
                              I was planning on adding a Harmony remote and hub this weekend and connecting it with HS3. It seems like things will not work as seamlessly as I has hoped. Should I stay away from the whole thing due to functionality and security concerns? I’m a HS newbie and just want reliability, not more ongoing ‘projects’ and concerns.
                              This is an excellent reliable plugin. The problems were caused by Logitech decided to discontinue older protocol support (XMPP). Thanks god they did listen to our complaints and changed their mind. And the developer of this plugin sirmeili who put a lot of time and effort to implement changes introduced by Logitech.

                              Comment


                                #90
                                I’m happy to hear it’s reliable and the issue was on Logitech’s end. What about the security concerns outlined in the disclaimer, is this typical and has this always been a concern common to our type of unintended use? Should I be concerned?

                                Here’s the Disclaimer..

                                DISCLAIMER:
                                By enabling XMPP connection you are disabling a critical security feature required to safeguard you against vulnerabilities. This connection may create an unsecured local access point vulnerable to be hacked. We recommend all users disable this connection.

                                By enabling the XMPP connection, you expressly assume risks and exposures to your network and all connected devices. Further, enabling this connection and/or making unauthorized modifications to Logitech software, you void all warranty and agree to hold Logitech harmless from any claim arising from your use of this product and in no event shall Logitech be liable for any direct, indirect, punitive, incidental, special or consequential damages arising out of or connected with the use or misuse of any of its products


                                Sent from my iPad using Tapatalk

                                Comment

                                Working...
                                X