Announcement

Collapse
No announcement yet.

MeiHarmonyHub version 3.1.0.9 (Beta) is now available!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MeiHarmonyHub version 3.1.0.9 (Beta) is now available!

    MeiHarmonyHub v3.1.0.9 is now available in the HomeSeer store and in the updater (Beta Section)!

    The following are included:
    • Code Cleanup
    • Fixed issue with Logitech's newest update to XMPP in firmware .250
    PLEASE NOTE THAT i HAVEN'T FULLY TESTED THIS RELEASE FROM MY CODE CLEANUP. I AM RELEASING IT BECAUSE LOGITECH MADE A CHANGE IN THE NEWEST FIRMWARE AND I WANTED TO GET A FIX OUT FAST. THIS IS TRULY BETA. THE MORE PEOPLE THAT TEST THE BETTER.

    Please see the full descriptions here:
    https://forums.homeseer.com/showthread.php?t=194095

    Release notes Here:
    https://forums.homeseer.com/showthread.php?t=194096

    Request new Features Here:
    https://forums.homeseer.com/showthread.php?t=194097
    MeiAutomtion Home

  • #2
    I get this error installing the beta and the plugin is now completely gone in the list of plugins
    Feb-18 11:25:56 Error Error, Class not found in plugin EXE, maybe namespace is not correct,? Note filename is case sensitive!: HSPI_MeiHarmonyHub.exe Class: HSPI_MeiHarmonyHub.HSPI->
    Cheers,
    Bob
    Web site | Help Desk | Feature Requests | Message Board

    Comment


    • #3
      Well, this is interesting.
      I had the plugin disabled (usually a good idea before updating any plugin anyway) when I updated to 3.1.0.9
      Now, the plugin is no longer listed on the plugin manage screen, so I can't enable it. When I look at the list of additional interfaces, it shows 3.1.0.9 in the installed column for your released and your beta plugins.

      The log didn't indicate anything wrong with the install. I am on HS Pro version 3.0.0.500
      Feb-18 10:19:39 AM Updater Install/Update of package MeiHarmonyHub was successful.
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\html\images\MeiHarmonyHub\Status\remote-icon-rotated.png
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\html\images\MeiHarmonyHub\remote-icon-rotated.png
      Feb-18 10:19:39 AM Updater Warning File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Config\MeiHarmonyHub\HSPI_MeiHarmonyHubs_KnonwHubs.json
      Feb-18 10:19:39 AM Updater Warning File exists, not overwriting: C:\Program Files (x86)\HomeSeer HS3\Config\MeiHarmonyHub\HSPI_MeiHarmonyHubs_Settings.json
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\MeiHarmonyHub\Newtonsoft.Json.dll
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\MeiHarmonyHub\Serilog.Sinks.File.dll
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\MeiHarmonyHub\Serilog.dll
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\MeiHarmonyHub\MBPlugins.dll
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\bin\MeiHarmonyHub\CommandLine.dll
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_MeiHarmonyHub.exe.config
      Feb-18 10:19:39 AM Updater Copying file: C:\Program Files (x86)\HomeSeer HS3\HSPI_MeiHarmonyHub.exe
      Feb-18 10:19:39 AM Updater Installing package MeiHarmonyHub
      Feb-18 10:19:39 AM Updater Update hspi_meiharmonyhub.exe downloaded successfully
      Feb-18 10:19:39 AM Updater Downloading update: MeiHarmonyHub
      Feb-18 10:19:39 AM Updater Starting download of updates
      I rather wait till I am home to try a restart of HS.

      Oh, I did get the error mentioned above too. I had thought it related to another plugin that I enabled by mistake.
      Feb-18 10:19:40 AM Error Error, Class not found in plugin EXE, maybe namespace is not correct,? Note filename is case sensitive!: HSPI_MeiHarmonyHub.exe Class: HSPI_MeiHarmonyHub.HSPI->

      Comment


      • #4
        working on it.....
        MeiAutomtion Home

        Comment


        • #5
          Fixed. Please install 3.1.0.10
          MeiAutomtion Home

          Comment

          Working...
          X